summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenat Lumpau <rl03@gentoo.org>2004-08-18 16:52:00 +0000
committerRenat Lumpau <rl03@gentoo.org>2004-08-18 16:52:00 +0000
commitcebc1bcd0e9b787e31e9e29aa2423842b5f70f81 (patch)
treeacb27187942bb9940859edc7c13b510bf09e466e /dev-util/cvsweb/cvsweb-3.0.1.ebuild
parentAdded the 4.1.2-r5 and 4.2-r1 xml-dtd's to use the new build-docbook-catalog ... (diff)
downloadgentoo-2-cebc1bcd0e9b787e31e9e29aa2423842b5f70f81.tar.gz
gentoo-2-cebc1bcd0e9b787e31e9e29aa2423842b5f70f81.tar.bz2
gentoo-2-cebc1bcd0e9b787e31e9e29aa2423842b5f70f81.zip
Version bump (bug #43546)
Diffstat (limited to 'dev-util/cvsweb/cvsweb-3.0.1.ebuild')
-rw-r--r--dev-util/cvsweb/cvsweb-3.0.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/cvsweb/cvsweb-3.0.1.ebuild b/dev-util/cvsweb/cvsweb-3.0.1.ebuild
new file mode 100644
index 000000000000..9bd43bfacb17
--- /dev/null
+++ b/dev-util/cvsweb/cvsweb-3.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvsweb/cvsweb-3.0.1.ebuild,v 1.1 2004/08/18 16:52:00 rl03 Exp $
+
+inherit webapp
+
+KEYWORDS="~x86 ~sparc ~ppc"
+LICENSE="BSD"
+DESCRIPTION="WWW interface to a CVS tree"
+SRC_URI="ftp://ftp.freebsd.org/pub/FreeBSD/ports/local-distfiles/scop/${P}.tar.gz"
+HOMEPAGE="http://www.freebsd.org/projects/cvsweb.html"
+IUSE=""
+
+DEPEND="$DEPEND"
+RDEPEND=">=dev-lang/perl-5.8
+ >=dev-util/cvs-1.11
+ >=app-text/rcs-5.7
+ >=dev-perl/URI-1.28
+ dev-perl/IPC-Run
+ dev-perl/MIME-Types
+ dev-perl/String-Ediff
+ >=dev-util/cvsgraph-1.4.0
+ >=app-text/enscript-1.6.3
+"
+
+src_install() {
+ webapp_src_preinst
+
+ cp cvsweb.conf ${D}/${MY_HOSTROOTDIR}
+ cp css/cvsweb.css ${D}/${MY_HTDOCSDIR}
+ exeinto ${MY_CGIBINDIR}
+ doexe cvsweb.cgi
+
+ dodoc README TODO NEWS ChangeLog
+
+ webapp_hook_script ${FILESDIR}/reconfig
+ webapp_postinst_txt en ${FILESDIR}/postinstall-en.txt
+ webapp_src_install
+}