summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarald van Dijk <truedfx@gentoo.org>2005-11-20 19:07:00 +0000
committerHarald van Dijk <truedfx@gentoo.org>2005-11-20 19:07:00 +0000
commit74b537e85f854011c4f043ed347ee49ea8b4d2b4 (patch)
tree0f825752e601cf81ebd089c6a981dc7fbdd3ebdd /dev-util/dialog/dialog-1.0.20051107.ebuild
parentstable on amd64 wrt bug 112482 (diff)
downloadgentoo-2-74b537e85f854011c4f043ed347ee49ea8b4d2b4.tar.gz
gentoo-2-74b537e85f854011c4f043ed347ee49ea8b4d2b4.tar.bz2
gentoo-2-74b537e85f854011c4f043ed347ee49ea8b4d2b4.zip
version bump + bug #112024
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'dev-util/dialog/dialog-1.0.20051107.ebuild')
-rw-r--r--dev-util/dialog/dialog-1.0.20051107.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-util/dialog/dialog-1.0.20051107.ebuild b/dev-util/dialog/dialog-1.0.20051107.ebuild
new file mode 100644
index 000000000000..45f07c2533cf
--- /dev/null
+++ b/dev-util/dialog/dialog-1.0.20051107.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dialog/dialog-1.0.20051107.ebuild,v 1.1 2005/11/20 19:07:00 truedfx Exp $
+
+inherit eutils
+
+MY_PV="${PV/1.0./1.0-}"
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="tool to display dialog boxes from a shell"
+HOMEPAGE="http://invisible-island.net/dialog/dialog.html"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${PN}_${MY_PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="unicode"
+
+DEPEND=">=app-shells/bash-2.04-r3
+ >=sys-libs/ncurses-5.2-r5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-mouseselect.patch
+}
+
+src_compile() {
+ #export LANG=C
+ use unicode && ncursesw="w"
+ econf "--with-ncurses${ncursesw}" || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc CHANGES README VERSION
+
+ docinto samples
+ dodoc samples/*
+}