summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-03-03 15:12:44 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-03-03 15:12:44 +0000
commit29019b7c8a72fb99331760f166e6e78edf96af44 (patch)
treece1a768ba6b25772d208263e7e75a25d6a8524fa /dev-util/dwarves/dwarves-1.10-r1.ebuild
parentCheck for tgetent instead of initscr from the termcap library; check for -lti... (diff)
downloadgentoo-2-29019b7c8a72fb99331760f166e6e78edf96af44.tar.gz
gentoo-2-29019b7c8a72fb99331760f166e6e78edf96af44.tar.bz2
gentoo-2-29019b7c8a72fb99331760f166e6e78edf96af44.zip
fix bug 423817
(Portage version: 2.2.0_alpha164/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-util/dwarves/dwarves-1.10-r1.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-1.10-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.10-r1.ebuild b/dev-util/dwarves/dwarves-1.10-r1.ebuild
new file mode 100644
index 000000000000..c640afaa23f1
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.10-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/dwarves-1.10-r1.ebuild,v 1.1 2013/03/03 15:12:43 hasufell Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+inherit multilib cmake-utils python-single-r1
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/acme/pahole.git;a=summary"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND="${PYTHON_DEPS}
+ >=dev-libs/elfutils-0.131
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV//_p} == ${PV} ]]; then
+ SRC_URI="http://fedorapeople.org/~acme/dwarves/${P}.tar.bz2"
+ S=${WORKDIR}
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+fi
+
+DOCS=( README README.ctracer NEWS )
+PATCHES=( "${FILESDIR}"/${P}-python-import.patch )
+
+src_configure() {
+ local mycmakeargs=( "-D__LIB=$(get_libdir)" )
+ cmake-utils_src_configure
+}
+
+src_test() { :; }
+
+src_install() {
+ cmake-utils_src_install
+ python_fix_shebang "${D}"/usr/bin/ostra-cg \
+ "${D}"/usr/share/dwarves/runtime/python/ostra.py
+}