summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-07-16 23:17:46 +0000
committerBen de Groot <yngwin@gentoo.org>2008-07-16 23:17:46 +0000
commit3e3fb8b84b01eddb7fe00ad9caf3f4ba841a62e5 (patch)
tree5fe8dd2a939ed45330cdb7c5a51d3efad0b5f44c /dev-util/eric
parentwhitespace (diff)
downloadgentoo-2-3e3fb8b84b01eddb7fe00ad9caf3f4ba841a62e5.tar.gz
gentoo-2-3e3fb8b84b01eddb7fe00ad9caf3f4ba841a62e5.tar.bz2
gentoo-2-3e3fb8b84b01eddb7fe00ad9caf3f4ba841a62e5.zip
eric version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-hh7 i686)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog7
-rw-r--r--dev-util/eric/eric-4.1.6.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 44a8499738ec..0f427a5f5643 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.62 2008/07/16 22:36:38 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.63 2008/07/16 23:17:46 yngwin Exp $
+
+*eric-4.1.6 (16 Jul 2008)
+
+ 16 Jul 2008; Ben de Groot <yngwin@gentoo.org> +eric-4.1.6.ebuild:
+ Version bump
16 Jul 2008; Ben de Groot <yngwin@gentoo.org> eric-4.0.4.ebuild,
eric-4.1.1.ebuild:
diff --git a/dev-util/eric/eric-4.1.6.ebuild b/dev-util/eric/eric-4.1.6.ebuild
new file mode 100644
index 000000000000..ed4d9223c6bc
--- /dev/null
+++ b/dev-util/eric/eric-4.1.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.1.6.ebuild,v 1.1 2008/07/16 23:17:46 yngwin Exp $
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_fr linguas_ru"
+
+DEPEND="dev-python/PyQt4
+ >=dev-python/qscintilla-python-2.1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de fr ru"
+
+python_version
+
+pkg_setup() {
+ if ! built_with_use 'dev-python/qscintilla-python' 'qt4'; then
+ eerror "Please build qscintilla-python with qt4 useflag."
+ die "qscintilla-python built without qt4."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/4.1.4-paths.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}