summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-03-07 20:32:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-03-07 20:32:30 +0000
commitd99c7b860874a3f532b348fbdf6f01f7eb74228d (patch)
tree3b59c080651e6e38501d99e7727c6e4c6e25bb6b /dev-util/eric
parentMigrate to EAPI 2. (diff)
downloadgentoo-2-d99c7b860874a3f532b348fbdf6f01f7eb74228d.tar.gz
gentoo-2-d99c7b860874a3f532b348fbdf6f01f7eb74228d.tar.bz2
gentoo-2-d99c7b860874a3f532b348fbdf6f01f7eb74228d.zip
Bump to 4.3.1.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog7
-rw-r--r--dev-util/eric/eric-4.3.1.ebuild78
2 files changed, 84 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 53b6c9deb7f6..2d6fb059412a 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.72 2009/02/18 23:56:38 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.73 2009/03/07 20:32:30 patrick Exp $
+
+*eric-4.3.1 (07 Mar 2009)
+
+ 07 Mar 2009; Patrick Lauer <patrick@gentoo.org> +eric-4.3.1.ebuild:
+ Bump to 4.3.1.
18 Feb 2009; Jeroen Roovers <jer@gentoo.org> eric-4.3.0.ebuild:
Marked ~hppa too.
diff --git a/dev-util/eric/eric-4.3.1.ebuild b/dev-util/eric/eric-4.3.1.ebuild
new file mode 100644
index 000000000000..a1017bdec0b4
--- /dev/null
+++ b/dev-util/eric/eric-4.3.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.1.ebuild,v 1.1 2009/03/07 20:32:30 patrick Exp $
+
+EAPI="2"
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="A full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/eric/index.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_es? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-es-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )
+ linguas_tr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-tr-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_es linguas_fr linguas_ru linguas_tr"
+
+DEPEND="dev-python/PyQt4[svg]
+ >=dev-python/qscintilla-python-2.2[qt4]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de es fr ru tr"
+
+python_version
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ #epatch "${FILESDIR}"/4.3.0-paths.patch
+ epatch "${FILESDIR}"/4.2.3-no-interactive.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}