summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 20:21:54 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-24 20:21:54 +0000
commite0443b3889c458dd7d0bd0005545a2c82fb6f119 (patch)
tree4b583e0661cdf5c4a0db97010b7e925cce57f4bd /dev-util/eric
parentVersion bump. (diff)
downloadgentoo-2-e0443b3889c458dd7d0bd0005545a2c82fb6f119.tar.gz
gentoo-2-e0443b3889c458dd7d0bd0005545a2c82fb6f119.tar.bz2
gentoo-2-e0443b3889c458dd7d0bd0005545a2c82fb6f119.zip
Set SUPPORT_PYTHON_ABIS. Update message in pkg_postinst() (bug #282589).
(Portage version: 14153-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/eric')
-rw-r--r--dev-util/eric/ChangeLog6
-rw-r--r--dev-util/eric/eric-4.3.6.ebuild41
2 files changed, 30 insertions, 17 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 5406b03daa22..a3532c75b69e 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/eric
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.86 2009/08/01 15:00:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.87 2009/08/24 20:21:54 arfrever Exp $
+
+ 24 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ eric-4.3.6.ebuild:
+ Set SUPPORT_PYTHON_ABIS. Update message in pkg_postinst() (bug #282589).
*eric-4.3.6 (01 Aug 2009)
diff --git a/dev-util/eric/eric-4.3.6.ebuild b/dev-util/eric/eric-4.3.6.ebuild
index 118f8408ba30..823eb7126330 100644
--- a/dev-util/eric/eric-4.3.6.ebuild
+++ b/dev-util/eric/eric-4.3.6.ebuild
@@ -1,10 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.6.ebuild,v 1.1 2009/08/01 15:00:33 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.3.6.ebuild,v 1.2 2009/08/24 20:21:54 arfrever Exp $
EAPI="2"
-NEED_PYTHON=2.4
-inherit python eutils
+NEED_PYTHON="2.4"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit eutils python
MY_PN=${PN}4
MY_P=${MY_PN}-${PV}
@@ -28,6 +30,8 @@ DEPEND="dev-python/PyQt4[svg,webkit,X]
>=dev-python/qscintilla-python-2.2[qt4]"
RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3*"
+
S=${WORKDIR}/${MY_P}
LANGS="cs de es fr ru tr"
@@ -40,14 +44,19 @@ src_prepare() {
src_install() {
# Change qt dir to be located in ${D}
- dodir /usr/share/qt4/
- ${python} install.py \
- -z \
- -b "/usr/bin" \
- -i "${D}" \
- -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
- -c || die "python install.py failed"
+ dodir /usr/share/qt4
+ installation() {
+ "$(PYTHON)" install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "$(python_get_sitedir)" \
+ -c
+ }
+ python_execute_function installation
+
+ python_version
make_desktop_entry "eric4 --nosplash" \
eric4 \
"/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
@@ -55,18 +64,18 @@ src_install() {
}
pkg_postinst() {
- python_version
- python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ python_mod_optimize eric4{,config.py,plugins}
+ elog
elog "If you want to use eric4 with mod_python, have a look at"
elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
elog
- elog "The following packages will give eric extended functionality."
- elog
- elog "dev-python/pylint"
- elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog "The following packages will give eric extended functionality:"
+ elog " dev-python/pylint"
+ elog " dev-python/pysvn"
elog
elog "This version has a plugin interface with plugin-autofetch from"
elog "the App itself. You may want to check those as well."
+ elog
}
pkg_postrm() {