summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-06-02 00:13:53 +0000
committerMike Frysinger <vapier@gentoo.org>2005-06-02 00:13:53 +0000
commit84f1bb6157e9b5651bce6be2eb974cbe84414579 (patch)
tree4edeaf88fdd193841f5eaf231b74cb7f61170067 /dev-util/gambas
parentUnmasked x11-wm/wmii. (diff)
downloadgentoo-2-84f1bb6157e9b5651bce6be2eb974cbe84414579.tar.gz
gentoo-2-84f1bb6157e9b5651bce6be2eb974cbe84414579.tar.bz2
gentoo-2-84f1bb6157e9b5651bce6be2eb974cbe84414579.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/gambas')
-rw-r--r--dev-util/gambas/ChangeLog10
-rw-r--r--dev-util/gambas/files/digest-gambas-1.0.61
-rw-r--r--dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch40
-rw-r--r--dev-util/gambas/gambas-1.0.6.ebuild82
4 files changed, 131 insertions, 2 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 6e7d111cf4c2..6eb632a23a85 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gambas
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.28 2005/04/23 13:00:03 genone Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.29 2005/06/02 00:13:53 vapier Exp $
+
+*gambas-1.0.6 (02 Jun 2005)
+
+ 02 Jun 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/gambas-1.0.6-configure-CFLAGS.patch, +gambas-1.0.6.ebuild:
+ Version bump.
*gambas-1.0.5 (23 Apr 2005)
diff --git a/dev-util/gambas/files/digest-gambas-1.0.6 b/dev-util/gambas/files/digest-gambas-1.0.6
new file mode 100644
index 000000000000..ffcf3a1ac4fb
--- /dev/null
+++ b/dev-util/gambas/files/digest-gambas-1.0.6
@@ -0,0 +1 @@
+MD5 608772c93233eea4e488ba3bd1c2ac83 gambas-1.0.6.tar.bz2 4251901
diff --git a/dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch b/dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch
new file mode 100644
index 000000000000..1ede1cb29a93
--- /dev/null
+++ b/dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch
@@ -0,0 +1,40 @@
+--- configure.in
++++ configure.in
+@@ -27601,37 +27601,10 @@
+ CFLAGS="$CFLAGS -pipe -Wall -fno-strict-aliasing"
+ CXXFLAGS="$CXXFLAGS -pipe -Wall -fno-exceptions"
+
+-if test "$gambas_prof" = "yes"; then
+- CFLAGS="$CFLAGS -pg"
+- CXXFLAGS="$CXXFLAGS -pg"
+-
+-# if test "$gambas_optimization" = "yes"; then
+-# echo -e "\n**** Warning: --enable-profiling implies --disable-optimization\n"
+-# gambas_optimization="no";
+-# fi
+-
+-fi
+-
+-if test "$gambas_debug" = "yes"; then
+- CFLAGS="$CFLAGS -g"
+- CXXFLAGS="$CXXFLAGS -g"
+-fi
+-
+ # gambas_flag="-O2 -fstrength-reduce -frerun-loop-opt -fexpensive-optimizations -fschedule-insns2 -funroll-loops"
+ # gambas_flags="$gambas_flags -fno-strict-aliasing -falign-loops=2 -falign-jumps=2"
+ # gambas_flags="$gambas_flags -falign-functions=2 -ffast-math"
+
+-if test "$gambas_prof" = "no"; then
+- gambas_flags="$gambas_flags -fomit-frame-pointer"
+-fi
+-
+-if test "x$gambas_optimization" = "xyes"; then
+- CFLAGS="$CFLAGS -Os"
+- CXXFLAGS="$CXXFLAGS -Os -fno-omit-frame-pointer"
+-else
+- CFLAGS="$CFLAGS -O0"
+- CXXFLAGS="$CXXFLAGS -O0"
+-fi
+
+
+
diff --git a/dev-util/gambas/gambas-1.0.6.ebuild b/dev-util/gambas/gambas-1.0.6.ebuild
new file mode 100644
index 000000000000..706b4a32b02d
--- /dev/null
+++ b/dev-util/gambas/gambas-1.0.6.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-1.0.6.ebuild,v 1.1 2005/06/02 00:13:53 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="a RAD tool for BASIC"
+HOMEPAGE="http://gambas.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gambas/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-*"
+IUSE="postgres mysql sdl doc curl sqlite xml xsl zlib kde bzip2"
+
+RDEPEND=">=x11-libs/qt-3.2
+ kde? ( >=kde-base/kdelibs-3.2 )
+ sdl? ( media-libs/libsdl media-libs/sdl-mixer sys-libs/gpm )
+ mysql? ( dev-db/mysql )
+ postgres? ( dev-db/postgresql )
+ curl? ( net-misc/curl )
+ sqlite? ( dev-db/sqlite )
+ xml? ( dev-libs/libxml2 )
+ xsl? ( dev-libs/libxslt )
+ zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/automake-1.7.5"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-configure-CFLAGS.patch
+
+ # replace braindead Makefile (it's getting better, but
+ # still has the stupid symlink stuff)
+ rm Makefile*
+ cp "${FILESDIR}/Makefile.am-1.0_rc2" ./Makefile.am
+
+ aclocal && autoconf && automake || die "autotools failed"
+}
+
+src_compile() {
+ econf \
+ --enable-qt \
+ --enable-net \
+ --enable-vb \
+ $(use_enable mysql) \
+ $(use_enable postgres) \
+ $(use_enable sqlite) \
+ $(use_enable sdl) \
+ $(use_enable curl) \
+ $(use_enable zlib) \
+ $(use_enable xml libxml) \
+ $(use_enable xsl xslt) \
+ $(use_enable bzip2 bzlib2) \
+ $(use_enable kde) \
+ --disable-optimization \
+ --disable-debug \
+ --disable-profiling \
+ || die
+
+ emake || die
+}
+
+src_install() {
+ export PATH="${D}/usr/bin:${PATH}"
+ make DESTDIR="${D}" install || die
+
+ dodoc README INSTALL NEWS AUTHORS ChangeLog TODO
+
+ # only install the API docs and examples with USE=doc
+ if use doc ; then
+ mv "${D}"/usr/share/${PN}/help "${D}"/usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/${PN}/examples "${D}"/usr/share/doc/${PF}/examples
+ else
+ dohtml ${FILESDIR}/WebHome.html
+ fi
+ rm -r "${D}"/usr/share/${PN}/help "${D}"/usr/share/${PN}/examples
+ dosym ../doc/${PF}/html /usr/share/${PN}/help
+ dosym ../doc/${PF}/examples /usr/share/${PN}/examples
+}