summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-02-10 06:12:49 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-02-10 06:12:49 +0000
commitfeeebbd23e377fd6ef248874ce3abb3c82f298f4 (patch)
tree6146219a9ca862beb5fd70656052493cfd8b0113 /dev-util/gcvs
parentcomment fix closing bug #622 (minor) (diff)
downloadgentoo-2-feeebbd23e377fd6ef248874ce3abb3c82f298f4.tar.gz
gentoo-2-feeebbd23e377fd6ef248874ce3abb3c82f298f4.tar.bz2
gentoo-2-feeebbd23e377fd6ef248874ce3abb3c82f298f4.zip
gcvs 1.0b2: a gui frontend for cvs
Diffstat (limited to 'dev-util/gcvs')
-rw-r--r--dev-util/gcvs/files/digest-gcvs-1.0_beta21
-rw-r--r--dev-util/gcvs/gcvs-1.0_beta2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-util/gcvs/files/digest-gcvs-1.0_beta2 b/dev-util/gcvs/files/digest-gcvs-1.0_beta2
new file mode 100644
index 000000000000..2f29efd455d0
--- /dev/null
+++ b/dev-util/gcvs/files/digest-gcvs-1.0_beta2
@@ -0,0 +1 @@
+MD5 78cac5ec6c3463ece10a9b362b3965f7 gcvs-1.0b2.tar.gz 2975242
diff --git a/dev-util/gcvs/gcvs-1.0_beta2.ebuild b/dev-util/gcvs/gcvs-1.0_beta2.ebuild
new file mode 100644
index 000000000000..4731a6a0795b
--- /dev/null
+++ b/dev-util/gcvs/gcvs-1.0_beta2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gcvs/gcvs-1.0_beta2.ebuild,v 1.1 2002/02/10 06:12:49 blocke Exp $
+
+Z="gcvs-1.0b2"
+S=${WORKDIR}/${Z}
+DESCRIPTION="GUI frontend for CVS from the CVSGUI project"
+SRC_URI="http://prdownloads.sourceforge.net/cvsgui/${Z}.tar.gz"
+HOMEPAGE="http://cvsgui.sourceforge.net/"
+
+DEPEND=">=x11-libs/gtk+-1.2.10 >=dev-lang/tcl-8.3.3 sys-devel/perl sys-devel/bison dev-util/glademm"
+RDEPEND=">=x11-libs/gtk+-1.2.10 >=dev-lang/tcl-8.3.3 >=dev-util/cvs-1.11-r1"
+
+src_compile() {
+
+ ./make_configure || die
+ ./configure --prefix=/usr --host=${CHOST} || die
+
+ # Ladies and Gentlemen... The following is pure evil...
+ export HOME=${S}
+ # Yes, thats right... the build process ends up trying to create
+ # something in root's home directory... why? they use glade,
+ # a full blown gnome gui application to generate source code...
+
+ # more evil... without this it builds its own copy of cvs
+ # which of course installs itself on top of the real cvs package
+ mv Makefile Makefile.old
+ sed 's|cvsunix||g' Makefile.old > Makefile
+
+ emake all || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install
+
+ # note: html docs ignored because they focus on the mac and windows
+ # version and seem to be of questionable use with gcvs
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL README
+
+
+}
+
+