summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-04-04 07:22:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-04-04 07:22:43 +0000
commit694b61b8ecd89a440f87dd317f489cd33f8c5213 (patch)
tree5512807b5d188618e17c3023a081d51370be9732 /dev-util/gitosis-gentoo
parentBlock the fork here too. (diff)
downloadgentoo-2-694b61b8ecd89a440f87dd317f489cd33f8c5213.tar.gz
gentoo-2-694b61b8ecd89a440f87dd317f489cd33f8c5213.tar.bz2
gentoo-2-694b61b8ecd89a440f87dd317f489cd33f8c5213.zip
Specifically package the Gitosis fork that powers git.overlays.gentoo.org. Upstream has not responded to multiple requests to integrate these features.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/gitosis-gentoo')
-rw-r--r--dev-util/gitosis-gentoo/ChangeLog12
-rw-r--r--dev-util/gitosis-gentoo/Manifest4
-rw-r--r--dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild41
-rw-r--r--dev-util/gitosis-gentoo/metadata.xml12
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitosis-gentoo/ChangeLog b/dev-util/gitosis-gentoo/ChangeLog
new file mode 100644
index 000000000000..6a6a64f4d1fe
--- /dev/null
+++ b/dev-util/gitosis-gentoo/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for dev-util/gitosis-gentoo
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/ChangeLog,v 1.1 2008/04/04 07:22:43 robbat2 Exp $
+
+*gitosis-gentoo-0.2_p20080203 (04 Apr 2008)
+
+ 04 Apr 2008; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+ +gitosis-gentoo-0.2_p20080203.ebuild:
+ Specifically package the Gitosis fork that powers git.overlays.gentoo.org.
+ Upstream has not responded to multiple requests to integrate these
+ features.
+
diff --git a/dev-util/gitosis-gentoo/Manifest b/dev-util/gitosis-gentoo/Manifest
new file mode 100644
index 000000000000..f134afcc2768
--- /dev/null
+++ b/dev-util/gitosis-gentoo/Manifest
@@ -0,0 +1,4 @@
+DIST gitosis-gentoo.git-20080203-231e601545d0a09d84d3c5c2786d774f56fe9217.tar.bz2 35661 RMD160 f33f36e6984b9e601d5f632b3ee53b5617351612 SHA1 aad1cfa691274317e610f3621ead49812431f55a SHA256 7672209eb2fbf6960967ba20372bcb269ae2b539c628e6e099f9989884f34c21
+EBUILD gitosis-gentoo-0.2_p20080203.ebuild 1219 RMD160 c83e6ec2998cd1d61d833f46839f32c7f5f080aa SHA1 0ec6fa92cf95e7cd57f150dc8356628293dc5b74 SHA256 61caa913ffc72fba07313ad56dbcc800009d1dcb56763a42427fe265a9669779
+MISC ChangeLog 436 RMD160 b49aec4f93f5f539fd4bcd9630fdd88f0998cd18 SHA1 6783bcce67f9f88aa3496ef7becb43ac3f108f7c SHA256 41a53b8b82b6e835c0bf5264ce3584e82aabb293dd380991794b8f2dc48ecf77
+MISC metadata.xml 377 RMD160 74cab863bd42cd43f0c07276c4be096e5fa38291 SHA1 c05576f5fc0e51708a151d73f8db0f04d3d36f8c SHA256 ea6084f3ae1cc0247c58bceae2259e7eb800e94f39678c2d004cfd4ae6c42b70
diff --git a/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
new file mode 100644
index 000000000000..1d471e084525
--- /dev/null
+++ b/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gitosis-gentoo/gitosis-gentoo-0.2_p20080203.ebuild,v 1.1 2008/04/04 07:22:43 robbat2 Exp $
+
+inherit distutils
+
+DESCRIPTION="gitosis -- software for hosting git repositories, Gentoo fork"
+HOMEPAGE="http://git.overlays.gentoo.org/gitweb/?p=proj/gitosis-gentoo.git"
+# This is a snapshot taken from the Gentoo overlays gitweb.
+MY_PV="20080203-231e601545d0a09d84d3c5c2786d774f56fe9217"
+MY_PN="${PN}.git"
+MY_P="${MY_PN}-${MY_PV}"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc"
+IUSE=""
+DEPEND=">=dev-util/git-1.5.3.6
+ >=dev-python/setuptools-0.6_rc5"
+RDEPEND="${DEPEND}
+ !dev-util/gitosis"
+
+S=${WORKDIR}/gitosis-gentoo
+
+DOCS="example.conf gitweb.conf lighttpd-gitweb.conf TODO.rst"
+
+pkg_setup() {
+ enewgroup git
+ enewuser git -1 /bin/sh /var/spool/gitosis git
+}
+
+src_install() {
+ distutils_src_install
+ keepdir /var/spool/gitosis
+ fowners git:git /var/spool/gitosis
+}
+
+# We should handle more of this, but it requires the input of an SSH public key
+# from the user, and they may want to set up more configuration first.
+#pkg_config() {
+#}
diff --git a/dev-util/gitosis-gentoo/metadata.xml b/dev-util/gitosis-gentoo/metadata.xml
new file mode 100644
index 000000000000..24da8d39f644
--- /dev/null
+++ b/dev-util/gitosis-gentoo/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+<longdescription>
+Gitosis-gentoo is a fork of the upstream Gitosis project specifically intended
+for powering git.overlays.gentoo.org.
+</longdescription>
+</pkgmetadata>