summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-04 21:58:46 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-04 21:58:46 +0000
commit41e72649c19b51794a78eadb189c36362ac19aea (patch)
tree9fac736a5a8b99294dc8656fefa2a73393481f4a /dev-util/glade
parentREADME contains basic installation instructions (diff)
downloadgentoo-2-41e72649c19b51794a78eadb189c36362ac19aea.tar.gz
gentoo-2-41e72649c19b51794a78eadb189c36362ac19aea.tar.bz2
gentoo-2-41e72649c19b51794a78eadb189c36362ac19aea.zip
*** empty log message ***
Diffstat (limited to 'dev-util/glade')
-rw-r--r--dev-util/glade/glade-0.6.2.ebuild26
1 files changed, 17 insertions, 9 deletions
diff --git a/dev-util/glade/glade-0.6.2.ebuild b/dev-util/glade/glade-0.6.2.ebuild
index 3070889cc8b3..1b4cefafaccf 100644
--- a/dev-util/glade/glade-0.6.2.ebuild
+++ b/dev-util/glade/glade-0.6.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.6.2.ebuild,v 1.2 2001/05/11 13:07:05 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/glade/glade-0.6.2.ebuild,v 1.3 2001/06/04 21:57:52 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,30 +10,38 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/glade/"${A}
HOMEPAGE="http://www.gnome.org/"
DEPEND=">=x11-libs/gtk+-1.2.8
+ bonobo? ( >=gnome-base/bonobo-1.0.4 )
gnome? ( >=gnome-base/gnome-libs-1.2.8
- >=gnome-office/gnome-db-0.2.0
- >=gnome-base/scrollkeeper-0.2 )"
+ >=gnome-base/scrollkeeper-0.2 )"
+ #gnome-db stuff disabled atm
+ #>=gnome-office/gnome-db-0.2.0
+
+src_compile() {
-src_compile() {
- cd ${S}
local myopts
if [ -n "`use gnome`" ]
then
echo "Using Gnome"
- myopts="--prefix=/opt/gnome --without-bonobo"
+ myopts="--prefix=/opt/gnome"
+
else
myopts="--prefix=/usr/X11R6 --disable-gnome"
fi
+ if [ "`use bonobo`" ] ; then
+ myopts="$myopts --with-bonobo"
+ else
+ myopts="$myopts --without-bonobo"
+ fi
try ./configure --host=${CHOST} ${myopts}
# bonobo support does not work with 0.28 requires around 0.18
try make
}
-src_install() {
- cd ${S}
+src_install() {
+
local myopts
if [ -n "`use gnome`" ]
- then
+ then
try make prefix=${D}/opt/gnome install
else
try make prefix=${D}/usr/X11R6 install