summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2008-11-27 21:53:41 +0000
committerJeroen Roovers <jer@gentoo.org>2008-11-27 21:53:41 +0000
commit79d99daf6fdcf9fd346cce321c192cde2e08cd91 (patch)
tree46c67464407aa3731c2d58a75460a97fd8a37589 /dev-util/global
parentold (diff)
downloadgentoo-2-79d99daf6fdcf9fd346cce321c192cde2e08cd91.tar.gz
gentoo-2-79d99daf6fdcf9fd346cce321c192cde2e08cd91.tar.bz2
gentoo-2-79d99daf6fdcf9fd346cce321c192cde2e08cd91.zip
Version bump (bug #246495) thanks to Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.25-gentoo-r7-JeR i686)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/global-5.7.3.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 92a9ce6707c8..c1fa4ed8d696 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.31 2008/08/24 01:38:53 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.32 2008/11/27 21:53:41 jer Exp $
+
+*global-5.7.3 (27 Nov 2008)
+
+ 27 Nov 2008; Jeroen Roovers <jer@gentoo.org> +global-5.7.3.ebuild:
+ Version bump (bug #246495) thanks to Arfrever Frehtes Taifersar Arahesis.
24 Aug 2008; Ulrich Mueller <ulm@gentoo.org> global-5.6.2.ebuild,
global-5.7.1.ebuild:
diff --git a/dev-util/global/global-5.7.3.ebuild b/dev-util/global/global-5.7.3.ebuild
new file mode 100644
index 000000000000..9ff21fa15b6d
--- /dev/null
+++ b/dev-util/global/global-5.7.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.7.3.ebuild,v 1.1 2008/11/27 21:53:41 jer Exp $
+
+inherit elisp-common
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc vim emacs"
+
+RDEPEND="vim? ( || ( app-editors/vim app-editors/gvim ) )
+ emacs? ( virtual/emacs )"
+DEPEND="${DEPEND}
+ doc? ( sys-apps/texinfo )"
+
+SITEFILE=50gtags-gentoo.el
+
+src_compile() {
+ econf || die "econf failed"
+
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.txi
+ texi2html -o doc/global.html doc/global.txi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc; then
+ dohtml doc/global.html
+ dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}