summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2005-12-08 21:48:19 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2005-12-08 21:48:19 +0000
commite8a49a993ab34ea0f4c286826570d12c5bac7cfb (patch)
treec5d43b030fcfec780c22a0b1bdf871db6c9367e5 /dev-util/global
parentversion bump (diff)
downloadgentoo-2-e8a49a993ab34ea0f4c286826570d12c5bac7cfb.tar.gz
gentoo-2-e8a49a993ab34ea0f4c286826570d12c5bac7cfb.tar.bz2
gentoo-2-e8a49a993ab34ea0f4c286826570d12c5bac7cfb.zip
Corrected support for Emacs (inherit "elisp-common", not "emacs"); Add Emacs Lisp site-file including autoload; Resolves Bug #110979.
(Portage version: 2.0.53)
Diffstat (limited to 'dev-util/global')
-rw-r--r--dev-util/global/ChangeLog7
-rw-r--r--dev-util/global/Manifest7
-rw-r--r--dev-util/global/files/50gtags-gentoo.el5
-rw-r--r--dev-util/global/global-4.8.2.ebuild20
4 files changed, 25 insertions, 14 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index 40e9cd91a723..0a559140b44f 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/global
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.15 2005/04/30 11:19:48 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.16 2005/12/08 21:48:19 mkennedy Exp $
+
+ 08 Dec 2005; Matthew Kennedy <mkennedy@gentoo.org>
+ +files/50gtags-gentoo.el, global-4.8.2.ebuild:
+ Corrected support for Emacs (inherit "elisp-common", not "emacs"); Add Emacs
+ Lisp site-file including autoload; Resolves Bug #110979.
30 Apr 2005; David Holm <dholm@gentoo.org> global-4.8.2.ebuild:
Readded to ~ppc
diff --git a/dev-util/global/Manifest b/dev-util/global/Manifest
index 5878ca43ac87..6368f5b0ba8a 100644
--- a/dev-util/global/Manifest
+++ b/dev-util/global/Manifest
@@ -1,7 +1,8 @@
MD5 eddd0c49a413897c6702b2ad551da20c ChangeLog 2162
-MD5 d938a5a567a195b4379516bf21c8e926 global-4.5.ebuild 730
-MD5 f4661530b9745748bd43ad19b0ca7f7c global-4.7.2.ebuild 1104
-MD5 a5530109ac2ee54fa61b7ec1a4a133a1 global-4.8.2.ebuild 1438
+MD5 050c877ef3774d638722b9a90dbd48b2 files/50gtags-gentoo.el 184
MD5 0424e6fe5b2cb2d127bb8c2d358c86f0 files/digest-global-4.5 62
MD5 e9f2d3ff22577cbeeb33f207c8660067 files/digest-global-4.7.2 64
MD5 abfcd62d837afb87d067cc5175a77b72 files/digest-global-4.8.2 64
+MD5 d938a5a567a195b4379516bf21c8e926 global-4.5.ebuild 730
+MD5 f4661530b9745748bd43ad19b0ca7f7c global-4.7.2.ebuild 1104
+MD5 e3aedfb4d2f4bddbc54c20c87cd1535d global-4.8.2.ebuild 1484
diff --git a/dev-util/global/files/50gtags-gentoo.el b/dev-util/global/files/50gtags-gentoo.el
new file mode 100644
index 000000000000..a9e6e08de742
--- /dev/null
+++ b/dev-util/global/files/50gtags-gentoo.el
@@ -0,0 +1,5 @@
+
+;; site-lisp configuration for global
+
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'gtags-mode "gtags" "Toggle Gtags mode, a minor mode for browsing source code using GLOBAL." t)
diff --git a/dev-util/global/global-4.8.2.ebuild b/dev-util/global/global-4.8.2.ebuild
index 7254f181e9dd..c0a7570cb676 100644
--- a/dev-util/global/global-4.8.2.ebuild
+++ b/dev-util/global/global-4.8.2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.8.2.ebuild,v 1.3 2005/04/30 11:19:48 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-4.8.2.ebuild,v 1.4 2005/12/08 21:48:19 mkennedy Exp $
-inherit elisp
+inherit elisp-common
DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in C, C++, Yacc, Java and assembler sources."
HOMEPAGE="http://www.gnu.org/software/global/global.html"
@@ -27,6 +27,10 @@ src_compile() {
texi2html -o doc/global.html doc/global.txi
fi
+ if use emacs; then
+ elisp-comp *.el || die
+ fi
+
emake || die "emake failed"
}
@@ -49,19 +53,15 @@ src_install() {
fi
if use emacs; then
- cp gtags.el ${SITEFILE}
- elisp-site-file-install ${SITEFILE}
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
fi
}
pkg_postinst() {
- if use emacs; then
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}
pkg_postrm() {
- if use emacs; then
- elisp-site-regen
- fi
+ use emacs && elisp-site-regen
}