summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-11-30 18:03:40 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-11-30 18:03:40 +0000
commit67abfbd00589b927b84e6f9fcadf074d21441098 (patch)
tree64392dc27f96f0426b3988fe99b39f0b10a99759 /dev-util/include-what-you-use
parentNeeds libsdl[opengl] (bug #531216) (diff)
downloadgentoo-2-67abfbd00589b927b84e6f9fcadf074d21441098.tar.gz
gentoo-2-67abfbd00589b927b84e6f9fcadf074d21441098.tar.bz2
gentoo-2-67abfbd00589b927b84e6f9fcadf074d21441098.zip
Version bump (bug #531218 by August Hörandl).
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-util/include-what-you-use')
-rw-r--r--dev-util/include-what-you-use/ChangeLog8
-rw-r--r--dev-util/include-what-you-use/include-what-you-use-3.5.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-util/include-what-you-use/ChangeLog b/dev-util/include-what-you-use/ChangeLog
index 48280b13ee78..4bb2645354cc 100644
--- a/dev-util/include-what-you-use/ChangeLog
+++ b/dev-util/include-what-you-use/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/include-what-you-use
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/ChangeLog,v 1.3 2014/02/05 21:01:40 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/ChangeLog,v 1.4 2014/11/30 18:03:40 slyfox Exp $
+
+*include-what-you-use-3.5 (30 Nov 2014)
+
+ 30 Nov 2014; Sergei Trofimovich <slyfox@gentoo.org>
+ +include-what-you-use-3.5.ebuild:
+ Version bump (bug #531218 by August Hörandl).
*include-what-you-use-3.4 (05 Feb 2014)
diff --git a/dev-util/include-what-you-use/include-what-you-use-3.5.ebuild b/dev-util/include-what-you-use/include-what-you-use-3.5.ebuild
new file mode 100644
index 000000000000..c413a0168d70
--- /dev/null
+++ b/dev-util/include-what-you-use/include-what-you-use-3.5.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/include-what-you-use/include-what-you-use-3.5.ebuild,v 1.1 2014/11/30 18:03:40 slyfox Exp $
+
+EAPI=5
+inherit eutils cmake-utils flag-o-matic
+
+DESCRIPTION="find unused include directives in C/C++ programs"
+HOMEPAGE="https://code.google.com/p/include-what-you-use/"
+SRC_URI="http://include-what-you-use.com/downloads/include-what-you-use-3.5.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="=sys-devel/llvm-3.5*
+ =sys-devel/clang-3.5*"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() {
+ append-ldflags -L$(llvm-config --libdir)
+
+ local mycmakeargs=(
+ -DLLVM_PATH=$(llvm-config --libdir)
+ )
+ cmake-utils_src_configure
+}