summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-07-30 07:47:55 +0000
committerMike Frysinger <vapier@gentoo.org>2007-07-30 07:47:55 +0000
commit7833a955837c292fd1863d368cbd0d6f4b6fc870 (patch)
tree7841e90298896364c733f13a96d3e66e2b73f8fa /dev-util/insight
parentstable x86, bug 185631 (diff)
downloadgentoo-2-7833a955837c292fd1863d368cbd0d6f4b6fc870.tar.gz
gentoo-2-7833a955837c292fd1863d368cbd0d6f4b6fc870.tar.bz2
gentoo-2-7833a955837c292fd1863d368cbd0d6f4b6fc870.zip
tweak code a bit to account for cross compilers
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'dev-util/insight')
-rw-r--r--dev-util/insight/insight-6.6.ebuild21
1 files changed, 17 insertions, 4 deletions
diff --git a/dev-util/insight/insight-6.6.ebuild b/dev-util/insight/insight-6.6.ebuild
index ffdaedee84ff..3c31f95316f3 100644
--- a/dev-util/insight/insight-6.6.ebuild
+++ b/dev-util/insight/insight-6.6.ebuild
@@ -1,15 +1,24 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.6.ebuild,v 1.1 2007/03/08 01:36:54 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/insight/insight-6.6.ebuild,v 1.2 2007/07/30 07:47:55 vapier Exp $
inherit eutils flag-o-matic
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
DESCRIPTION="A graphical interface to the GNU debugger"
HOMEPAGE="http://sourceware.org/insight/"
SRC_URI="ftp://sources.redhat.com/pub/${PN}/releases/${P}.tar.bz2"
LICENSE="GPL-2 LGPL-2"
-SLOT="0"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
IUSE="nls"
@@ -41,7 +50,11 @@ src_compile() {
src_install() {
# the tcl-related subdirs are not parallel safe
emake -j1 DESTDIR="${D}" install || die
- dodoc gdb/gdbtk/{README,TODO}
+
+ # Don't install docs when building a cross-insight
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ dodoc gdb/gdbtk/{README,TODO}
+ fi
# the gui tcl code does not consider any of the configure
# options given it ... instead, it requires the path to
@@ -52,7 +65,7 @@ src_install() {
local x
cd "${D}"/usr/bin
for x in * ; do
- [[ ${x} != "insight" ]] && rm -f ${x}
+ [[ ${x} != *insight ]] && rm -f ${x}
done
cd "${D}"
rm -rf usr/{include,man,share/{info,locale,man}}