summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-27 08:10:52 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-27 08:10:52 +0000
commitf2b44306bc4326cf5377d55fdd3614fe97472a38 (patch)
tree0b4ebb8e6b388b8dcdda9876069d10ba99ec2dab /dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
parentUse more readable CTARGET setup logic. (diff)
downloadgentoo-2-f2b44306bc4326cf5377d55fdd3614fe97472a38.tar.gz
gentoo-2-f2b44306bc4326cf5377d55fdd3614fe97472a38.tar.bz2
gentoo-2-f2b44306bc4326cf5377d55fdd3614fe97472a38.zip
Use more readable CTARGET setup logic.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-util/mingw-runtime/mingw-runtime-3.18.ebuild')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.18.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
index 7f292166d0da..a00a25d4bdb8 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild,v 1.4 2013/05/10 09:38:39 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.18.ebuild,v 1.5 2015/02/27 08:10:52 vapier Exp $
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi