summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-05 23:04:18 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-05 23:04:18 +0000
commitf2274c2d565d449b3a5769efeccd4ff93e9af4ce (patch)
tree2cf3bb6db4724ea52a30104a87755953401edaef /dev-util/mingw-runtime
parentmark amd64/x86 stable (diff)
downloadgentoo-2-f2274c2d565d449b3a5769efeccd4ff93e9af4ce.tar.gz
gentoo-2-f2274c2d565d449b3a5769efeccd4ff93e9af4ce.tar.bz2
gentoo-2-f2274c2d565d449b3a5769efeccd4ff93e9af4ce.zip
Version bump #291981 by Rafał Mużyło.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/mingw-runtime')
-rw-r--r--dev-util/mingw-runtime/ChangeLog7
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.16.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-util/mingw-runtime/ChangeLog b/dev-util/mingw-runtime/ChangeLog
index 91aaf2e5fc38..57b162a852ea 100644
--- a/dev-util/mingw-runtime/ChangeLog
+++ b/dev-util/mingw-runtime/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/mingw-runtime
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.17 2009/11/05 23:03:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/ChangeLog,v 1.18 2009/11/05 23:04:18 vapier Exp $
+
+*mingw-runtime-3.16 (05 Nov 2009)
+
+ 05 Nov 2009; Mike Frysinger <vapier@gentoo.org> +mingw-runtime-3.16.ebuild:
+ Version bump #291981 by Rafał Mużyło.
05 Nov 2009; Mike Frysinger <vapier@gentoo.org> mingw-runtime-3.15.2.ebuild:
Mark amd64/x86 stable.
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.16.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.16.ebuild
new file mode 100644
index 000000000000..9468b008d8ab
--- /dev/null
+++ b/dev-util/mingw-runtime/mingw-runtime-3.16.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.16.ebuild,v 1.1 2009/11/05 23:04:18 vapier Exp $
+
+# This version does not work as the configure script expects the installed
+# cross-compiler to be able to link binaries ... except we haven't provided
+# any of the crt objects yet so it is impossible to link binaries.
+# Older mingw-runtime packages hacked around the issue, but this version seems
+# to have dropped said hack thus breaking the package.
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+inherit eutils flag-o-matic
+
+MY_P="mingwrt-${PV}-mingw32"
+DESCRIPTION="Free Win32 runtime and import library definitions"
+HOMEPAGE="http://www.mingw.org/"
+SRC_URI="mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+S=${WORKDIR}/${MY_P}
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/W32API_INCLUDE/s:=.*:='-I /usr/${CTARGET}/usr/include':" \
+ $(find -name configure) || die
+ epatch "${FILESDIR}"/${PN}-3.12-DESTDIR.patch
+}
+
+src_compile() {
+ just_headers && return 0
+
+ CHOST=${CTARGET} strip-unsupported-flags
+ econf --host=${CTARGET} || die
+ emake || die
+}
+
+src_install() {
+ if just_headers ; then
+ insinto /usr/${CTARGET}/usr/include
+ doins -r include/* || die
+ else
+ local insdir
+ is_crosscompile \
+ && insdir="${D}/usr/${CTARGET}" \
+ || insdir="${D}"
+ emake install DESTDIR="${insdir}" || die
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${insdir}"/usr/doc
+ dodoc CONTRIBUTORS ChangeLog README TODO readme.txt
+ fi
+ is_crosscompile && dosym usr /usr/${CTARGET}/mingw
+}