summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2015-05-05 11:39:40 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2015-05-05 11:39:40 +0000
commit7dedf2dc57cbef60b65055a63554ffa4c4f75eb5 (patch)
treeef28f83658d7ec561b504a26515e3786c3633c93 /dev-util/mingw64-runtime
parentRemove old. (diff)
downloadgentoo-2-7dedf2dc57cbef60b65055a63554ffa4c4f75eb5.tar.gz
gentoo-2-7dedf2dc57cbef60b65055a63554ffa4c4f75eb5.tar.bz2
gentoo-2-7dedf2dc57cbef60b65055a63554ffa4c4f75eb5.zip
Version bump, bug#543954
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'dev-util/mingw64-runtime')
-rw-r--r--dev-util/mingw64-runtime/ChangeLog10
-rw-r--r--dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-build.patch88
-rw-r--r--dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-winpthreads.patch86
-rw-r--r--dev-util/mingw64-runtime/metadata.xml6
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-4.0.1.ebuild113
5 files changed, 302 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/ChangeLog b/dev-util/mingw64-runtime/ChangeLog
index 3d836b4d9d66..1e72b21f8af4 100644
--- a/dev-util/mingw64-runtime/ChangeLog
+++ b/dev-util/mingw64-runtime/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/mingw64-runtime
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.19 2015/02/27 08:11:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/ChangeLog,v 1.20 2015/05/05 11:39:40 alonbl Exp $
+
+*mingw64-runtime-4.0.1 (05 May 2015)
+
+ 05 May 2015; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/mingw64-runtime-4.0.1-build.patch,
+ +files/mingw64-runtime-4.0.1-winpthreads.patch, +mingw64-runtime-4.0.1.ebuild,
+ metadata.xml:
+ Version bump, bug#543954
27 Feb 2015; Mike Frysinger <vapier@gentoo.org> mingw64-runtime-2.0.8.ebuild,
mingw64-runtime-3.0.0.ebuild, mingw64-runtime-3.1.0.ebuild,
diff --git a/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-build.patch b/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-build.patch
new file mode 100644
index 000000000000..6461b98e5044
--- /dev/null
+++ b/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-build.patch
@@ -0,0 +1,88 @@
+From 67434f57cbb5aba791e9ca973a86859e0736f829 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Mon, 4 May 2015 21:31:10 +0300
+Subject: [PATCH 2/2] build: autoconf: enable multiple tools and libs
+
+this somewhat reduces the error checking, but makes code and usage nicer.
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ configure.ac | 55 ++++++++++++-------------------------------------------
+ 1 file changed, 12 insertions(+), 43 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 468d1b1..1b59821 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -56,32 +56,12 @@ AC_ARG_WITH([libraries],
+ [Build the extra mingw-w64 libs, where ARG is one of libmangle, pseh, winpthreads, or all])],
+ [],
+ [with_libraries=no])
+-AS_CASE([$with_libraries],
+- [yes|all],[
+- with_libraries="libmangle,pseh,winpthreads"
+- with_libraries_winpthreads=yes
+- with_libraries_mangle=yes
+- with_libraries_pseh=yes],
+- [libmangle],[
+- with_libraries="libmangle"
+- with_libraries_winpthreads=no
+- with_libraries_mangle=yes
+- with_libraries_pseh=no],
+- [pseh],[
+- with_libraries="pseh"
+- with_libraries_winpthreads=no
+- with_libraries_mangle=no
+- with_libraries_pseh=yes],
+- [winpthreads],[
+- with_libraries="winpthreads"
+- with_libraries_winpthreads=yes
+- with_libraries_mangle=no
+- with_libraries_pseh=no],
+- [no],[
+- with_libraries_winpthreads=no
+- with_libraries_mangle=no
+- with_libraries_pseh=no],
+- [MW64_OPTION_ERROR([with-libraries])])
++for l in winpthreads mangle pseh; do
++ res=`echo "${with_libraries}" | grep $l > /dev/null && echo yes || echo no`
++ AS_CASE([$with_libraries],
++ [all|yes],[res=yes])
++ AS_VAR_COPY([with_libraries_$l], [res])
++done
+ AM_CONDITIONAL([LIBRARIES_MANGLE],[test "x$with_libraries_mangle" = xyes])
+ AM_CONDITIONAL([LIBRARIES_PSEH],[test "x$with_libraries_pseh" = xyes])
+ AM_CONDITIONAL([LIBRARIES_WINPTHREADS],[test "x$with_libraries_winpthreads" = xyes])
+@@ -96,23 +76,12 @@ AC_ARG_WITH([tools],
+ [Build the extra mingw-w64 tools, where ARG is one of gendef, genidl, or all])],
+ [],
+ [with_tools=no])
+-AS_CASE([$with_tools],
+- [yes|all],[
+- with_tools="gendef,genidl"
+- with_tools_gendef=yes
+- with_tools_genidl=yes],
+- [gendef],[
+- with_tools="gendef"
+- with_tools_gendef=yes
+- with_tools_genidl=no],
+- [genidl],[
+- with_tools="genidl"
+- with_tools_gendef=no
+- with_tools_genidl=yes],
+- [no],[
+- with_tools_gendef=no
+- with_tools_genidl=no],
+- [MW64_OPTION_ERROR([with-tools])])
++for t in gendef genidl; do
++ res=`echo "${with_tools}" | grep $t > /dev/null && echo yes || echo no`
++ AS_CASE([$with_tools],
++ [all|yes],[res=yes])
++ AS_VAR_COPY([with_tools_$t], [res])
++done
+ AM_CONDITIONAL([TOOLS_GENDEF],[test "x$with_tools_gendef" = xyes])
+ AM_CONDITIONAL([TOOLS_GENIDL],[test "x$with_tools_genidl" = xyes])
+ AM_COND_IF([TOOLS_GENDEF],[AC_CONFIG_SUBDIRS([mingw-w64-tools/gendef])])
+--
+2.3.6
+
diff --git a/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-winpthreads.patch b/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-winpthreads.patch
new file mode 100644
index 000000000000..0d3e59dc9dd5
--- /dev/null
+++ b/dev-util/mingw64-runtime/files/mingw64-runtime-4.0.1-winpthreads.patch
@@ -0,0 +1,86 @@
+From 0adec5d0e1c65fc4ce4f84f3d4bb6738e923e1de Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Mon, 4 May 2015 20:39:52 +0300
+Subject: [PATCH 1/2] build: autoconf: support winpthreads library
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ Makefile.am | 6 +++++-
+ configure.ac | 15 +++++++++++++--
+ 2 files changed, 18 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 26a7606..308b6fd 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -14,6 +14,10 @@ if LIBRARIES_PSEH
+ MAYBE_LIBRARIES_PSEH = mingw-w64-libraries/pseh
+ endif
+
++if LIBRARIES_WINPTHREADS
++ MAYBE_LIBRARIES_WINPTHREADS = mingw-w64-libraries/winpthreads
++endif
++
+ if TOOLS_GENDEF
+ MAYBE_TOOLS_GENDEF = mingw-w64-tools/gendef
+ endif
+@@ -22,7 +26,7 @@ if TOOLS_GENIDL
+ MAYBE_TOOLS_GENIDL = mingw-w64-tools/genidl
+ endif
+
+-SUBDIRS = $(MAYBE_HEADER) $(MAYBE_CRT) $(MAYBE_LIBRARIES_MANGLE) $(MAYBE_LIBRARIES_PSEH) $(MAYBE_TOOLS_GENDEF) $(MAYBE_TOOLS_GENIDL)
++SUBDIRS = $(MAYBE_HEADER) $(MAYBE_CRT) $(MAYBE_LIBRARIES_MANGLE) $(MAYBE_LIBRARIES_PSEH) $(MAYBE_LIBRARIES_WINPTHREADS) $(MAYBE_TOOLS_GENDEF) $(MAYBE_TOOLS_GENIDL)
+
+ DISTCHECK_CONFIGURE_FLAGS = --with-headers --with-crt --with-libraries=all --with-tools=all
+
+diff --git a/configure.ac b/configure.ac
+index 4bb3926..468d1b1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -53,30 +53,41 @@ AC_MSG_RESULT([$with_crt])
+ AC_MSG_CHECKING([whether to build the optional libraries])
+ AC_ARG_WITH([libraries],
+ [AS_HELP_STRING([--with-libraries=ARG],
+- [Build the extra mingw-w64 libs, where ARG is one of libmangle, pseh, or all])],
++ [Build the extra mingw-w64 libs, where ARG is one of libmangle, pseh, winpthreads, or all])],
+ [],
+ [with_libraries=no])
+ AS_CASE([$with_libraries],
+ [yes|all],[
+- with_libraries="libmangle,pseh"
++ with_libraries="libmangle,pseh,winpthreads"
++ with_libraries_winpthreads=yes
+ with_libraries_mangle=yes
+ with_libraries_pseh=yes],
+ [libmangle],[
+ with_libraries="libmangle"
++ with_libraries_winpthreads=no
+ with_libraries_mangle=yes
+ with_libraries_pseh=no],
+ [pseh],[
+ with_libraries="pseh"
++ with_libraries_winpthreads=no
+ with_libraries_mangle=no
+ with_libraries_pseh=yes],
++ [winpthreads],[
++ with_libraries="winpthreads"
++ with_libraries_winpthreads=yes
++ with_libraries_mangle=no
++ with_libraries_pseh=no],
+ [no],[
++ with_libraries_winpthreads=no
+ with_libraries_mangle=no
+ with_libraries_pseh=no],
+ [MW64_OPTION_ERROR([with-libraries])])
+ AM_CONDITIONAL([LIBRARIES_MANGLE],[test "x$with_libraries_mangle" = xyes])
+ AM_CONDITIONAL([LIBRARIES_PSEH],[test "x$with_libraries_pseh" = xyes])
++AM_CONDITIONAL([LIBRARIES_WINPTHREADS],[test "x$with_libraries_winpthreads" = xyes])
+ AM_COND_IF([LIBRARIES_MANGLE],[AC_CONFIG_SUBDIRS([mingw-w64-libraries/libmangle])])
+ AM_COND_IF([LIBRARIES_PSEH],[AC_CONFIG_SUBDIRS([mingw-w64-libraries/pseh])])
++AM_COND_IF([LIBRARIES_WINPTHREADS],[AC_CONFIG_SUBDIRS([mingw-w64-libraries/winpthreads])])
+ AC_MSG_RESULT([$with_libraries])
+
+ AC_MSG_CHECKING([whether to build the optional tools])
+--
+2.3.6
+
diff --git a/dev-util/mingw64-runtime/metadata.xml b/dev-util/mingw64-runtime/metadata.xml
index bf6941f943c3..3afd7c80097e 100644
--- a/dev-util/mingw64-runtime/metadata.xml
+++ b/dev-util/mingw64-runtime/metadata.xml
@@ -6,5 +6,11 @@
<flag name='idl'>
Install idl files.
</flag>
+ <flag name='libraries'>
+ Build extra libraries.
+ </flag>
+ <flag name='tools'>
+ Build extra tools.
+ </flag>
</use>
</pkgmetadata>
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-4.0.1.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-4.0.1.ebuild
new file mode 100644
index 000000000000..48c6178cabc1
--- /dev/null
+++ b/dev-util/mingw64-runtime/mingw64-runtime-4.0.1.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw64-runtime/mingw64-runtime-4.0.1.ebuild,v 1.1 2015/05/05 11:39:40 alonbl Exp $
+
+EAPI=5
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
+ fi
+fi
+
+WANT_AUTOMAKE="1.15"
+
+inherit autotools flag-o-matic eutils
+
+DESCRIPTION="Free Win64 runtime and import library definitions"
+HOMEPAGE="http://mingw-w64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/mingw-w64/mingw-w64/mingw-w64-release/mingw-w64-v${PV}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="crosscompile_opts_headers-only idl libraries tools"
+RESTRICT="strip"
+
+S="${WORKDIR}/mingw-w64-v${PV}"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+just_headers() {
+ use crosscompile_opts_headers-only && [[ ${CHOST} != ${CTARGET} ]]
+}
+crt_with() {
+ just_headers && echo --without-$1 || echo --with-$1
+}
+crt_use_enable() {
+ just_headers && echo --without-$2 || use_enable "$@"
+}
+crt_use_with() {
+ just_headers && echo --without-$2 || use_with "$@"
+}
+
+pkg_setup() {
+ if [[ ${CBUILD} == ${CHOST} ]] && [[ ${CHOST} == ${CTARGET} ]] ; then
+ die "Invalid configuration"
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-winpthreads.patch"
+ epatch "${FILESDIR}/${P}-build.patch"
+ eautoreconf
+}
+
+src_configure() {
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ if ! just_headers; then
+ mkdir "${WORKDIR}/headers"
+ pushd "${WORKDIR}/headers" > /dev/null
+ CHOST=${CTARGET} "${S}/configure" \
+ --prefix="${T}/tmproot" \
+ --with-headers \
+ --without-crt \
+ || die
+ popd > /dev/null
+ append-cppflags "-I${T}/tmproot/include"
+ fi
+
+ local extra_conf=()
+
+ case ${CTARGET} in
+ x86_64*) extra_conf+=( --disable-lib32 --enable-lib64 ) ;;
+ i?86*) extra_conf+=( --enable-lib32 --disable-lib64 ) ;;
+ *) die "Unsupported ${CTARGET}" ;;
+ esac
+
+ CHOST=${CTARGET} econf \
+ --prefix=/usr/${CTARGET} \
+ --includedir=/usr/${CTARGET}/usr/include \
+ --with-headers \
+ --enable-sdk \
+ $(crt_with crt) \
+ $(crt_use_enable idl) \
+ $(crt_use_with libraries libraries winpthreads,libmangle) \
+ $(crt_use_with tools) \
+ "${extra_conf[@]}"
+}
+
+src_compile() {
+ if ! just_headers; then
+ emake -C "${WORKDIR}/headers" install
+ fi
+ default
+}
+
+src_install() {
+ default
+
+ if is_crosscompile ; then
+ # gcc is configured to look at specific hard-coded paths for mingw #419601
+ dosym usr /usr/${CTARGET}/mingw
+ dosym usr /usr/${CTARGET}/${CTARGET}
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+
+ env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ rm -rf "${ED}/usr/share"
+}