summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2007-06-21 08:52:24 +0000
committerDaniel Black <dragonheart@gentoo.org>2007-06-21 08:52:24 +0000
commitb781196b55b15223e86bd6984a60f79bcac95258 (patch)
treea6236469dffa716c0dfb47f4283d8dce8ed558c9 /dev-util/monotone
parentSilent bump to ooo-build-2.2.1, bunch of bugfixes. Also fix java bug #171274 (diff)
downloadgentoo-2-b781196b55b15223e86bd6984a60f79bcac95258.tar.gz
gentoo-2-b781196b55b15223e86bd6984a60f79bcac95258.tar.bz2
gentoo-2-b781196b55b15223e86bd6984a60f79bcac95258.zip
version bump and patch as per bug #177147 thanks to Cameron Brunner
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-util/monotone')
-rw-r--r--dev-util/monotone/ChangeLog8
-rw-r--r--dev-util/monotone/files/digest-monotone-0.353
-rw-r--r--dev-util/monotone/files/monotone-0.35-numeric-vocab.patch10
-rw-r--r--dev-util/monotone/monotone-0.35.ebuild115
4 files changed, 135 insertions, 1 deletions
diff --git a/dev-util/monotone/ChangeLog b/dev-util/monotone/ChangeLog
index e2e44ea81474..ca380be7df53 100644
--- a/dev-util/monotone/ChangeLog
+++ b/dev-util/monotone/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/monotone
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.42 2007/05/15 09:10:31 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/ChangeLog,v 1.43 2007/06/21 08:52:24 dragonheart Exp $
+
+*monotone-0.35 (21 Jun 2007)
+
+ 21 Jun 2007; Daniel Black <dragonheart@gentoo.org>
+ +files/monotone-0.35-numeric-vocab.patch, +monotone-0.35.ebuild:
+ version bump and patch as per bug #177147 thanks to Cameron Brunner
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/dev-util/monotone/files/digest-monotone-0.35 b/dev-util/monotone/files/digest-monotone-0.35
new file mode 100644
index 000000000000..485216f8e984
--- /dev/null
+++ b/dev-util/monotone/files/digest-monotone-0.35
@@ -0,0 +1,3 @@
+MD5 9b53046dda8ba7549fa5ce765e14fa65 monotone-0.35.tar.gz 4857094
+RMD160 91cb91fc25415f8357a57f199a5f83b8ea9293a1 monotone-0.35.tar.gz 4857094
+SHA256 bbe0c5ff34f58a8af81563560e5f21408a568dfe277baa452a56f19b5b7a07de monotone-0.35.tar.gz 4857094
diff --git a/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch b/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch
new file mode 100644
index 000000000000..fc91e0c66f5e
--- /dev/null
+++ b/dev-util/monotone/files/monotone-0.35-numeric-vocab.patch
@@ -0,0 +1,10 @@
+--- monotone-0.35.orig/numeric_vocab.hh 2007-06-20 14:17:12.689221923 -0300
++++ monotone-0.35/numeric_vocab.hh 2007-06-20 14:15:41.297802806 -0300
+@@ -12,6 +12,7 @@
+
+ #include <cstddef>
+ #include <limits>
++#include <climits>
+
+ #include "mt-stdint.h"
+ #include <boost/static_assert.hpp>
diff --git a/dev-util/monotone/monotone-0.35.ebuild b/dev-util/monotone/monotone-0.35.ebuild
new file mode 100644
index 000000000000..4f443de1bdb6
--- /dev/null
+++ b/dev-util/monotone/monotone-0.35.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/monotone/monotone-0.35.ebuild,v 1.1 2007/06/21 08:52:24 dragonheart Exp $
+
+inherit elisp-common flag-o-matic bash-completion eutils
+
+DESCRIPTION="Monotone Distributed Version Control System"
+HOMEPAGE="http://monotone.ca"
+SRC_URI="http://monotone.ca/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+
+IUSE="doc emacs ipv6 nls"
+
+RDEPEND=">=dev-libs/boost-1.33.1
+ sys-libs/zlib
+ emacs? ( virtual/emacs )"
+
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.11.5 )
+ doc? ( sys-apps/texinfo )"
+
+
+pkg_setup() {
+ enewgroup monotone
+ enewuser monotone -1 -1 /var/lib/monotone monotone
+ if [[ "$(gcc-version)" == "3.3" ]]; then
+ die 'requires >=gcc-3.4'
+ fi
+}
+
+src_compile() {
+ local myconf="$(use_enable nls) \
+ $(use_enable ipv6)"
+ #lvcargnini modifications
+ epatch "${FILESDIR}"/${P}-numeric-vocab.patch
+
+ # more aggressive optimizations cause trouble with the crypto library
+ strip-flags
+ append-flags $(test-flags -fno-stack-protector-all -fno-stack-protector)
+ append-flags -fno-strict-aliasing -fno-omit-frame-pointer
+
+ econf ${myconf} || die "configure failed"
+ emake || die "Compilation failed"
+
+ if use doc; then
+ make html || die 'html compilation failed'
+ fi
+
+ use emacs && elisp-compile contrib/*.el
+}
+
+src_test() {
+ make check || die "self test failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ mv "${D}"/usr/share/doc/"${PN}" "${D}"/usr/share/doc/"${PF}"
+
+ dobashcompletion contrib/monotone.bash_completion
+
+ if use doc; then
+ dohtml -r html/*
+ dohtml -r figures
+ fi
+
+ if use emacs; then
+ elisp-install ${PN} contrib/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/30monotone-gentoo.el
+ fi
+
+ dodoc ABOUT-NLS AUTHORS ChangeLog NEWS README* UPGRADE
+ docinto contrib
+ dodoc contrib/*
+ newconfd "${FILESDIR}"/monotone.confd monotone
+ newinitd "${FILESDIR}"/${PN}-0.33.initd monotone
+
+ insinto /etc/monotone ;
+ newins "${FILESDIR}"/hooks.lua hooks.lua
+ newins "${FILESDIR}"/read-permissions read-permissions
+ newins "${FILESDIR}"/write-permissions write-permissions
+
+ keepdir /var/lib/monotone/keys/ /var/log/monotone /var/run/monotone
+ fowners monotone:monotone /var/lib/monotone /var/lib/monotone/keys/ \
+ /var/log/monotone /var/run/monotone
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ elog
+ elog "For details and instructions to upgrade from previous versions,"
+ elog "please read /usr/share/doc/${PF}/UPGRADE.gz"
+ elog
+ elog " 1. edit /etc/conf.d/monotone"
+ elog " 2. import the first keys to enable access with"
+ elog " env HOME=\${homedir} mtn pubkey me@example.net | /etc/init.d/monotone import"
+ elog " Thereafter, those with write permission can add other keys via"
+ elog " netsync with 'monotone push --key-to-push=IDENT' and then IDENT"
+ elog " can be used in the read-permission and write-permission files."
+ elog " 3. adjust permisions in /etc/monotone/read-permissions"
+ elog " and /etc/monotone/write-permissions"
+ elog " 4. start the daemon: /etc/init.d/monotone start"
+ elog " 5. make persistent: rc-update add monotone default"
+ elog
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}