summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-10-19 12:15:43 +0000
committerAlin Năstac <mrness@gentoo.org>2008-10-19 12:15:43 +0000
commitfdfd23de8fdcb7dca81fd7e2029e1310098f87b7 (patch)
tree11072aef511e6db7f6aa10cd79661e5df861c454 /dev-util/nsis
parentBump, bug 241526, thanks to Daniel Pielmeier <daniel.pielmeier@googlemail.com>. (diff)
downloadgentoo-2-fdfd23de8fdcb7dca81fd7e2029e1310098f87b7.tar.gz
gentoo-2-fdfd23de8fdcb7dca81fd7e2029e1310098f87b7.tar.bz2
gentoo-2-fdfd23de8fdcb7dca81fd7e2029e1310098f87b7.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/nsis')
-rw-r--r--dev-util/nsis/ChangeLog7
-rw-r--r--dev-util/nsis/nsis-2.40.ebuild108
2 files changed, 114 insertions, 1 deletions
diff --git a/dev-util/nsis/ChangeLog b/dev-util/nsis/ChangeLog
index 80af38421a68..b1f84cb859ec 100644
--- a/dev-util/nsis/ChangeLog
+++ b/dev-util/nsis/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/nsis
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.24 2008/08/22 03:33:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/ChangeLog,v 1.25 2008/10/19 12:15:43 mrness Exp $
+
+*nsis-2.40 (19 Oct 2008)
+
+ 19 Oct 2008; Alin Năstac <mrness@gentoo.org> +nsis-2.40.ebuild:
+ Version bump.
22 Aug 2008; Mike Frysinger <vapier@gentoo.org> nsis-2.39.ebuild:
Add USE=doc to disable generation/installation of extraneous docs.
diff --git a/dev-util/nsis/nsis-2.40.ebuild b/dev-util/nsis/nsis-2.40.ebuild
new file mode 100644
index 000000000000..3bb21db5d875
--- /dev/null
+++ b/dev-util/nsis/nsis-2.40.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/nsis/nsis-2.40.ebuild,v 1.1 2008/10/19 12:15:43 mrness Exp $
+
+mingw32_variants=$(eval echo {,i{6,5,4,3}86-}mingw32)
+
+DESCRIPTION="Nullsoft Scriptable Install System"
+HOMEPAGE="http://nsis.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2
+ prebuilt-system? ( mirror://sourceforge/${PN}/${P}.zip )"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="bzip2 config-log doc prebuilt-system zlib"
+
+# NSIS Menu uses wxwindows but it's all broken, so disable for now
+# wxwindows? ( x11-libs/wxGTK )
+RDEPEND="bzip2? ( app-arch/bzip2 )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-0.98"
+
+S=${WORKDIR}/${P}-src
+
+mingw_CTARGET() {
+ local i
+ for i in ${mingw32_variants} ; do
+ type -P ${i}-gcc > /dev/null && echo ${i} && return
+ done
+}
+
+pkg_setup() {
+ [[ -n $(mingw_CTARGET) ]] && return 0
+
+ local i
+ eerror "Before you could emerge nsis, you need to install mingw32."
+ eerror "Run the following command:"
+ eerror " emerge crossdev"
+ eerror "then run _one_ of the following commands:"
+ for i in ${mingw32_variants} ; do
+ eerror " crossdev ${i}"
+ done
+ die "mingw32 is needed"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # a dirty but effective way of killing generated docs
+ use doc || echo > Docs/src/SConscript
+}
+
+get_additional_options() {
+ echo \
+ PREFIX=/usr \
+ PREFIX_CONF=/etc \
+ PREFIX_DOC=/usr/share/doc/${PF} \
+ PREFIX_DEST=\"${D}\" \
+ VERSION=${PV} \
+ DEBUG=no \
+ STRIP=no
+ echo \
+ SKIPSTUBS=\"$(use zlib || echo zlib) $(use bzip2 || echo bzip2)\" \
+ SKIPUTILS=\"NSIS Menu\"
+ use config-log && echo NSIS_CONFIG_LOG=yes
+ # remove the following line when nsis bug 1753070 will be fixed
+ use amd64 && echo APPEND_CCFLAGS=-m32 APPEND_LINKFLAGS=-m32
+}
+
+do_scons() {
+ local cmd=$1
+ eval set -- $(get_additional_options)
+ echo scons $(get_additional_options) ${cmd}
+ scons "$@" ${cmd}
+}
+
+src_compile() {
+ do_scons || die "scons failed"
+}
+
+src_install() {
+ do_scons install || die "scons failed"
+ if use prebuilt-system ; then
+ insinto /usr/share/nsis/Plugins
+ doins "${WORKDIR}"/${P}/Plugins/System.dll || die
+ fi
+ use doc || rm -rf "${D}"/usr/share/doc/${PF}/{Docs,Examples}
+
+ fperms -R go-w,a-x,a+X /usr/share/${PN}/ /usr/share/doc/${PF}/ /etc/nsisconf.nsh
+
+ src_strip_win32
+}
+
+src_strip_win32() {
+ # need to strip win32 binaries ourselves ... should fold this
+ # back in to prepstrip at some point
+ local STRIP_PROG=$(mingw_CTARGET)-strip
+ local STRIP_FLAGS="--strip-unneeded"
+
+ echo
+ echo "strip: ${STRIP_PROG} ${STRIP_FLAGS}"
+ local FILE
+ for FILE in $(find "${D}" -iregex '.*\.\(dll\|exe\)$') ; do
+ echo " ${FILE#${D}}"
+ ${STRIP_PROG} ${STRIP_FLAGS} "${FILE}"
+ done
+}