summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-11-11 18:55:13 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-11-11 18:55:13 +0000
commitc46da56b0412862fcaa85da736922c1a67719962 (patch)
tree7ee664364e7cbbfefed9f1171c0ddc082ad09e07 /dev-util/oprofile
parentEAPI=5; update to latest debian patchball (diff)
downloadgentoo-2-c46da56b0412862fcaa85da736922c1a67719962.tar.gz
gentoo-2-c46da56b0412862fcaa85da736922c1a67719962.tar.bz2
gentoo-2-c46da56b0412862fcaa85da736922c1a67719962.zip
Version bump to 0.9.9.
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog7
-rw-r--r--dev-util/oprofile/oprofile-0.9.9.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index b6b469e09cad..3883d495c0e0 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.91 2013/05/12 15:14:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.92 2013/11/11 18:55:13 tomwij Exp $
+
+*oprofile-0.9.9 (11 Nov 2013)
+
+ 11 Nov 2013; Tom Wijsman <TomWij@gentoo.org> +oprofile-0.9.9.ebuild:
+ Version bump to 0.9.9.
12 May 2013; Agostino Sarubbo <ago@gentoo.org> oprofile-0.9.8.ebuild:
Stable for arm, wrt bug #467152
diff --git a/dev-util/oprofile/oprofile-0.9.9.ebuild b/dev-util/oprofile/oprofile-0.9.9.ebuild
new file mode 100644
index 000000000000..be7fe3171ac2
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.9.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.9.ebuild,v 1.1 2013/11/11 18:55:13 tomwij Exp $
+
+EAPI="5"
+inherit eutils linux-info multilib user java-pkg-opt-2
+
+MY_P=${PN}-${PV/_/-}
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://${PN}.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="java pch qt4"
+
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt4? ( dev-qt/qtgui:4[qt3support] )
+ java? ( >=virtual/jdk-1.5 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ linux-info_pkg_setup
+ if ! linux_config_exists || ! linux_chkconfig_present OPROFILE ; then
+ echo
+ elog "In order for ${PN} to work, you need to configure your kernel"
+ elog "with CONFIG_OPROFILE set to 'm' or 'y'."
+ echo
+ fi
+
+ if ! kernel_is -ge 2 6 ; then
+ echo
+ elog "Support for kernels before 2.6 has been dropped in ${PN}-0.9.8."
+ echo
+ fi
+
+ # Required for JIT support, see README_PACKAGERS
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+
+ use java && java-pkg_init
+}
+
+src_configure() {
+ econf \
+ --disable-werror \
+ $(use_with qt4 x) \
+ $(use_enable qt4 gui qt4) \
+ $(use_enable pch) \
+ $(use_with java java ${JAVA_HOME})
+}
+
+src_install() {
+ emake DESTDIR="${D}" htmldir="/usr/share/doc/${PF}" install
+
+ dodoc ChangeLog* README TODO
+
+ dodir /etc/env.d
+ echo "LDPATH=${PREFIX}/usr/$(get_libdir)/${PN}" > "${D}"/etc/env.d/10${PN} || die "env.d failed"
+}
+
+pkg_postinst() {
+ echo
+ elog "Now load the ${PN} module by running:"
+ elog " # opcontrol --init"
+ elog "Then read manpages and this html doc:"
+ elog " /usr/share/doc/${PF}/${PN}.html"
+ echo
+}