summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-10-24 05:10:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-10-24 05:10:37 +0000
commite06a76d667997bdd91741328fb65283ac5dd31c9 (patch)
tree730d5cc2ded55c61d18484ce110a8a3a9cabc60e /dev-util/oprofile
parentfix fencepost error - bug 31645 (diff)
downloadgentoo-2-e06a76d667997bdd91741328fb65283ac5dd31c9.tar.gz
gentoo-2-e06a76d667997bdd91741328fb65283ac5dd31c9.tar.bz2
gentoo-2-e06a76d667997bdd91741328fb65283ac5dd31c9.zip
*** empty log message ***
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/Manifest4
-rw-r--r--dev-util/oprofile/oprofile-0.7.ebuild62
2 files changed, 33 insertions, 33 deletions
diff --git a/dev-util/oprofile/Manifest b/dev-util/oprofile/Manifest
index cfb3a17b3c85..bf225c8fb61e 100644
--- a/dev-util/oprofile/Manifest
+++ b/dev-util/oprofile/Manifest
@@ -1,3 +1,3 @@
-MD5 bdaedbd1d27e7c91a6d7cc35abcb7b3e oprofile-0.7.ebuild 1731
-MD5 908127b0c92bd9c241dddacfe4b0dfbe ChangeLog 295
+MD5 a513bd34276fa8264699aba3e0c0dc98 ChangeLog 385
+MD5 9f22f8e463a7306f32be6be6b42a9aa3 oprofile-0.7.ebuild 1607
MD5 06028442781220898a045871c9db7de6 files/digest-oprofile-0.7 64
diff --git a/dev-util/oprofile/oprofile-0.7.ebuild b/dev-util/oprofile/oprofile-0.7.ebuild
index 7b3ea5dadc20..866fc652545a 100644
--- a/dev-util/oprofile/oprofile-0.7.ebuild
+++ b/dev-util/oprofile/oprofile-0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.ebuild,v 1.1 2003/10/23 22:48:16 cretin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.7.ebuild,v 1.2 2003/10/24 05:10:35 mr_bones_ Exp $
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -12,48 +12,48 @@ KEYWORDS="~x86"
# IUSE: it also needs kernel sources but all gentoo users have them
IUSE="qt"
DEPEND="
- >=dev-libs/popt-1.7-r1
- >=sys-devel/binutils-2.14.90.0.6-r3
- >=sys-libs/glibc-2.3.2-r1
- qt? ( >=x11-libs/qt-3.2.1-r2 )"
+ >=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt? ( >=x11-libs/qt-3.2.1-r2 )"
src_compile() {
- check_KV
+ check_KV
- local myconf=""
+ local myconf=""
- myconf="${myconf} --with-x"
- # note: compilation has only been tested with a 2.4 kernel
- case $KV in
- 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
- 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
- *) die "Kernel version '$KV' not supported";;
- esac
- econf ${myconf} || die "econf failed"
+ myconf="${myconf} --with-x"
+ # note: compilation has only been tested with a 2.4 kernel
+ case $KV in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '$KV' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
- local mymake=""
+ local mymake=""
- sed -i -e "s,depmod -a,:,g" Makefile
- emake ${mymake} || die "emake failed"
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
}
src_install() {
- local myinst=""
+ local myinst=""
- myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
- make DESTDIR=${D} ${myinst} install || die "make install failed"
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ make DESTDIR=${D} ${myinst} install || die "make install failed"
- dodoc ChangeLog* README TODO
+ dodoc ChangeLog* README TODO
}
pkg_postinst() {
- # media-video/nvidia-kernel does the following:
- [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
-
- echo
- einfo "Now load the oprofile module by running:"
- einfo " # opcontrol --init"
- einfo "Then read manpages and this html doc:"
- einfo " /usr/share/doc/oprofile/oprofile.html"
- echo
+ # media-video/nvidia-kernel does the following:
+ [ -x /usr/sbin/update-modules ] && /usr/sbin/update-modules
+
+ echo
+ einfo "Now load the oprofile module by running:"
+ einfo " # opcontrol --init"
+ einfo "Then read manpages and this html doc:"
+ einfo " /usr/share/doc/oprofile/oprofile.html"
+ echo
}