summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Yao <ryao@gentoo.org>2012-10-17 15:51:49 +0000
committerRichard Yao <ryao@gentoo.org>2012-10-17 15:51:49 +0000
commit8bc97c3f3037a979f8e5a92cfb9e650d16ea27ae (patch)
treea2baa0f39e0058d9596d5c559e1086da7397c8f8 /dev-util/pkgconf
parentFix Homepage and GIT url (diff)
downloadgentoo-2-8bc97c3f3037a979f8e5a92cfb9e650d16ea27ae.tar.gz
gentoo-2-8bc97c3f3037a979f8e5a92cfb9e650d16ea27ae.tar.bz2
gentoo-2-8bc97c3f3037a979f8e5a92cfb9e650d16ea27ae.zip
Bump pkgconf to 0.8.9
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/ChangeLog8
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.9.ebuild46
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild7
3 files changed, 56 insertions, 5 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index e26f01b41e73..deccc643f3a6 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.50 2012/10/17 15:26:53 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.51 2012/10/17 15:51:49 ryao Exp $
+
+*pkgconf-0.8.9 (17 Oct 2012)
+
+ 17 Oct 2012; Richard Yao <ryao@gentoo.org> +pkgconf-0.8.9.ebuild,
+ pkgconf-0.8.5.ebuild, pkgconf-0.8.7.ebuild, pkgconf-9999.ebuild:
+ Bump pkgconf to 0.8.9
17 Oct 2012; Richard Yao <ryao@gentoo.org> pkgconf-0.8.5.ebuild,
pkgconf-0.8.7.ebuild, pkgconf-9999.ebuild:
diff --git a/dev-util/pkgconf/pkgconf-0.8.9.ebuild b/dev-util/pkgconf/pkgconf-0.8.9.ebuild
new file mode 100644
index 000000000000..11a1a88fe6dc
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.9.ebuild,v 1.1 2012/10/17 15:51:49 ryao Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
+ inherit autotools git-2
+else
+ inherit autotools vcs-snapshot
+ inherit eutils
+ SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/pkgconf/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 5d0d58a8656f..b8dc762127c8 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.11 2012/10/17 15:26:53 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-9999.ebuild,v 1.12 2012/10/17 15:51:49 ryao Exp $
EAPI="4"
@@ -8,9 +8,8 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/pkgconf/pkgconf.git"
inherit autotools git-2
else
- #inherit autotools vcs-snapshot
- #SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
- SRC_URI="http://tortois.es/~nenolod/distfiles/${P}.tar.bz2"
+ inherit autotools vcs-snapshot
+ SRC_URI="https://github.com/pkgconf/pkgconf/tarball/${P} -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd"
fi