summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeff Horelick <jdhore@gentoo.org>2012-08-20 13:46:40 +0000
committerJeff Horelick <jdhore@gentoo.org>2012-08-20 13:46:40 +0000
commit900a32ad7728b03c3477539a83c4b36d8629ce16 (patch)
tree9245bc6c5a5c879e1554b594c5f80d69f3b8de93 /dev-util/pkgconf
parent... and clean up the python bits (diff)
downloadgentoo-2-900a32ad7728b03c3477539a83c4b36d8629ce16.tar.gz
gentoo-2-900a32ad7728b03c3477539a83c4b36d8629ce16.tar.bz2
gentoo-2-900a32ad7728b03c3477539a83c4b36d8629ce16.zip
Version bump
(Portage version: 2.2.0_alpha121/cvs/Linux i686)
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/ChangeLog7
-rw-r--r--dev-util/pkgconf/pkgconf-0.8.7.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-util/pkgconf/ChangeLog b/dev-util/pkgconf/ChangeLog
index b687a0e73180..4893ff17d3d1 100644
--- a/dev-util/pkgconf/ChangeLog
+++ b/dev-util/pkgconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconf
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.45 2012/08/05 13:31:45 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/ChangeLog,v 1.46 2012/08/20 13:46:40 jdhore Exp $
+
+*pkgconf-0.8.7 (20 Aug 2012)
+
+ 20 Aug 2012; Jeff Horelick <jdhore@gentoo.org> +pkgconf-0.8.7.ebuild:
+ Version bump
05 Aug 2012; Fabian Groffen <grobian@gentoo.org> pkgconf-0.8.5.ebuild:
Marked ~{ppc,x86,x64}-macos, ~{x86,x64}-freebsd
diff --git a/dev-util/pkgconf/pkgconf-0.8.7.ebuild b/dev-util/pkgconf/pkgconf-0.8.7.ebuild
new file mode 100644
index 000000000000..6a1c4c83118f
--- /dev/null
+++ b/dev-util/pkgconf/pkgconf-0.8.7.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconf/pkgconf-0.8.7.ebuild,v 1.1 2012/08/20 13:46:40 jdhore Exp $
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/nenolod/pkgconf.git"
+ inherit autotools git-2
+else
+ #inherit autotools vcs-snapshot
+ inherit eutils
+ #SRC_URI="https://github.com/nenolod/pkgconf/tarball/${P} -> ${P}.tar.gz"
+ SRC_URI="http://tortois.es/~nenolod/distfiles/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ppc-macos ~x64-macos ~x86-macos"
+fi
+
+DESCRIPTION="pkg-config compatible replacement with no dependencies other than ANSI C89"
+HOMEPAGE="https://github.com/nenolod/pkgconf"
+
+LICENSE="BSD-1"
+SLOT="0"
+IUSE="+pkg-config strict"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkg-config-lite
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ )"
+
+src_prepare() {
+ [[ -e configure ]] || AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable strict)
+}
+
+src_install() {
+ default
+ use pkg-config \
+ && dosym pkgconf /usr/bin/pkg-config \
+ || rm "${ED}"/usr/share/aclocal/pkg.m4 \
+ || die
+}