summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-07-18 10:27:06 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-07-18 10:27:06 +0000
commitc857f85e5399379838e27c2027df286e364337f5 (patch)
tree887d27a94d7a710b92437d3577549eb9a6926e53 /dev-util/pkgconfig/files
parentVersion bumped. (diff)
downloadgentoo-2-c857f85e5399379838e27c2027df286e364337f5.tar.gz
gentoo-2-c857f85e5399379838e27c2027df286e364337f5.tar.bz2
gentoo-2-c857f85e5399379838e27c2027df286e364337f5.zip
Adding patch to fix compile-time tests (bug #98651)
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/pkgconfig/files')
-rw-r--r--dev-util/pkgconfig/files/pkg-config-0.18.1-checks.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/pkgconfig/files/pkg-config-0.18.1-checks.patch b/dev-util/pkgconfig/files/pkg-config-0.18.1-checks.patch
new file mode 100644
index 000000000000..2b09a64ac7fa
--- /dev/null
+++ b/dev-util/pkgconfig/files/pkg-config-0.18.1-checks.patch
@@ -0,0 +1,26 @@
+diff -NurdB pkg-config-0.18.1/check/Makefile.am pkg-config-0.18.1-patched/check/Makefile.am
+--- pkg-config-0.18.1/check/Makefile.am 2005-06-27 14:37:41.000000000 -0500
++++ pkg-config-0.18.1-patched/check/Makefile.am 2005-07-18 03:46:37.000000000 -0500
+@@ -1,6 +1,9 @@
+
+-TESTS = check-cflags check-libs check-define-variable \
+- check-libs-private check-requires-private
++TESTS = check-cflags check-define-variable check-libs-private
++
++if !ENABLE_INDIRECT_DEPS
++TESTS += check-libs check-requires-private
++endif
+
+ EXTRA_DIST = $(TESTS) common simple.pc requires-test.pc public-dep.pc \
+ private-dep.pc
+diff -NurdB pkg-config-0.18.1/configure.in pkg-config-0.18.1-patched/configure.in
+--- pkg-config-0.18.1/configure.in 2005-06-29 06:07:14.000000000 -0500
++++ pkg-config-0.18.1-patched/configure.in 2005-07-18 03:32:07.000000000 -0500
+@@ -59,6 +59,7 @@
+ AC_MSG_RESULT($use_indirect_deps)
+
+ AC_DEFINE_UNQUOTED(ENABLE_INDIRECT_DEPS, `test $use_indirect_deps = no; echo $?`, [Link library to all dependent libraries, not only directly needed ones])
++AM_CONDITIONAL(ENABLE_INDIRECT_DEPS, test x$use_indirect_deps = xyes)
+
+ AC_MSG_CHECKING([for Win32])
+ case "$host" in