summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2015-06-01 12:52:12 +0000
committerMichael Weber <xmw@gentoo.org>2015-06-01 12:52:12 +0000
commitd486110ceef6daa7f475219897bada5a9c6c9948 (patch)
tree26f670a955c48bc5cf350e7300cf6a81bc647233 /dev-util/pycharm-community
parentVersion bump (thanks Manuel Rüger, 550276). (diff)
downloadgentoo-2-d486110ceef6daa7f475219897bada5a9c6c9948.tar.gz
gentoo-2-d486110ceef6daa7f475219897bada5a9c6c9948.tar.bz2
gentoo-2-d486110ceef6daa7f475219897bada5a9c6c9948.zip
Version bump (thanks Manuel Rüger, 550276).
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/pycharm-community')
-rw-r--r--dev-util/pycharm-community/ChangeLog8
-rw-r--r--dev-util/pycharm-community/pycharm-community-4.0.6.ebuild4
-rw-r--r--dev-util/pycharm-community/pycharm-community-4.5.1.ebuild38
3 files changed, 47 insertions, 3 deletions
diff --git a/dev-util/pycharm-community/ChangeLog b/dev-util/pycharm-community/ChangeLog
index 4631d0bf0244..b2ed914afc66 100644
--- a/dev-util/pycharm-community/ChangeLog
+++ b/dev-util/pycharm-community/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/pycharm-community
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pycharm-community/ChangeLog,v 1.5 2015/04/28 20:29:05 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pycharm-community/ChangeLog,v 1.6 2015/06/01 12:52:12 xmw Exp $
+
+*pycharm-community-4.5.1 (01 Jun 2015)
+
+ 01 Jun 2015; Michael Weber <xmw@gentoo.org> +pycharm-community-4.5.1.ebuild,
+ pycharm-community-4.0.6.ebuild:
+ Version bump (thanks Manuel Rüger, 550276).
*pycharm-community-4.0.6 (28 Apr 2015)
diff --git a/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild b/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild
index 99dd440520fd..e544abbe80ec 100644
--- a/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild
+++ b/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild,v 1.1 2015/04/28 20:29:05 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pycharm-community/pycharm-community-4.0.6.ebuild,v 1.2 2015/06/01 12:52:12 xmw Exp $
EAPI=5
@@ -8,7 +8,7 @@ inherit eutils readme.gentoo
DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
HOMEPAGE="http://www.jetbrains.com/pycharm/"
-SRC_URI="https://download.jetbrains.com/python/${P}.tar.gz"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
SLOT="0"
diff --git a/dev-util/pycharm-community/pycharm-community-4.5.1.ebuild b/dev-util/pycharm-community/pycharm-community-4.5.1.ebuild
new file mode 100644
index 000000000000..2a18f9dbb071
--- /dev/null
+++ b/dev-util/pycharm-community/pycharm-community-4.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pycharm-community/pycharm-community-4.5.1.ebuild,v 1.1 2015/06/01 12:52:12 xmw Exp $
+
+EAPI=5
+
+inherit eutils readme.gentoo
+
+DESCRIPTION="Intelligent Python IDE with unique code assistance and analysis"
+HOMEPAGE="http://www.jetbrains.com/pycharm/"
+SRC_URI="http://download.jetbrains.com/python/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD CDDL MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=""
+
+RESTRICT="mirror strip"
+QA_PREBUILT="/opt/${PN}/bin/fsnotifier
+ /opt/${PN}/bin/fsnotifier64"
+
+MY_PN=${PN/-community/}
+
+src_install() {
+ insinto /opt/${PN}
+ doins -r *
+
+ fperms a+x /opt/${PN}/bin/{pycharm.sh,fsnotifier{,64},inspect.sh}
+
+ dosym /opt/${PN}/bin/pycharm.sh /usr/bin/${PN}
+ newicon "bin/${MY_PN}.png" ${PN}.png
+ make_desktop_entry ${PN} "${PN}" "${PN}"
+
+ readme.gentoo_src_install
+}