summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:24:41 +0000
committerGunnar Wrobel <wrobel@gentoo.org>2008-01-25 08:24:41 +0000
commit9bb81ff6820676771d95dcaee1e1813a12c7e46f (patch)
treeb90c3658b17d3c24d0e81fb044c4cf038b697a9c /dev-util/qsoapman
parentlicense for worldofpadman (diff)
downloadgentoo-2-9bb81ff6820676771d95dcaee1e1813a12c7e46f.tar.gz
gentoo-2-9bb81ff6820676771d95dcaee1e1813a12c7e46f.tar.bz2
gentoo-2-9bb81ff6820676771d95dcaee1e1813a12c7e46f.zip
Added qsoapman-0.4 (#201661).
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util/qsoapman')
-rw-r--r--dev-util/qsoapman/ChangeLog9
-rw-r--r--dev-util/qsoapman/files/digest-qsoapman-0.43
-rw-r--r--dev-util/qsoapman/qsoapman-0.4.ebuild36
3 files changed, 46 insertions, 2 deletions
diff --git a/dev-util/qsoapman/ChangeLog b/dev-util/qsoapman/ChangeLog
index 223b9ec95508..0a47a263086c 100644
--- a/dev-util/qsoapman/ChangeLog
+++ b/dev-util/qsoapman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/qsoapman
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/qsoapman/ChangeLog,v 1.9 2007/02/22 02:24:30 peper Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qsoapman/ChangeLog,v 1.10 2008/01/25 08:24:41 wrobel Exp $
+
+*qsoapman-0.4 (25 Jan 2008)
+
+ 25 Jan 2008; <wrobel@gentoo.org> +qsoapman-0.4.ebuild:
+ Added qsoapman-0.4 (#201661).
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-util/qsoapman/files/digest-qsoapman-0.4 b/dev-util/qsoapman/files/digest-qsoapman-0.4
new file mode 100644
index 000000000000..08304ecc6809
--- /dev/null
+++ b/dev-util/qsoapman/files/digest-qsoapman-0.4
@@ -0,0 +1,3 @@
+MD5 ba7f094f0b38ce587ed44014e7da52c9 qsoapman-0.4.tar.gz 53819
+RMD160 370238a9beb8232da688b05b0ed915b0ec8adc6b qsoapman-0.4.tar.gz 53819
+SHA256 fd95b08fea2fb8ec1fa946e167f74217a967e1e399fec9dad2559da244eb5277 qsoapman-0.4.tar.gz 53819
diff --git a/dev-util/qsoapman/qsoapman-0.4.ebuild b/dev-util/qsoapman/qsoapman-0.4.ebuild
new file mode 100644
index 000000000000..9523ec0f50d3
--- /dev/null
+++ b/dev-util/qsoapman/qsoapman-0.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/qsoapman/qsoapman-0.4.ebuild,v 1.1 2008/01/25 08:24:41 wrobel Exp $
+
+inherit qt3
+
+IUSE=""
+
+DESCRIPTION="Qt SOAP Manager is a GUI tool for sending SOAP messages."
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://qsoapman.sourceforge.net/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+LICENSE="GPL-2"
+
+DEPEND="$(qt_min_version 3.1)"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ ${QTDIR}/bin/qmake -o Makefile qsoapman.pro
+ sed -i -e "s/CFLAGS = -pipe -Wall -W -O2/CFLAGS = ${CFLAGS} -Wall -W/" src/Makefile
+ sed -i -e "s/CXXFLAGS = -pipe -Wall -W -O2/CXXFLAGS = ${CXXFLAGS} -Wall -W/" src/Makefile
+
+ addpredict ${QTDIR}/etc/settings
+
+ emake || die "make failed"
+}
+
+src_install () {
+ insinto /usr/share/${PN}
+ doins *.xml
+ dobin bin/qsoapman
+ dodoc AUTHORS BUGS ChangeLog TODO
+}