summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-02-02 06:50:09 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-02-02 06:50:09 +0000
commit4e4b5c4bd5b9829eedba74b6db9ad6689ddc3f49 (patch)
tree7db4ad400821fc945676d6b7d4bf07f3985bc437 /dev-util/re2c/re2c-0.13.5-r1.ebuild
parentKill off the sse2 USE flag from the 3.1 ebuilds as its been dropped. Closes b... (diff)
downloadgentoo-2-4e4b5c4bd5b9829eedba74b6db9ad6689ddc3f49.tar.gz
gentoo-2-4e4b5c4bd5b9829eedba74b6db9ad6689ddc3f49.tar.bz2
gentoo-2-4e4b5c4bd5b9829eedba74b6db9ad6689ddc3f49.zip
Cleanup ebuild: drop already applied patch, don't fix tarball permissions, switch to EAPI=4. Approved by robbat2.
(Portage version: 2.2.0_alpha84_p47/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/re2c/re2c-0.13.5-r1.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.13.5-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.13.5-r1.ebuild b/dev-util/re2c/re2c-0.13.5-r1.ebuild
new file mode 100644
index 000000000000..0560281528e5
--- /dev/null
+++ b/dev-util/re2c/re2c-0.13.5-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.13.5-r1.ebuild,v 1.1 2012/02/02 06:50:09 slyfox Exp $
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+MY_PV="${PV/_/.}"
+MY_P="${PN}-${MY_PV}"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dobin re2c
+ doman re2c.1
+ dodoc README CHANGELOG doc/*
+ docinto examples
+ dodoc examples/*.c examples/*.re
+}