summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-08-01 04:31:14 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-08-01 04:31:14 +0000
commit98a50530fbe2005ed2cd1b2a24d8eb76c5dc7804 (patch)
treecf256f0f6027bd64b38d4e99c1c76fbfcdd6ac51 /dev-util/re2c/re2c-0.9.9.ebuild
parentdev-lisp/cl-blog (diff)
downloadgentoo-2-98a50530fbe2005ed2cd1b2a24d8eb76c5dc7804.tar.gz
gentoo-2-98a50530fbe2005ed2cd1b2a24d8eb76c5dc7804.tar.bz2
gentoo-2-98a50530fbe2005ed2cd1b2a24d8eb76c5dc7804.zip
Bugs #100620 and #100914 fixed, version bump.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-util/re2c/re2c-0.9.9.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.9.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.9.9.ebuild b/dev-util/re2c/re2c-0.9.9.ebuild
new file mode 100644
index 000000000000..44d210dd46b0
--- /dev/null
+++ b/dev-util/re2c/re2c-0.9.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.9.9.ebuild,v 1.1 2005/08/01 04:31:14 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="|| ( >=dev-util/byacc-1.9 >=sys-devel/bison-2.0 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A} || die
+ # Fix permissions
+ chmod -R u+rw ${S}
+}
+
+src_compile() {
+ econf || die
+ emake -e || die
+}
+
+src_install() {
+ dobin re2c || die "dobin failed"
+ doman re2c.1 || die "doman failed"
+ dodoc README CHANGELOG doc/* && \
+ docinto examples && \
+ dodoc examples/*.c examples/*.re || die "docs failed"
+}