summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-08-14 11:08:21 +0000
committerJustin Lecher <jlec@gentoo.org>2012-08-14 11:08:21 +0000
commit5a5171329e087a5fcd7ce7d86713c786c218b604 (patch)
tree8100189d07c9c51c98a519dd2e8ff7b1d879abd8 /dev-util/rec
parentsci-misc/netlogo-bin: Use QA_PREBUILt for binary packages, #431124 (diff)
downloadgentoo-2-5a5171329e087a5fcd7ce7d86713c786c218b604.tar.gz
gentoo-2-5a5171329e087a5fcd7ce7d86713c786c218b604.tar.bz2
gentoo-2-5a5171329e087a5fcd7ce7d86713c786c218b604.zip
dev-util/rec: Use QA_PREBUILt for binary packages, #430978
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/rec')
-rw-r--r--dev-util/rec/ChangeLog7
-rw-r--r--dev-util/rec/rec-1.6.ebuild22
2 files changed, 22 insertions, 7 deletions
diff --git a/dev-util/rec/ChangeLog b/dev-util/rec/ChangeLog
index c9c85ac7e52f..fb0db8515f22 100644
--- a/dev-util/rec/ChangeLog
+++ b/dev-util/rec/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/rec
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rec/ChangeLog,v 1.7 2010/02/21 11:59:15 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rec/ChangeLog,v 1.8 2012/08/14 11:08:21 jlec Exp $
+
+ 14 Aug 2012; Justin Lecher <jlec@gentoo.org> rec-1.6.ebuild:
+ Use QA_PREBUILt for binary packages, #430978
21 Feb 2010; Patrick Lauer <patrick@gentoo.org> rec-1.6.ebuild:
Adding ~amd64 for #302892
diff --git a/dev-util/rec/rec-1.6.ebuild b/dev-util/rec/rec-1.6.ebuild
index 23e1a9dd1ae4..514988bc5815 100644
--- a/dev-util/rec/rec-1.6.ebuild
+++ b/dev-util/rec/rec-1.6.ebuild
@@ -1,29 +1,41 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rec/rec-1.6.ebuild,v 1.7 2010/02/21 11:59:15 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rec/rec-1.6.ebuild,v 1.8 2012/08/14 11:08:21 jlec Exp $
+
+EAPI=4
inherit eutils
DESCRIPTION="Reverse Engineering Compiler"
HOMEPAGE="http://www.backerstreet.com/rec/rec.htm"
SRC_URI="http://www.backerstreet.com/rec/rec16lx.zip"
+
LICENSE="as-is"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
+
RESTRICT="strip"
+
DEPEND="app-arch/unzip"
-RDEPEND="sys-libs/ncurses sys-libs/gpm"
+RDEPEND="
+ sys-libs/ncurses
+ sys-libs/gpm"
+
S=${WORKDIR}
+QA_PREBUILT="/opt/bin/rec"
+
src_unpack() {
unzip -L -d "${S}" -q "${DISTDIR}/${A}" || die
}
-src_compile() {
- sed -i 's#\(^.*$\)#/opt/rec/\1#g' proto.lst
+src_prepare() {
+ sed -i 's#\(^.*$\)#/opt/rec/\1#g' proto.lst || die
}
+src_compile() { :; }
+
src_install() {
dodir /opt/rec
into /opt