summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-05-17 05:59:43 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-05-17 05:59:43 +0000
commite91f47da9d535a8177ca2887f03841e382c12927 (patch)
treec40e92d5e39e7a31b2b3fe87feff432316859925 /dev-util/shc/shc-3.6.ebuild
parentnew version, now builds with icc (diff)
downloadgentoo-2-e91f47da9d535a8177ca2887f03841e382c12927.tar.gz
gentoo-2-e91f47da9d535a8177ca2887f03841e382c12927.tar.bz2
gentoo-2-e91f47da9d535a8177ca2887f03841e382c12927.zip
new version
Diffstat (limited to 'dev-util/shc/shc-3.6.ebuild')
-rw-r--r--dev-util/shc/shc-3.6.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/shc/shc-3.6.ebuild b/dev-util/shc/shc-3.6.ebuild
new file mode 100644
index 000000000000..35a25eaaf73b
--- /dev/null
+++ b/dev-util/shc/shc-3.6.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.6.ebuild,v 1.1 2003/05/17 05:59:31 george Exp $
+
+IUSE=""
+
+DESCRIPTION="A (shell-) script compiler/scrambler."
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+ ## the "test"-target leads to an access-violation -> so we skip it
+ ## as it's only for demonstration purposes anyway.
+ make shc || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe shc
+ doman shc.1
+ dodoc shc.README CHANGES
+}