summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-09 23:48:14 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-09 23:48:14 +0000
commit5e79f0a62b118514e19be106ee76679ffa18f9f2 (patch)
tree452f5db4ac74bd60f429679f14d49f2863916f9c /dev-util/strace
parentAdd upstream CPE tag (security info) from ChromiumOS. (diff)
downloadgentoo-2-5e79f0a62b118514e19be106ee76679ffa18f9f2.tar.gz
gentoo-2-5e79f0a62b118514e19be106ee76679ffa18f9f2.tar.bz2
gentoo-2-5e79f0a62b118514e19be106ee76679ffa18f9f2.zip
Version bump.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'dev-util/strace')
-rw-r--r--dev-util/strace/ChangeLog7
-rw-r--r--dev-util/strace/strace-4.8.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-util/strace/ChangeLog b/dev-util/strace/ChangeLog
index c43019f8d8af..1d54b64f59f3 100644
--- a/dev-util/strace/ChangeLog
+++ b/dev-util/strace/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/strace
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.187 2013/05/02 17:28:35 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/ChangeLog,v 1.188 2013/06/09 23:48:14 vapier Exp $
+
+*strace-4.8 (09 Jun 2013)
+
+ 09 Jun 2013; Mike Frysinger <vapier@gentoo.org> +strace-4.8.ebuild:
+ Version bump.
02 May 2013; Mike Frysinger <vapier@gentoo.org> strace-4.7.ebuild,
strace-9999.ebuild:
diff --git a/dev-util/strace/strace-4.8.ebuild b/dev-util/strace/strace-4.8.ebuild
new file mode 100644
index 000000000000..ebbc26480086
--- /dev/null
+++ b/dev-util/strace/strace-4.8.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/strace/strace-4.8.ebuild,v 1.1 2013/06/09 23:48:14 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic eutils
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://strace.git.sourceforge.net/gitroot/strace/strace"
+ inherit git-2 autotools
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux"
+fi
+
+DESCRIPTION="A useful diagnostic, instructional, and debugging tool"
+HOMEPAGE="http://sourceforge.net/projects/strace/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="static aio"
+
+# strace only uses the header from libaio to decode structs
+DEPEND="aio? ( >=dev-libs/libaio-0.3.106 )
+ sys-kernel/linux-headers"
+RDEPEND=""
+
+src_prepare() {
+ if epatch_user || [[ ! -e configure ]] ; then
+ # git generation
+ eautoreconf
+ [[ ! -e CREDITS ]] && cp CREDITS{.in,}
+ fi
+
+ filter-lfs-flags # configure handles this sanely
+ use static && append-ldflags -static
+
+ export ac_cv_header_libaio_h=$(usex aio)
+}
+
+src_install() {
+ default
+ dodoc CREDITS
+}