summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeert Bevin <gbevin@gentoo.org>2002-02-07 08:30:58 +0000
committerGeert Bevin <gbevin@gentoo.org>2002-02-07 08:30:58 +0000
commit449096cdc7ed9054835bef00f79ae029a68cb165 (patch)
tree672441c027669f83b9ed8a4610635a769540d89b /dev-util/subversion
parenta bunch of wmmaker dockups (diff)
downloadgentoo-2-449096cdc7ed9054835bef00f79ae029a68cb165.tar.gz
gentoo-2-449096cdc7ed9054835bef00f79ae029a68cb165.tar.bz2
gentoo-2-449096cdc7ed9054835bef00f79ae029a68cb165.zip
Committed to be able to work on it elsewhere, DON'T USE !
Diffstat (limited to 'dev-util/subversion')
-rw-r--r--dev-util/subversion/ChangeLog25
-rw-r--r--dev-util/subversion/files/digest-subversion-0.8.03
-rw-r--r--dev-util/subversion/subversion-0.8.0.ebuild96
3 files changed, 124 insertions, 0 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
new file mode 100644
index 000000000000..4ec23dfa0271
--- /dev/null
+++ b/dev-util/subversion/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.1 2002/02/07 08:30:58 gbevin Exp $
+
+*<PACKAGE_NAME>-<PACKAGE_VERSION>-<PACKAGE_RELEASE> (<DATE>)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> skel.ChangeLog :
+
+ This changelog is targetted to users. This means that the comments should be
+ well explained and written in clean English.
+
+ Every new version or revision of the package has to be marked by a '*'
+ seperator line as above. Changements since the last revision have to be
+ added to the top of the file, underneath the initial copyright and cvs header
+ comments, in exactly the same format as this comment.
+
+ This means that you start with header line that has the following format :
+
+ date; your_name <your_email> changed_file1, changed_file2 :
+
+ Below that line your explanation should follow. It has to be indented,
+ paragraphed and wrapped at a linewidth of 80 characters.
+
+ Any details about what exactly changed in the code should be added as a
+ message when the changes are committed to cvs, not in this file.
diff --git a/dev-util/subversion/files/digest-subversion-0.8.0 b/dev-util/subversion/files/digest-subversion-0.8.0
new file mode 100644
index 000000000000..a737b945e12c
--- /dev/null
+++ b/dev-util/subversion/files/digest-subversion-0.8.0
@@ -0,0 +1,3 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799
+MD5 cea9af10feb49aa9e6cae8a8b86c02e9 httpd-2_0_31-alpha.tar.gz 3861625
+MD5 7335ea5fef7eb796c648490ab70a5f8b subversion-r909.tar.gz 3880260
diff --git a/dev-util/subversion/subversion-0.8.0.ebuild b/dev-util/subversion/subversion-0.8.0.ebuild
new file mode 100644
index 000000000000..b8d92713ecb9
--- /dev/null
+++ b/dev-util/subversion/subversion-0.8.0.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Geert Bevin <gbevin@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.8.0.ebuild,v 1.1 2002/02/07 08:30:58 gbevin Exp $
+
+S=${WORKDIR}/subversion-r909
+S_BDB=${WORKDIR}/db-4.0.14/build_unix
+S_APACHE=${WORKDIR}/httpd-2_0_31
+I_BDB=${WORKDIR}/tmpinstall_db-4.0.14
+I_APACHE=${WORKDIR}/tmpinstall_httpd-2_0_31
+
+DESCRIPTION="A compelling replacement for CVS"
+SRC_URI="http://www.tigris.org/files/15/63/subversion-r909.tar.gz
+ http://www.sleepycat.com/update/4.0.14/db-4.0.14.tar.gz
+ http://www.apache.org/dist/httpd/httpd-2_0_31-alpha.tar.gz"
+HOMEPAGE="http://subversion.tigris.org/"
+
+DEPEND="virtual/glibc
+ >=dev-lang/python-2.0
+ >=sys-apps/diffutils-2.7.7
+ >=sys-devel/libtool-1.4.1-r1
+ >=sys-devel/bison-1.28-r3"
+RDEPEND="virtual/glibc
+ >=dev-lang/python-2.0
+ >=sys-apps/diffutils-2.7.7"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -rf apr
+}
+
+src_compile() {
+ svnpaths="--prefix=/usr/svn \
+ --mandir=/usr/svn/share/man \
+ --infodir=/usr/svn/share/info \
+ --datadir=/usr/svn/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --host=${CHOST}"
+
+ cd ${S_BDB}
+ ../dist/configure \
+ $svnpaths
+ emake || die "make of berkeley db failed"
+ make prefix=${I_BDB} install || die "temporary installation of berkeley db failed"
+ export LD_LIBRARY_PATH="${I_BDB}/lib:${LD_LIBRARY_PATH}"
+
+ cd ${S_APACHE}
+ ./buildconf
+ ./configure \
+ $svnpaths \
+ --enable-so \
+ --enable-dav \
+ --with-dbm=db4 \
+ --with-berkeley-db=${I_BDB} \
+ --enable-maintainer-mode || die "./configure of apache failed"
+ make depend
+ mv srclib/pcre/Makefile srclib/pcre/Makefile_orig
+ sed -e "s#./dftables#LD_LIBRARY_PATH=\"${LD_LIBRARY_PATH}\" ./dftables#" \
+ srclib/pcre/Makefile_orig > srclib/pcre/Makefile
+ mv server/Makefile server/Makefile_orig
+ sed -e "s#./gen_test_char#LD_LIBRARY_PATH=\"${LD_LIBRARY_PATH}\" ./gen_test_char#" \
+ server/Makefile_orig > server/Makefile
+ emake || die "make of apache failed"
+ make prefix=${I_APACHE} install || die "temporary installation of apache failed"
+ mv ${I_APACHE}/bin/apxs ${I_APACHE}/bin/apxs_orig
+ sed -e "s#/usr/svn#${I_APACHE}#" \
+ ${I_APACHE}/bin/apxs_orig > ${I_APACHE}/bin/apxs
+ chmod +x ${I_APACHE}/bin/apxs
+ export LD_LIBRARY_PATH="${I_APACHE}/lib:${LD_LIBRARY_PATH}"
+
+ cd ${S}
+ ./configure \
+ $svnpaths \
+ --with-berkeley-db=${I_BDB} \
+ --with-apr=${I_APACHE} \
+ --with-apr-util=${I_APACHE} \
+ --with-apxs=${I_APACHE}/bin/apxs \
+ --enable-maintainer-mode || die "./configure of subversion failed"
+ emake || die "make of subversion failed"
+}
+
+src_install () {
+ cd ${S_BDB}
+ make prefix=${D}/usr/svn install || die "installation of berkeley db failed"
+
+ cd ${S_APACHE}
+ make prefix=${D}/usr/svn install || die "installation of apache failed"
+
+ cd ${S}
+ make LD_LIBRARY_PATH="${D}/usr/svn/lib:${LD_LIBRARY_PATH}" \
+ prefix=${D}/usr/svn install \
+ mandir={D}/usr/svn/share/man \
+ infodir={D}/usr/svn/share/info || die "installation of subversion failed"
+}