summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-08-09 13:30:14 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-08-09 13:30:14 +0000
commit69e679ff3d2a6e9cbd81b65f34fcd873a6ec85b4 (patch)
tree4a927e90118710f22ac5a9e718d368bbbf7b17e8 /dev-util/valgrind
parentRemove no-nptl profiles because there is no sys-libs/glibc < 2.6 available. (diff)
downloadgentoo-2-69e679ff3d2a6e9cbd81b65f34fcd873a6ec85b4.tar.gz
gentoo-2-69e679ff3d2a6e9cbd81b65f34fcd873a6ec85b4.tar.bz2
gentoo-2-69e679ff3d2a6e9cbd81b65f34fcd873a6ec85b4.zip
Patch to allow valgrind to build against glibc-2.14, bug #378157
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/valgrind')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch26
-rw-r--r--dev-util/valgrind/valgrind-3.6.1-r2.ebuild103
3 files changed, 136 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 3c2cdf9a1679..9747f3491eba 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.124 2011/06/09 20:38:30 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.125 2011/08/09 13:30:13 blueness Exp $
+
+*valgrind-3.6.1-r2 (09 Aug 2011)
+
+ 09 Aug 2011; Anthony G. Basile <blueness@gentoo.org>
+ +valgrind-3.6.1-r2.ebuild, +files/valgrind-3.6.1-glibc-2.14.patch:
+ Added patch to allow valgrind to build against glibc-2.14, bug #378157
*valgrind-3.6.1-r1 (09 Jun 2011)
diff --git a/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch b/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch
new file mode 100644
index 000000000000..446efac118ce
--- /dev/null
+++ b/dev-util/valgrind/files/valgrind-3.6.1-glibc-2.14.patch
@@ -0,0 +1,26 @@
+diff -Naur valgrind-3.6.1.orig/configure.in valgrind-3.6.1/configure.in
+--- valgrind-3.6.1.orig/configure.in 2011-08-09 09:06:50.000000000 -0400
++++ valgrind-3.6.1/configure.in 2011-08-09 09:21:42.000000000 -0400
+@@ -756,6 +756,13 @@
+ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
+ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
+ ;;
++ 2.14)
++ AC_MSG_RESULT(2.14 family)
++ AC_DEFINE([GLIBC_2_14], 1, [Define to 1 if you're using glibc 2.14.x])
++ DEFAULT_SUPP="glibc-2.X.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.34567-NPTL-helgrind.supp ${DEFAULT_SUPP}"
++ DEFAULT_SUPP="glibc-2.X-drd.supp ${DEFAULT_SUPP}"
++ ;;
+ aix5)
+ AC_MSG_RESULT(AIX 5.1 or 5.2 or 5.3)
+ AC_DEFINE([AIX5_LIBC], 1, [Define to 1 if you're using AIX 5.1 or 5.2 or 5.3])
+@@ -769,7 +776,7 @@
+
+ *)
+ AC_MSG_RESULT([unsupported version ${GLIBC_VERSION}])
+- AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.13])
++ AC_MSG_ERROR([Valgrind requires glibc version 2.2 - 2.14])
+ AC_MSG_ERROR([or AIX 5.1 or 5.2 or 5.3 GLIBC_VERSION])
+ AC_MSG_ERROR([or Darwin libc])
+ ;;
diff --git a/dev-util/valgrind/valgrind-3.6.1-r2.ebuild b/dev-util/valgrind/valgrind-3.6.1-r2.ebuild
new file mode 100644
index 000000000000..81eb625498f6
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.6.1-r2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.6.1-r2.ebuild,v 1.1 2011/08/09 13:30:13 blueness Exp $
+
+EAPI=2
+inherit autotools eutils flag-o-matic toolchain-funcs multilib pax-utils
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mpi qt4"
+
+DEPEND="mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Respect CFLAGS, LDFLAGS
+ sed -i -e '/^CPPFLAGS =/d' -e '/^CFLAGS =/d' -e '/^LDFLAGS =/d' \
+ mpi/Makefile.am || die
+
+ # Changing Makefile.all.am to disable SSP
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' \
+ Makefile.all.am || die
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${PF}:" \
+ docs/Makefile.am || die
+
+ # Yet more local labels, this time for ppc32 & ppc64
+ epatch "${FILESDIR}"/${PN}-3.6.0-local-labels.patch
+
+ # Don't build in empty assembly files for other platforms or we'll get a QA
+ # warning about executable stacks.
+ epatch "${FILESDIR}"/${PN}-3.6.0-non-exec-stack.patch
+
+ # Fix up some suppressions that were not general enough for glibc versions
+ # with more than just a major and minor number.
+ epatch "${FILESDIR}"/${PN}-3.4.1-glibc-2.10.1.patch
+
+ # Remove automagic dependency on qt4
+ epatch "${FILESDIR}"/${PN}-3.6.1-user-enable-qt4.patch
+
+ # Allow valgrind to build against linux-3, bug #370857
+ epatch "${FILESDIR}"/${PN}-3.6.1-linux-3.patch
+
+ # Allow valgrind to build against glibc-2.14, bug #378157
+ epatch "${FILESDIR}"/${PN}-3.6.1-glibc-2.14.patch
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ # Don't use mpicc unless the user asked for it (bug #258832)
+ if ! use mpi; then
+ myconf="${myconf} --without-mpicc"
+ fi
+
+ if ! use qt4; then
+ myconf="${myconf} --disable-qtcore"
+ fi
+
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS FAQ.txt NEWS README*
+
+ pax-mark m "${D}"/usr/$(get_libdir)/valgrind/*-*-linux
+}
+
+pkg_postinst() {
+ if use ppc || use ppc64 || use amd64 ; then
+ ewarn "Valgrind will not work on ppc, ppc64 or amd64 if glibc does not have"
+ ewarn "debug symbols (see https://bugs.gentoo.org/show_bug.cgi?id=214065"
+ ewarn "and http://bugs.gentoo.org/show_bug.cgi?id=274771)."
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf and"
+ ewarn "remerge glibc."
+ fi
+}