summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2006-12-24 22:05:02 +0000
committerRyan Hill <dirtyepic@gentoo.org>2006-12-24 22:05:02 +0000
commitc29526f0a1a30b7912bfe724d8f3fbd0ddb3d4ec (patch)
tree604266ed14ee5a7529b3de897dbaa5ffb55c059b /dev-util/wxglade
parentmore updates to latest version (diff)
downloadgentoo-2-c29526f0a1a30b7912bfe724d8f3fbd0ddb3d4ec.tar.gz
gentoo-2-c29526f0a1a30b7912bfe724d8f3fbd0ddb3d4ec.tar.bz2
gentoo-2-c29526f0a1a30b7912bfe724d8f3fbd0ddb3d4ec.zip
Version bump. Fixes bug #133213.
(Portage version: 2.1.2_rc4)
Diffstat (limited to 'dev-util/wxglade')
-rw-r--r--dev-util/wxglade/ChangeLog7
-rw-r--r--dev-util/wxglade/files/digest-wxglade-0.4.13
-rw-r--r--dev-util/wxglade/wxglade-0.4.1.ebuild32
3 files changed, 41 insertions, 1 deletions
diff --git a/dev-util/wxglade/ChangeLog b/dev-util/wxglade/ChangeLog
index f5e96ec78bc5..59c6ea39b9b3 100644
--- a/dev-util/wxglade/ChangeLog
+++ b/dev-util/wxglade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/wxglade
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.26 2006/12/24 21:52:00 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/ChangeLog,v 1.27 2006/12/24 22:05:02 dirtyepic Exp $
+
+*wxglade-0.4.1 (24 Dec 2006)
+
+ 24 Dec 2006; Ryan Hill <dirtyepic@gentoo.org> +wxglade-0.4.1.ebuild:
+ Version bump. Fixes bug #133213.
24 Dec 2006; Ryan Hill <dirtyepic@gentoo.org> wxglade-0.4.ebuild:
Update wxpython dependency.
diff --git a/dev-util/wxglade/files/digest-wxglade-0.4.1 b/dev-util/wxglade/files/digest-wxglade-0.4.1
new file mode 100644
index 000000000000..fd5c603518ef
--- /dev/null
+++ b/dev-util/wxglade/files/digest-wxglade-0.4.1
@@ -0,0 +1,3 @@
+MD5 c5d06a450c80743f0adc9136ef91490a wxGlade-0.4.1.tar.gz 521274
+RMD160 e439f4a88ce0cde0da11e5950c20f1df40511129 wxGlade-0.4.1.tar.gz 521274
+SHA256 213282a771d33eb9ffa14d36112058d02e478c565da606d1ec48f914675afe13 wxGlade-0.4.1.tar.gz 521274
diff --git a/dev-util/wxglade/wxglade-0.4.1.ebuild b/dev-util/wxglade/wxglade-0.4.1.ebuild
new file mode 100644
index 000000000000..6c4943a80fa0
--- /dev/null
+++ b/dev-util/wxglade/wxglade-0.4.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wxglade/wxglade-0.4.1.ebuild,v 1.1 2006/12/24 22:05:02 dirtyepic Exp $
+
+inherit python
+
+MY_P="wxGlade-${PV}"
+DESCRIPTION="Glade-like GUI designer which can generate Python, Perl, C++ or XRC code"
+HOMEPAGE="http://wxglade.sourceforge.net/"
+SRC_URI="mirror://sourceforge/wxglade/${MY_P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+S="${WORKDIR}/${MY_P}"
+DEPEND=">=dev-lang/python-2.2
+ >=dev-python/wxpython-2.6"
+
+src_install() {
+ python_version
+ dodir /usr/lib/python${PYVER}/site-packages/${PN}
+ dodoc *txt
+ cp credits.txt ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ dohtml -r docs/*
+ rm -rf docs *txt
+ cp -R * ${D}/usr/lib/python${PYVER}/site-packages/${PN}/
+ dosym /usr/share/doc/${PF}/html /usr/lib/python${PYVER}/site-packages/${PN}/docs
+ echo "#!/bin/bash" > wxglade
+ echo "exec python /usr/lib/python${PYVER}/site-packages/${PN}/wxglade.py \$*" >> wxglade
+ exeinto /usr/bin
+ doexe wxglade
+}