summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Jones <cretin@gentoo.org>2005-05-27 17:35:55 +0000
committerStefan Jones <cretin@gentoo.org>2005-05-27 17:35:55 +0000
commit7c8e49ace74e184adb1b6523cdcb61dbd9114651 (patch)
tree7cedbf151f85548bddaaf710e5e449964b229cac /dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild
parentNew version and cleanup (diff)
downloadgentoo-2-7c8e49ace74e184adb1b6523cdcb61dbd9114651.tar.gz
gentoo-2-7c8e49ace74e184adb1b6523cdcb61dbd9114651.tar.bz2
gentoo-2-7c8e49ace74e184adb1b6523cdcb61dbd9114651.zip
[2~New version and cleanup
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild')
-rw-r--r--dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild b/dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild
new file mode 100644
index 000000000000..50396bad4a81
--- /dev/null
+++ b/dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmingw-w32api/xmingw-w32api-3.2.ebuild,v 1.1 2005/05/27 17:35:55 cretin Exp $
+
+inherit eutils
+
+MY_P=${P/xmingw-}
+RUNTIME=mingw-runtime-3.7
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Free headers and libraries for the Win32 API"
+HOMEPAGE="http://www.mingw.org"
+SRC_URI="mirror://sourceforge/mingw/${RUNTIME}-src.tar.gz
+ mirror://sourceforge/mingw/${MY_P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-util/xmingw-binutils
+ dev-util/xmingw-gcc"
+
+src_unpack() {
+ unpack ${RUNTIME}-src.tar.gz
+ unpack ${MY_P}-src.tar.gz
+ ln -s ${MY_P} w32api
+ ln -s ${RUNTIME} mingw
+ cd ${S} && epatch ${FILESDIR}/xmingw-w32api-3.1-include.patch
+}
+
+src_compile() {
+ export PATH=$PATH:/opt/xmingw/bin:/opt/xmingw/i386-mingw32msvc/bin
+ unset CFLAGS CXXFLAGS
+ RANLIB=i386-mingw32msvc-ranlib \
+ AR=i386-mingw32msvc-ar \
+ AS=i386-mingw32msvc-as \
+ CC=i386-mingw32msvc-gcc \
+ ./configure \
+ --target=i386-mingw32msvc \
+ --prefix=/opt/xmingw/i386-mingw32msvc \
+ --build=i386-mingw32msvc \
+ || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install prefix=${D}/opt/xmingw/i386-mingw32msvc \
+ || die "make install failed"
+}