summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-02-11 18:15:56 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-02-11 18:15:56 +0000
commit87513e3b686d1a9aa20abf953377b1fdf92ed234 (patch)
treedfe35ccb265703dfc6fb79fff649a2ae86830d3b /dev-util/xxdiff/xxdiff-2.9.2.ebuild
parentMake QTDIR/etc/settings a keepdir instead of dodir, so it persists via upgrad... (diff)
downloadgentoo-2-87513e3b686d1a9aa20abf953377b1fdf92ed234.tar.gz
gentoo-2-87513e3b686d1a9aa20abf953377b1fdf92ed234.tar.bz2
gentoo-2-87513e3b686d1a9aa20abf953377b1fdf92ed234.zip
adding workaround to compile. closes 37839.
Diffstat (limited to 'dev-util/xxdiff/xxdiff-2.9.2.ebuild')
-rw-r--r--dev-util/xxdiff/xxdiff-2.9.2.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-util/xxdiff/xxdiff-2.9.2.ebuild b/dev-util/xxdiff/xxdiff-2.9.2.ebuild
index 1060b7460671..8521a9166f01 100644
--- a/dev-util/xxdiff/xxdiff-2.9.2.ebuild
+++ b/dev-util/xxdiff/xxdiff-2.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-2.9.2.ebuild,v 1.4 2004/01/25 19:10:45 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xxdiff/xxdiff-2.9.2.ebuild,v 1.5 2004/02/11 18:15:47 mholzer Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A graphical file and directories comparator and merge tool."
@@ -23,6 +23,15 @@ src_compile() {
cd src
tmake -o Makefile xxdiff.pro
+ REALHOME="$HOME"
+ mkdir -p $T/fakehome/.kde
+ mkdir -p $T/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+
emake || die
}