summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2002-03-27 04:23:04 +0000
committerBruce A. Locke <blocke@gentoo.org>2002-03-27 04:23:04 +0000
commit0adc177328b899d6636fbceb9d3580b91ea2f232 (patch)
tree678734dca281eacce7c2dbff4722bcef975c0875 /dev-util
parentFHS compliance fix. add /var/spool/mail and symlink /var/mail to it. this m... (diff)
downloadgentoo-2-0adc177328b899d6636fbceb9d3580b91ea2f232.tar.gz
gentoo-2-0adc177328b899d6636fbceb9d3580b91ea2f232.tar.bz2
gentoo-2-0adc177328b899d6636fbceb9d3580b91ea2f232.zip
update ltrace to 0.3.23
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ltrace/ChangeLog16
-rw-r--r--dev-util/ltrace/files/digest-ltrace-0.3.231
-rw-r--r--dev-util/ltrace/ltrace-0.3.23.ebuild34
3 files changed, 42 insertions, 9 deletions
diff --git a/dev-util/ltrace/ChangeLog b/dev-util/ltrace/ChangeLog
index 7360a3d0e0ca..6268297fd387 100644
--- a/dev-util/ltrace/ChangeLog
+++ b/dev-util/ltrace/ChangeLog
@@ -1,13 +1,11 @@
# ChangeLog for dev-util/ltrace
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ChangeLog,v 1.2 2002/03/27 04:23:01 blocke Exp $
+
+*ltrace-0.3.23 (26 Mar 2002)
+
+ 26 Mar 2002; Bruce A. Locke <blocke@shivan.org> ltrace-0.3.23.ebuild :
+
+ Ebuild cleanup and update to 0.3.23
-*ltrace-0.3.15 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
diff --git a/dev-util/ltrace/files/digest-ltrace-0.3.23 b/dev-util/ltrace/files/digest-ltrace-0.3.23
new file mode 100644
index 000000000000..76e67fd6ef8d
--- /dev/null
+++ b/dev-util/ltrace/files/digest-ltrace-0.3.23
@@ -0,0 +1 @@
+MD5 7ad003a5c87091bf976ad7224c95cc89 ltrace_0.3.23.tar.gz 80456
diff --git a/dev-util/ltrace/ltrace-0.3.23.ebuild b/dev-util/ltrace/ltrace-0.3.23.ebuild
new file mode 100644
index 000000000000..0f9b2280ad28
--- /dev/null
+++ b/dev-util/ltrace/ltrace-0.3.23.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ltrace/ltrace-0.3.23.ebuild,v 1.1 2002/03/27 04:23:04 blocke Exp $
+
+
+S=${WORKDIR}/${P}
+FILE_VERSION="ltrace_0.3.23"
+DESCRIPTION="ltrace shows runtime library call information for dynamically linked executables"
+SRC_URI="http://ftp.debian.org/debian/pool/main/l/ltrace/${FILE_VERSION}.tar.gz"
+HOMEPAGE="http://packages.debian.org/unstable/utils/ltrace.html"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure --prefix=/usr || die
+
+ # modify CFLAGS (hopefully in a more time friendly way)
+ mv Makefile Makefile.orig
+ sed "s/ -O2 / ${CFLAGS} /" Makefile.orig > Makefile || die "sed failed... newer version of Makefile?"
+
+ emake all || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ # documentation
+ rm -rvf ${D}usr/doc/
+ dodoc BUGS COPYING debian/changelog README TODO
+
+}