summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-07-28 11:45:16 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-07-28 11:45:16 +0000
commit2c2595098f1edd45ac92a6f0af76362da5fe9d71 (patch)
tree22d2a03c3935b15402f9b226aa5eff2a1bca4522 /dev-util
parentVersion bump (diff)
downloadgentoo-2-2c2595098f1edd45ac92a6f0af76362da5fe9d71.tar.gz
gentoo-2-2c2595098f1edd45ac92a6f0af76362da5fe9d71.tar.bz2
gentoo-2-2c2595098f1edd45ac92a6f0af76362da5fe9d71.zip
Version bump wrt security #502536 by Agostino Sarubbo. Pull in virtual/freedesktop-icon-theme, at least for gnome-mime-* icons that are present in gnome-icon-theme, faenza-icon-theme, and other full ones wrt #518294 by Paweł Stankowski. Remove support for Python 3.2 as obsolete.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/catfish/ChangeLog12
-rw-r--r--dev-util/catfish/catfish-1.0.2.ebuild46
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-util/catfish/ChangeLog b/dev-util/catfish/ChangeLog
index e99bd3daaecd..67309497dd0c 100644
--- a/dev-util/catfish/ChangeLog
+++ b/dev-util/catfish/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/catfish
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.13 2013/10/13 09:12:59 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/ChangeLog,v 1.14 2014/07/28 11:45:16 ssuominen Exp $
+
+*catfish-1.0.2 (28 Jul 2014)
+
+ 28 Jul 2014; Samuli Suominen <ssuominen@gentoo.org> +catfish-1.0.2.ebuild:
+ Version bump wrt security #502536 by Agostino Sarubbo. Pull in virtual
+ /freedesktop-icon-theme, at least for gnome-mime-* icons that are present in
+ gnome-icon-theme, faenza-icon-theme, and other full ones wrt #518294 by Paweł
+ Stankowski. Remove support for Python 3.2 as obsolete.
13 Oct 2013; Pacho Ramos <pacho@gentoo.org> catfish-0.6.4.ebuild:
Also compatible with python3_3
diff --git a/dev-util/catfish/catfish-1.0.2.ebuild b/dev-util/catfish/catfish-1.0.2.ebuild
new file mode 100644
index 000000000000..d5d7a908e511
--- /dev/null
+++ b/dev-util/catfish/catfish-1.0.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/catfish/catfish-1.0.2.ebuild,v 1.1 2014/07/28 11:45:16 ssuominen Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+inherit gnome2-utils python-single-r1
+
+DESCRIPTION="A frontend for find, (s)locate, doodle, tracker, beagle, strigi and pinot"
+HOMEPAGE="http://launchpad.net/catfish-search http://twotoasts.de/index.php/catfish/"
+SRC_URI="http://launchpad.net/${PN}-search/${PV%.*}/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}
+ virtual/freedesktop-icon-theme"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ sed -i -e "s:share/doc/\$(APPNAME):share/doc/${PF}:" Makefile.in.in || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr --python="${EPYTHON}" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ python_optimize "${ED}"/usr/share/${PN}
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }