summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2011-09-04 06:29:21 +0000
committerDirkjan Ochtman <djc@gentoo.org>2011-09-04 06:29:21 +0000
commit45f3b45a1cf85eb7e9010a9f2985232a36e8592e (patch)
tree67f0a61554929a7d3053823ff7f41bb0b409bd45 /dev-util
parentTake some fixes from the python overlay. (diff)
downloadgentoo-2-45f3b45a1cf85eb7e9010a9f2985232a36e8592e.tar.gz
gentoo-2-45f3b45a1cf85eb7e9010a9f2985232a36e8592e.tar.bz2
gentoo-2-45f3b45a1cf85eb7e9010a9f2985232a36e8592e.zip
Take some fixes from the python overlay.
(Portage version: 2.1.10.12/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/buildbot/ChangeLog5
-rw-r--r--dev-util/buildbot/buildbot-0.8.4_p2.ebuild22
2 files changed, 18 insertions, 9 deletions
diff --git a/dev-util/buildbot/ChangeLog b/dev-util/buildbot/ChangeLog
index e74046ecd46a..79f382ada89e 100644
--- a/dev-util/buildbot/ChangeLog
+++ b/dev-util/buildbot/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/buildbot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.92 2011/09/03 19:34:00 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/ChangeLog,v 1.93 2011/09/04 06:29:21 djc Exp $
+
+ 04 Sep 2011; Dirkjan Ochtman <djc@gentoo.org> buildbot-0.8.4_p2.ebuild:
+ Take fixes suggested by Arfrever from the python overlay.
*buildbot-0.8.4_p2 (03 Sep 2011)
diff --git a/dev-util/buildbot/buildbot-0.8.4_p2.ebuild b/dev-util/buildbot/buildbot-0.8.4_p2.ebuild
index 9fc3d4db6a50..eecdf15f0617 100644
--- a/dev-util/buildbot/buildbot-0.8.4_p2.ebuild
+++ b/dev-util/buildbot/buildbot-0.8.4_p2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.4_p2.ebuild,v 1.1 2011/09/03 19:34:00 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/buildbot/buildbot-0.8.4_p2.ebuild,v 1.2 2011/09/04 06:29:21 djc Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -51,13 +51,19 @@ pkg_setup() {
enewuser buildbot
}
+src_prepare() {
+ distutils_src_prepare
+ # https://github.com/buildbot/buildbot/commit/a3abed70546b3742964994517bb27556e06f6e20
+ sed -e "s/sqlalchemy-migrate == 0.6/sqlalchemy-migrate ==0.6, ==0.7/" -i setup.py || die "sed failed"
+}
+
src_compile() {
distutils_src_compile
if use doc; then
einfo "Generation of documentation"
pushd docs > /dev/null
- emake buildbot.html buildbot.info || die "Generation of documentation failed"
+ emake buildbot.html buildbot.info
popd > /dev/null
fi
}
@@ -65,20 +71,20 @@ src_compile() {
src_install() {
distutils_src_install
- doman docs/buildbot.1 || die "doman failed"
+ doman docs/buildbot.1
if use doc; then
- dohtml -r docs/buildbot.html docs/images || die "dohtml failed"
- doinfo docs/buildbot.info || die "doinfo failed"
+ dohtml -r docs/buildbot.html docs/images
+ doinfo docs/buildbot.info
fi
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r contrib docs/examples || die "doins failed"
+ doins -r contrib docs/examples
fi
- newconfd "${FILESDIR}/buildmaster.confd" buildmaster || die "newconfd failed"
- newinitd "${FILESDIR}/buildmaster.initd" buildmaster || die "newinitd failed"
+ newconfd "${FILESDIR}/buildmaster.confd" buildmaster
+ newinitd "${FILESDIR}/buildmaster.initd" buildmaster
}
pkg_postinst() {