summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-07-28 17:30:49 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-07-28 17:30:49 +0000
commit487405e1fa602866e93fd5c647a68ad08ef807b6 (patch)
tree72a913b4e83638211ba847f5c986bcb5ba96fc82 /dev-util
parentadded more valid python usedeps (diff)
downloadgentoo-2-487405e1fa602866e93fd5c647a68ad08ef807b6.tar.gz
gentoo-2-487405e1fa602866e93fd5c647a68ad08ef807b6.tar.bz2
gentoo-2-487405e1fa602866e93fd5c647a68ad08ef807b6.zip
Fix underlinking failure with gold (bug #468620, thanks to Justin Lecher).
(Portage version: 2.2.0_alpha190/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/anjuta/ChangeLog6
-rw-r--r--dev-util/anjuta/anjuta-3.8.4.ebuild9
-rw-r--r--dev-util/anjuta/files/anjuta-3.8.4-librt.patch47
3 files changed, 59 insertions, 3 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index c9b8da40dd62..e7b95891f33d 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/anjuta
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.164 2013/06/30 15:38:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.165 2013/07/28 17:30:49 tetromino Exp $
+
+ 28 Jul 2013; Alexandre Rostovtsev <tetromino@gentoo.org> anjuta-3.8.4.ebuild,
+ +files/anjuta-3.8.4-librt.patch:
+ Fix underlinking failure with gold (bug #468620, thanks to Justin Lecher).
30 Jun 2013; Justin Lecher <jlec@gentoo.org> anjuta-3.6.2-r1.ebuild,
anjuta-3.8.3.ebuild, anjuta-3.8.4.ebuild, metadata.xml:
diff --git a/dev-util/anjuta/anjuta-3.8.4.ebuild b/dev-util/anjuta/anjuta-3.8.4.ebuild
index 8ac21886f9fd..ebf5cb50d887 100644
--- a/dev-util/anjuta/anjuta-3.8.4.ebuild
+++ b/dev-util/anjuta/anjuta-3.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-3.8.4.ebuild,v 1.2 2013/06/30 15:38:41 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-3.8.4.ebuild,v 1.3 2013/07/28 17:30:49 tetromino Exp $
EAPI="5"
GCONF_DEBUG="yes"
@@ -11,7 +11,7 @@ PYTHON_COMPAT=( python{2_6,2_7} )
VALA_MIN_API_VERSION="0.20"
VALA_MAX_API_VERSION="${VALA_MIN_API_VERSION}"
-inherit gnome2 flag-o-matic readme.gentoo python-single-r1 vala
+inherit autotools gnome2 flag-o-matic readme.gentoo python-single-r1 vala
DESCRIPTION="A versatile IDE for GNOME"
HOMEPAGE="http://projects.gnome.org/anjuta/"
@@ -100,6 +100,11 @@ will need to:
sed -e 's:$PYTHON-config:$PYTHON$PYTHON_VERSION-config:g' \
-i plugins/am-project/tests/anjuta.lst || die "sed failed"
+ # fix linking with gold, bug #468620, https://bugzilla.gnome.org/show_bug.cgi?id=704985
+ epatch "${FILESDIR}/${PN}-3.8.4-librt.patch"
+
+ eautoreconf # for the librtpatch
+
use vala && vala_src_prepare
gnome2_src_prepare
}
diff --git a/dev-util/anjuta/files/anjuta-3.8.4-librt.patch b/dev-util/anjuta/files/anjuta-3.8.4-librt.patch
new file mode 100644
index 000000000000..c30c7ef92837
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-3.8.4-librt.patch
@@ -0,0 +1,47 @@
+From cefee2f5dff25d56f55c195291fae15cf2254c3f Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Sun, 28 Jul 2013 12:48:52 -0400
+Subject: [PATCH] symbol-db: link with librt on Linux
+
+Fixes underlinking failure when using GNU gold
+
+https://bugzilla.gnome.org/show_bug.cgi?id=704985
+---
+ configure.ac | 6 ++++++
+ plugins/symbol-db/Makefile.am | 3 ++-
+ 2 files changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ba17c93..e68f99d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -758,6 +758,12 @@ fi
+
+ AC_SUBST(SYMBOL_DB_SHM)
+
++dnl On Linux, need librt for shm_open/shm_unlink
++bck_LIBS="$LIBS"
++AC_SEARCH_LIBS(shm_open, rt, [SHM_LIBS="$LIBS"], [AC_MSG_ERROR([Failed to find library with shm_open()])])
++AC_SUBST(SHM_LIBS)
++LIBS="$bck_LIBS"
++
+ dnl Test using autotest
+ dnl -----------------------------
+ AC_CONFIG_TESTDIR(plugins/am-project/tests)
+diff --git a/plugins/symbol-db/Makefile.am b/plugins/symbol-db/Makefile.am
+index 4be13c6..baff48d 100644
+--- a/plugins/symbol-db/Makefile.am
++++ b/plugins/symbol-db/Makefile.am
+@@ -84,7 +84,8 @@ libanjuta_symbol_db_la_LDFLAGS = $(ANJUTA_PLUGIN_LDFLAGS)
+ # Plugin dependencies
+ libanjuta_symbol_db_la_LIBADD = \
+ $(GDA_LIBS) \
+- $(LIBANJUTA_LIBS)
++ $(LIBANJUTA_LIBS) \
++ $(SHM_LIBS)
+
+ BUILT_SOURCES=symbol-db-marshal.c symbol-db-marshal.h
+
+--
+1.8.3.2
+