summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-07-06 02:50:04 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-07-06 02:50:04 +0000
commit5e207f27ef6b99580237c4668a8e387fb6d15ce0 (patch)
tree7292d36b5c478efe8ed678bcc9e065ef7c3d4106 /dev-util
parentPut back eclipse mask. Whoops. (diff)
downloadgentoo-2-5e207f27ef6b99580237c4668a8e387fb6d15ce0.tar.gz
gentoo-2-5e207f27ef6b99580237c4668a8e387fb6d15ce0.tar.bz2
gentoo-2-5e207f27ef6b99580237c4668a8e387fb6d15ce0.zip
Revision bump for 3.1.2 to disable embedded browser support (bug #137665). Version bump to 3.2 (bug #139191).
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-sdk/ChangeLog11
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild9
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r3.ebuild365
-rw-r--r--dev-util/eclipse-sdk/eclipse-sdk-3.2.ebuild304
-rw-r--r--dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.1.2-r33
-rw-r--r--dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.26
6 files changed, 693 insertions, 5 deletions
diff --git a/dev-util/eclipse-sdk/ChangeLog b/dev-util/eclipse-sdk/ChangeLog
index 98464920c093..9e61421e8385 100644
--- a/dev-util/eclipse-sdk/ChangeLog
+++ b/dev-util/eclipse-sdk/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/eclipse-sdk
# Copyright 2003-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.107 2006/07/04 18:04:24 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/ChangeLog,v 1.108 2006/07/06 02:50:04 nichoj Exp $
+
+*eclipse-sdk-3.2 (06 Jul 2006)
+*eclipse-sdk-3.1.2-r3 (06 Jul 2006)
+
+ 06 Jul 2006; Joshua Nichols <jnichols@gentoo.org>
+ eclipse-sdk-3.1.2-r2.ebuild, +eclipse-sdk-3.1.2-r3.ebuild,
+ -eclipse-sdk-3.2_rc7-r1.ebuild, +eclipse-sdk-3.2.ebuild:
+ Revision bump for 3.1.2 to disable embedded browser support (bug #137665).
+ Version bump to 3.2 (bug #139191).
*eclipse-sdk-3.2_rc7-r1 (04 Jul 2006)
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild
index bf6ca0e95852..98ce6a2e23f0 100644
--- a/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild
+++ b/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild,v 1.1 2006/04/20 13:49:19 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r2.ebuild,v 1.2 2006/07/06 02:50:04 nichoj Exp $
-inherit eutils java-utils flag-o-matic check-reqs
+inherit eutils java-pkg java-utils flag-o-matic check-reqs
MY_A="eclipse-sourceBuild-srcIncluded-${PV}.zip"
RELEASE_DATE="200601181600"
@@ -51,8 +51,9 @@ pkg_setup() {
check-cflags
# Make sure our vm is sane
- java-utils_setup-vm
- java-utils_ensure-vm-version-ge 1 4 2
+ java-utils_pkg_setup
+# java-utils_setup-vm
+# java-utils_ensure-vm-version-ge 1 4 2
# All other gentoo archs match in eclipse build system except amd64
if use amd64 ; then
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r3.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r3.ebuild
new file mode 100644
index 000000000000..7458a52d5bd2
--- /dev/null
+++ b/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r3.ebuild
@@ -0,0 +1,365 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.1.2-r3.ebuild,v 1.1 2006/07/06 02:50:04 nichoj Exp $
+
+inherit eutils java-pkg java-utils flag-o-matic check-reqs
+
+MY_A="eclipse-sourceBuild-srcIncluded-${PV}.zip"
+RELEASE_DATE="200601181600"
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/R-${PV}-${RELEASE_DATE}/${MY_A}"
+IUSE="gnome jikes nosrc nodoc atk"
+SLOT="3.1"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~amd64"
+S="${WORKDIR}"
+
+RDEPEND=">=virtual/jre-1.4.2
+ >=x11-libs/gtk+-2.2.4
+ atk? ( >=dev-libs/atk-1.6 )
+ gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )"
+
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.4.2
+ jikes? ( >=dev-java/jikes-1.21 )
+ >=dev-java/ant-1.6.2
+ >=dev-java/ant-core-1.6.2-r4
+ >=sys-apps/findutils-4.1.7
+ app-arch/unzip
+ app-arch/zip"
+
+ECLIPSE_DIR="/usr/lib/eclipse-${SLOT}"
+ECLIPSE_LINKS_DIR="${ECLIPSE_DIR}/links"
+
+# TODO:
+# - use CFLAGS from make.conf when building native libraries
+# - must patch eclipse build files
+# - also submit patch to bugs.eclipse.org
+# - ppc support not tested, but not explicitly broken either
+# - make a extension location in /var/lib that's writable by 'eclipse' group
+# - use make_desktop_entry from eutils instead of our own stuff
+# -
+
+pkg_setup() {
+ java-pkg_pkg_setup
+ debug-print "Checking for sufficient physical RAM"
+ CHECKREQS_MEMORY="768"
+ check_reqs
+
+ debug-print "Checking for bad CFLAGS"
+ check-cflags
+
+ # Make sure our vm is sane
+ java-utils_pkg_setup
+# java-utils_setup-vm
+# java-utils_ensure-vm-version-ge 1 4 2
+
+ # All other gentoo archs match in eclipse build system except amd64
+ if use amd64 ; then
+ eclipsearch=x86_64
+ else
+ eclipsearch=${ARCH}
+ fi
+
+ # All other gentoo archs match in sun jdk library patch except x86
+ if use x86 ; then
+ jvmarch=i386
+ else
+ jvmarch=${ARCH}
+ fi
+
+ # eventually, we'll have a plugin directory that's user writable, as group
+ # 'eclipse' -nichoj
+
+ # Add the eclipse group, for our plugin directories
+ #enewgroup eclipse
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # TODO figure out what this does -nichoj
+ epatch ${FILESDIR}/06-path-fixups.patch
+
+ einfo "Setting up virtual machine"
+ java-utils_setup-vm
+
+ einfo "Cleaning out prebuilt code"
+ clean-prebuilt-code
+
+ einfo "Patching makefiles"
+ fix_makefiles
+ fix_amd64_ibm_jvm
+}
+
+src_compile() {
+ # karltk: this should be handled by the java-pkg eclass in setup-vm
+ addwrite "/proc/self/maps"
+ addwrite "/proc/cpuinfo"
+ addwrite "/dev/random"
+
+ # Figure out VM, set up ant classpath and native library paths
+ setup-jvm-opts
+
+# if use !nogecko-sdk ; then
+# einfo "Will compile embedded Mozilla support against net-libs/gecko-sdk"
+# setup-mozilla-opts
+# else
+# einfo "Not building embedded Mozilla support"
+# fi
+
+ use jikes && bootstrap_ant_opts="-Dbuild.compiler=jikes"
+
+ debug-print "Bootstrapping bootstrap ecj"
+ ant ${bootstrap_ant_opts} -q -f jdtcoresrc/compilejdtcorewithjavac.xml || die "Failed to bootstrap ecj"
+
+ debug-print "Bootstrapping ecj"
+ ant -lib jdtcoresrc/ecj.jar -q -f jdtcoresrc/compilejdtcore.xml || die "Failed to bootstrap ecj"
+
+ debug-print "Compiling Eclipse -- see ${S}/compilelog.txt for details"
+ ANT_OPTS="-Xmx1024M" \
+ ant -lib jdtcoresrc/ecj.jar -q -f build.xml \
+ -DinstallOs=linux \
+ -DinstallWs=gtk \
+ -DinstallArch=${eclipsearch} \
+ -Dbootclasspath=${bootclasspath} \
+ -Dlibsconfig=true \
+ -DjavacTarget=1.4 \
+ -DjavacSource=1.4 \
+ -DjavacVerbose=false \
+ -DjavacFailOnError=true \
+ -DjavacDebugInfo=true \
+ -DbuildId="Gentoo Linux ${PF}" \
+ || die "Failed to compile Eclipse"
+
+ cp launchertmp/eclipse eclipse-gtk || die "Cannot find eclipse binary"
+
+ # TODO use make_desktop_entry from eutils during src_install instead -nichoj
+ create-desktop-entry
+}
+
+src_install() {
+ dodir /usr/lib
+
+ debug-print "Installing features and plugins"
+
+ [ -f result/linux-gtk-${eclipsearch}-sdk.tar.gz ] || die "tar.gz bundle was not built properly!"
+ tar zxf result/linux-gtk-${eclipsearch}-sdk.tar.gz -C ${D}/usr/lib || die "Failed to extract the built package"
+
+
+ mv ${D}/usr/lib/eclipse ${D}/${ECLIPSE_DIR}
+ insinto ${ECLIPSE_DIR}
+ exeinto ${ECLIPSE_DIR}
+
+ debug-print "Installing eclipse-gtk binary"
+ doexe eclipse-gtk || die "Failed to install eclipse binary"
+ # need to rename inf file to eclipse-gtk.ini, see bug #128128
+
+ if use nosrc; then
+ debug-print "Removing source code"
+ strip-src
+ fi
+
+ if use nodoc ; then
+ debug-print "Removing documentation"
+ strip-docs
+ fi
+
+ # Install startup script
+ exeinto /usr/bin
+ doexe ${FILESDIR}/eclipse-${SLOT}
+
+ install-desktop-entry
+
+ doman ${FILESDIR}/eclipse.1
+
+ install-link-files
+
+ # eventually, we'll have a user writable extension location -nichoj
+ # TODO make g+w
+ #dodir /var/lib/eclipse-${SLOT}
+ #touch ${D}/var/lib/eclipse-${SLOT}/.eclipseextension
+ #fowners root:eclipse /var/lib/eclipse-${SLOT}
+
+}
+
+# -----------------------------------------------------------------------------
+# Helper functions
+# -----------------------------------------------------------------------------
+
+fix_makefiles() {
+ # Comment out hard-coded JAVA_HOME
+ sed -i 's/^JAVA_HOME/#JAVA_HOME/' plugins/org.eclipse.core.resources.linux/src/Makefile || die "Failed to patch Makefile"
+
+ # Select the set of native libraries to compile
+ local libs="make_swt make_awt make_atk"
+
+ if use gnome ; then
+ einfo "Building GNOME VFS support"
+ libs="${libs} make_gnome"
+ fi
+
+# if use !nogecko-sdk ; then
+# einfo "Building Mozilla embed support"
+# libs="${libs} make_mozilla"
+# fi
+
+ if use atk ; then
+ einfo "Building ATK support"
+ libs="${libs} make_atk"
+ fi
+
+ sed -i "s/^all:.*/all: ${libs}/" "plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_linux.mak" || die "Failed to patch make_linux.mak"
+}
+
+fix_amd64_ibm_jvm() {
+ # the ibm jdk ebuild should have fixed headers, but until then
+ # we just fix the compiling here (see bug #97421)
+ if use amd64 ; then
+ if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
+ einfo "Fixing IBM jdk header problem"
+ find plugins -name "make_linux.mak" -print0 | xargs -0 sed -i -e 's/^CFLAGS =/CFLAGS = -D_JNI_IMPORT_OR_EXPORT_= /'
+ fi
+ fi
+}
+
+
+clean-prebuilt-code() {
+ find ${S} -type f \( -name '*.class' -o -name '*.so' -o -name '*.so.*' -o -name 'eclipse' \) | xargs rm -f
+}
+
+check-cflags() {
+ local badflags="-fomit-frame-pointer -msse2"
+ local error=false
+ local flag
+
+ for flag in ${badflags} ; do
+ if is-flag ${flag}; then
+ ewarn "Found offending option ${flag} in your CFLAGS"
+ error=true
+ fi
+ done
+ if [ ${error} == "true" ]; then
+ echo
+ ewarn "One or more potentially gruesome CFLAGS detected. When you run into trouble,"
+ ewarn "please edit /etc/make.conf and remove all offending flags, then recompile"
+ ewarn "Eclipse and all its dependencies before submitting a bug report."
+ echo
+ ewarn "In particular, gtk+ is extremely sensitive to which which flags it was"
+ ewarn "compiled with."
+ echo
+ einfo "Tip: use equery depgraph \"=${PF}\" to list all dependencies."
+ echo
+ ebeep
+ fi
+}
+
+setup-jvm-opts() {
+ # Figure out correct boot classpath
+ # karltk: this should be handled by the java-pkg eclass in setup-vm
+ if [ ! -z "`java-config --java-version | grep IBM`" ] ; then
+ # IBM JDK
+ local bp="$(java-config --jdk-home)/jre/lib"
+ bootclasspath="${bp}/core.jar:${bp}/xml.jar:${bp}/graphics.jar:${bp}/security.jar:${bp}/server.jar"
+ JAVA_LIB_DIR="$(java-config --jdk-home)/jre/bin"
+ else
+ # Sun derived JDKs (Blackdown, Sun)
+ local bp="$(java-config --jdk-home)/jre/lib"
+ bootclasspath="${bp}/rt.jar:${bp}/jsse.jar"
+ JAVA_LIB_DIR="$(java-config --jdk-home)/jre/lib/${jvmarch}"
+ fi
+
+ einfo "Using bootclasspath ${bootclasspath}"
+ einfo "Using JVM library path ${JAVA_LIB_DIR}"
+
+ if [ ! -f ${JAVA_LIB_DIR}/libawt.so ] ; then
+ die "Could not find libawt.so native library"
+ fi
+
+ export AWT_LIB_PATH=${JAVA_LIB_DIR}
+}
+
+setup-mozilla-opts() {
+ mozilla_dir="--mozdir-unset---"
+
+ if [ -f ${ROOT}/usr/lib/gecko-sdk/lib/libgtkembedmoz.so ] ; then
+ mozilla_dir=/usr/lib/gecko-sdk
+ else
+ # TODO need to update this appropriately for gecko-sdk
+ eerror "You have enabled the embedded mozilla component, but no suitable"
+ eerror "provider was found. You need gecko-sdk compiled against"
+ eerror "gtk+ v2.0 or newer."
+ eerror "To merge it, execute 'USE=\"gtk2\" emerge mozilla' as root."
+ eerror "To disable embedded mozilla, remove \"mozilla\" from your USE flags."
+ die "Need Mozilla compiled with gtk+-2.x support"
+ fi
+
+ export GECKO_SDK="${mozilla_dir}"
+ # TODO should this be using pkg-config?
+ export GECKO_INCLUDES="-include ${GECKO_SDK}/include/mozilla-config.h \
+ -I${GECKO_SDK}/include/nspr \
+ -I${GECKO_SDK}/include/nspr \
+ -I${GECKO_SDK}/include/xpcom \
+ -I${GECKO_SDK}/include/string \
+ -I${GECKO_SDK}/include/embed_base \
+ -I${JAVA_HOME}/include/linux"
+ export GECKO_LIBS="-L${GECKO_SDK}/lib -lgtkembedmoz"
+}
+
+build-native() {
+ sh features/org.eclipse.platform.launchers/library/gtk/build.sh \
+ -os linux -ws gtk \
+ -arch ${eclipsearch} || die "Failed to build launcher"
+}
+create-desktop-entry() {
+ sed -e "s/@PV@/${PV}/" ${FILESDIR}/eclipse-${SLOT}.desktop \
+ > eclipse-${SLOT}.desktop || die "Failed to create desktop entry"
+}
+
+install-desktop-entry() {
+ dodir /usr/share/applications
+ insinto /usr/share/applications
+ doins eclipse-${SLOT}.desktop
+}
+
+install_link_file() {
+ local path=${1}
+ local file=${2}
+
+ echo "path=${path}" > "${D}/${ECLIPSE_LINKS_DIR}/${file}"
+}
+
+install-link-files() {
+ einfo "Installing link files"
+
+ dodir ${ECLIPSE_LINKS_DIR}
+ install_link_file /opt/eclipse-extensions-3 eclipse-binary-extensions-3.link
+ install_link_file /opt/eclipse-extensions-3.1 eclipse-binary-extensions-3.1.link
+
+ install_link_file /usr/lib/eclipse-extensions-3 eclipse-extensions-3.link
+ install_link_file /usr/lib/eclipse-extensions-3.1 eclipse-extensions-3.1.link
+
+# install_link_file /var/lib/eclipse-3 eclipse-var-3.link
+# install_link_file /var/lib/eclipse-3.1 eclipse-var-3.1.link
+}
+
+strip-src() {
+ local bp=${D}/${ECLIPSE_DIR}
+
+ rm -rf ${bp}/plugins/org.eclipse.pde.source_3* \
+ ${bp}/plugins/org.eclipse.jdt.source_3* \
+ ${bp}/plugins/org.eclipse.platform.source.linux.* \
+ ${bp}/plugins/org.eclipse.platform.source_3* \
+ ${bp}/features/org.eclipse.jdt.source_3* \
+ ${bp}/features/org.eclipse.pde.source_3* \
+ ${bp}/features/org.eclipse.platform.source_3*
+}
+
+strip-docs() {
+ local bp=${D}/${ECLIPSE_DIR}
+
+ rm -rf ${bp}/plugins/org.eclipse.platform.doc.* \
+ ${bp}/plugins/org.eclipse.jdt.doc.* \
+ ${bp}/plugins/org.eclipse.pde.doc.*
+}
diff --git a/dev-util/eclipse-sdk/eclipse-sdk-3.2.ebuild b/dev-util/eclipse-sdk/eclipse-sdk-3.2.ebuild
new file mode 100644
index 000000000000..17302d56bd44
--- /dev/null
+++ b/dev-util/eclipse-sdk/eclipse-sdk-3.2.ebuild
@@ -0,0 +1,304 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-sdk/eclipse-sdk-3.2.ebuild,v 1.1 2006/07/06 02:50:04 nichoj Exp $
+
+inherit eutils java-pkg-2 flag-o-matic check-reqs multilib
+
+DATESTAMP="200606291905"
+MY_A="eclipse-sourceBuild-srcIncluded-${PV}.zip"
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download.eclipse.org/eclipse/downloads/drops/R-${PV}-${DATESTAMP}/${MY_A}
+mirror://gentoo/${P}-patches.tar.bz2"
+IUSE="no-seamonkey gnome cairo opengl"
+SLOT="3.2"
+LICENSE="EPL-1.0"
+# TODO might be able to have ia64 and ppc64 support
+KEYWORDS="~x86 ~ppc ~amd64"
+S="${WORKDIR}"
+
+COMMON_DEP="
+ >=x11-libs/gtk+-2.2.4
+ !no-seamonkey? ( www-client/seamonkey )
+ gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
+ opengl? ( virtual/opengl )
+ >=dev-java/ant-core-1.6.5
+ >=dev-java/ant-tasks-1.6.5
+ =dev-java/lucene-1*"
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND="
+ ${COMMON_DEP}
+ =virtual/jdk-1.4*
+ >=virtual/jdk-1.5
+ >=sys-apps/findutils-4.1.7
+ app-arch/unzip
+ app-arch/zip"
+# Force 1.4 to be used for building
+JAVA_PKG_NV_DEPEND="=virtual/jdk-1.4*"
+
+ECLIPSE_DIR="/usr/lib/eclipse-${SLOT}"
+ECLIPSE_LINKS_DIR="${ECLIPSE_DIR}/links"
+
+# TODO:
+# - use CFLAGS from make.conf when building native libraries
+# - must patch eclipse build files
+# - also submit patch to bugs.eclipse.org
+# - ppc support not tested, but not explicitly broken either
+# - make a extension location in /var/lib that's writable by 'eclipse' group
+# - update man page
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ debug-print "Checking for sufficient physical RAM"
+ CHECKREQS_MEMORY="768"
+ check_reqs
+
+ # All other gentoo archs match in eclipse build system except amd64
+ if use amd64 ; then
+ eclipsearch=x86_64
+ else
+ eclipsearch=${ARCH}
+ fi
+
+ if use x86 ; then
+ jvmarch=i386
+ else
+ jvmarch=${ARCH}
+ fi
+
+ # Add the eclipse group, for our plugins/features directories
+ enewgroup eclipse
+}
+
+src_unpack() {
+ unpack ${A}
+
+ fix-swt-targets
+
+ pushd plugins/org.apache.ant/lib >/dev/null
+ rm *.jar
+ java-pkg_jar-from ant-core,ant-tasks
+ popd >/dev/null
+
+ pushd plugins/org.junit >/dev/null
+ rm *.jar
+ java-pkg_jar-from junit
+ popd >/dev/null
+
+ pushd plugins/org.apache.lucene >/dev/null
+ rm *.jar
+ java-pkg_jar-from lucene-1 lucene.jar lucene-1.4.3.jar
+ popd >/dev/null
+
+ # TODO replace stuff in plugins/org.eclipse.team.cvs.ssh2
+ # TODO replace stuff in plugins/org.eclipse.tomcat
+ # TODO replace stuff in plugins/org.junit4
+
+ # begin: patches/comments from fedora
+
+ # Build JNI libs
+ # FIXME: these should be built by upstream build method
+ # http://www.bagu.org/eclipse/plugin-source-drops.html
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=71637
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=86848
+ # GNU XML issue identified by Michael Koch
+ # patches 2, 4, 5
+ epatch ${WORKDIR}/${P}-build.patch
+ epatch ${WORKDIR}/${P}-libupdatebuild.patch
+ epatch ${WORKDIR}/${P}-libupdatebuild2.patch
+
+ # Build swttools.jar
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=90364
+ pushd plugins/org.eclipse.swt.gtk.linux.x86_64 >/dev/null
+ epatch ${WORKDIR}/${P}-swttools.patch # patch18
+ popd >/dev/null
+
+ # install location should automatically be added to homedir
+ # if ECLIPSE_HOME is not writable
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=90630
+ epatch ${WORKDIR}/${P}-updatehomedir.patch # patch22
+
+ # .so files installed in a strange location
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=90535
+ pushd plugins/org.eclipse.core.runtime >/dev/null
+ epatch ${WORKDIR}/${P}-fileinitializer.patch # patch24
+ popd >/dev/null
+
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=98707
+ # https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=178726
+# TODO figure out why this doesn't apply
+# pushd plugins/org.eclipse.compare >/dev/null
+# epatch ${WORKDIR}/${P}-compare-create-api.patch # patch 33
+# popd >/dev/null
+
+ # JPackage []s in names of symlinks ...
+ # https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=162177
+ pushd plugins/org.eclipse.jdt.core >/dev/null
+ epatch ${WORKDIR}/${P}-bz162177.patch # patch34
+ popd >/dev/null
+
+ epatch ${WORKDIR}/${P}-genjavadocoutput.patch # patch35
+
+ # buildHelpIndex caused a OutOfMemoryException
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=114001
+ epatch ${WORKDIR}/${P}-helpindexbuilder.patch # patch38
+
+ epatch ${WORKDIR}/${P}-usebuiltlauncher.patch # patch40
+
+ # Eclipse launcher does not follow symlinks
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=79592
+ # https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=168726
+ mkdir launchertmp
+ unzip -d launchertmp \
+ plugins/org.eclipse.platform/launchersrc.zip >/dev/null || die "unzip failed"
+ pushd launchertmp >/dev/null
+ epatch ${WORKDIR}/${P}-launcher-link.patch # patch47
+ zip -9 -r ../launchersrc.zip * >/dev/null || die "zip failed"
+ popd >/dev/null
+ mv launchersrc.zip plugins/org.eclipse.platform
+ rm -rf launchertmp
+
+ pushd features/org.eclipse.platform.launchers >/dev/null
+ epatch ${WORKDIR}/${P}-launcher-link.patch # patch47
+ popd >/dev/null
+
+ # Don't attempt to link to Sun's javadocs
+ epatch ${WORKDIR}/${P}-javadoclinks.patch # patch48
+
+ # generic releng plugins that can be used to build plugins
+ # see this thread for deails:
+ # https://www.redhat.com/archives/fedora-devel-java-list/2006-April/msg00048.html
+ pushd plugins/org.eclipse.pde.build >/dev/null
+ epatch ${WORKDIR}/${P}-pde.build-add-package-build.patch # patch53
+ sed --in-place "s:@eclipse_base@:${ECLIPSE_DIR}:" templates/package-build/build.properties
+ popd >/dev/null
+
+ # https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=191536
+ # https://bugs.eclipse.org/bugs/show_bug.cgi?id=142861
+ pushd plugins/org.eclipse.swt/Eclipse\ SWT >/dev/null
+ epatch ${WORKDIR}/${P}-swt-rm-ON_TOP.patch # patch54
+ popd >/dev/null
+
+ # We need to disable junit4 and apt until GCJ can handle Java5 code
+ # FIXME for some reason junit isn't using java5...
+ epatch ${WORKDIR}/${P}-disable-junit4-apt.patch # patch55
+}
+
+src_compile() {
+ # Figure out VM, set up ant classpath and native library paths
+ setup-jvm-opts
+
+ if ! use no-seamonkey ; then
+ einfo "Will compile embedded seamonkey support against www-client/seamonkey"
+ setup-mozilla-opts
+ else
+ einfo "Not building embedded seamonkey support"
+ fi
+
+ local java5vm=$(depend-java-query --get-vm ">=virtual/jdk-1.5")
+ local java5home=$(GENTOO_VM=${java5vm} java-config --jdk-home)
+ einfo "Using ${java5home} for java5home"
+ # TODO patch build to take buildId
+ ./build -os linux \
+ -arch ${eclipsearch} \
+ -ws gtk \
+ -java5home ${java5home} || die "build failed"
+}
+
+src_install() {
+ dodir /usr/lib
+
+ # TODO maybe there's a better way of installing than extracting the tar?
+ [[ -f result/linux-gtk-${eclipsearch}-sdk.tar.gz ]] || die "tar.gz bundle was not built properly!"
+ tar zxf result/linux-gtk-${eclipsearch}-sdk.tar.gz -C ${D}/usr/lib \
+ || die "Failed to extract the built package"
+
+ mv ${D}/usr/lib/eclipse ${D}/${ECLIPSE_DIR}
+ insinto ${ECLIPSE_DIR}
+ exeinto ${ECLIPSE_DIR}
+ echo "-Djava.library.path=/usr/lib" >> ${D}/${ECLIPSE_DIR}/eclipse.ini
+
+ debug-print "Installing eclipse-gtk binary"
+ doexe eclipse || die "Failed to install eclipse binary"
+
+ # Install startup script
+ exeinto /usr/bin
+ doexe ${FILESDIR}/eclipse-${SLOT}
+
+ make_desktop_entry eclipse-${SLOT} "Eclipse ${PV}" "${ECLIPSE_DIR}/icon.xpm"
+}
+
+# -----------------------------------------------------------------------------
+# Helper functions
+# -----------------------------------------------------------------------------
+
+fix-swt-targets() {
+ # Select the set of native libraries to compile
+ local targets="make_swt make_awt make_atk"
+
+ if use gnome ; then
+ einfo "Enabling GNOME VFS support"
+ targets="${targets} make_gnome"
+ fi
+
+ if ! use no-seamonkey ; then
+ einfo "Enabling embedded Mozilla support"
+ targets="${targets} make_mozilla"
+ fi
+
+ if use cairo ; then
+ einfo "Enabling CAIRO support"
+ targets="${targets} make_cairo"
+ fi
+
+ if use opengl ; then
+ einfo "Enabling OpenGL support"
+ targets="${targets} make_glx"
+ fi
+
+ sed -i "s/^all:.*/all: ${targets}/" \
+ "plugins/org.eclipse.swt/Eclipse SWT PI/gtk/library/make_linux.mak" \
+ || die "Failed to tweak make_linux.mak"
+}
+
+setup-jvm-opts() {
+ # Figure out correct boot classpath
+ # karltk: this should be handled by the java-pkg eclass in setup-vm
+ local bp="$(java-config --jdk-home)/jre/lib"
+ local bootclasspath=$(java-config --runtime)
+ if [[ ! -z "`java-config --java-version | grep IBM`" ]] ; then
+ # IBM JDK
+ JAVA_LIB_DIR="$(java-config --jdk-home)/jre/bin"
+ else
+ # Sun derived JDKs (Blackdown, Sun)
+ JAVA_LIB_DIR="$(java-config --jdk-home)/jre/lib/${jvmarch}"
+ fi
+
+ einfo "Using bootclasspath ${bootclasspath}"
+ einfo "Using JVM library path ${JAVA_LIB_DIR}"
+
+ if [[ ! -f ${JAVA_LIB_DIR}/libawt.so ]] ; then
+ die "Could not find libawt.so native library"
+ fi
+
+ export AWT_LIB_PATH=${JAVA_LIB_DIR}
+}
+
+setup-mozilla-opts() {
+ export GECKO_SDK="/usr/$(get_libdir)/seamonkey"
+ # TODO should this be using pkg-config?
+ export GECKO_INCLUDES=$(pkg-config seamonkey-gtkmozembed --cflags)
+ export GECKO_LIBS=$(pkg-config seamonkey-gtkmozembed --libs)
+}
+
+pkg_postinst() {
+ einfo "Users can now install plugins via Update Manager without any"
+ einfo "tweaking."
+ echo
+ einfo "Eclipse plugin packages (ie eclipse-cdt) will likely go away in"
+ einfo "the near future until they can be properly packaged. Update Manager"
+ einfo "is prefered in the meantime."
+}
diff --git a/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.1.2-r3 b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.1.2-r3
new file mode 100644
index 000000000000..f22ddffd2fd5
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.1.2-r3
@@ -0,0 +1,3 @@
+MD5 f2c8066151de14c5ccdf420266ce9f39 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673
+RMD160 ffe59352fe02b4a47be3e9a6daad3a5501f196b0 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673
+SHA256 31233332f205a197a42aafdc4f15a4f38eb5e4be19ac8a7192492ab8a21324a4 eclipse-sourceBuild-srcIncluded-3.1.2.zip 66630673
diff --git a/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.2 b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.2
new file mode 100644
index 000000000000..173d7da147b7
--- /dev/null
+++ b/dev-util/eclipse-sdk/files/digest-eclipse-sdk-3.2
@@ -0,0 +1,6 @@
+MD5 14b0ca859138e648d404a781b7e4acd7 eclipse-sdk-3.2-patches.tar.bz2 24883
+RMD160 a7b5826d8f63a00b4db70cbcec6f179372ed6806 eclipse-sdk-3.2-patches.tar.bz2 24883
+SHA256 0a1db1c111d0188487e6fb7ead77d158e9d8c61e483081b089d1f765bb2dfd56 eclipse-sdk-3.2-patches.tar.bz2 24883
+MD5 67b41802092d4b2f779fb756dcaec85c eclipse-sourceBuild-srcIncluded-3.2.zip 82018640
+RMD160 eadb8c5dde4ebe8b134fb35e6c42d08f52c145a7 eclipse-sourceBuild-srcIncluded-3.2.zip 82018640
+SHA256 e9366fd3046be753f821be786156c472148928101cf6bf8f9d31b455cb6039da eclipse-sourceBuild-srcIncluded-3.2.zip 82018640