summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-06-08 18:15:54 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-06-08 18:15:54 +0000
commit62820cf859afbeeac035d30f83c080666e1caa53 (patch)
tree5f9fbfb09f2bd04e5d2cc50a5b58d77aa6f59e5c /dev-util
parentremove package.mask for sherman-aquarium since it's gone. (diff)
downloadgentoo-2-62820cf859afbeeac035d30f83c080666e1caa53.tar.gz
gentoo-2-62820cf859afbeeac035d30f83c080666e1caa53.tar.bz2
gentoo-2-62820cf859afbeeac035d30f83c080666e1caa53.zip
bump to 2.4.2. Bug fixes and translation updates.
(Portage version: 2.1.5.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/anjuta/ChangeLog8
-rw-r--r--dev-util/anjuta/anjuta-2.4.2.ebuild98
-rw-r--r--dev-util/anjuta/files/anjuta-2.4.2-documentation.patch39
3 files changed, 144 insertions, 1 deletions
diff --git a/dev-util/anjuta/ChangeLog b/dev-util/anjuta/ChangeLog
index dbf23274e1de..cf1033c18f88 100644
--- a/dev-util/anjuta/ChangeLog
+++ b/dev-util/anjuta/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/anjuta
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.84 2008/06/07 15:32:48 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/ChangeLog,v 1.85 2008/06/08 18:15:53 eva Exp $
+
+*anjuta-2.4.2 (08 Jun 2008)
+
+ 08 Jun 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/anjuta-2.4.2-documentation.patch, +anjuta-2.4.2.ebuild:
+ bump to 2.4.2. Bug fixes and translation updates.
07 Jun 2008; Jeroen Roovers <jer@gentoo.org> anjuta-2.4.1.ebuild:
Marked ~hppa too.
diff --git a/dev-util/anjuta/anjuta-2.4.2.ebuild b/dev-util/anjuta/anjuta-2.4.2.ebuild
new file mode 100644
index 000000000000..993fdb823ae2
--- /dev/null
+++ b/dev-util/anjuta/anjuta-2.4.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-2.4.2.ebuild,v 1.1 2008/06/08 18:15:53 eva Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="http://www.anjuta.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE="debug devhelp doc glade inherit-graph sourceview subversion valgrind"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/gtk+-2.8.0
+ >=gnome-base/orbit-2.6.0
+ >=gnome-base/libglade-2.3.0
+ >=gnome-base/libgnome-2.12.0
+ >=gnome-base/libgnomeui-2.12.0
+ >=gnome-base/libgnomeprint-2.12.0
+ >=gnome-base/libgnomeprintui-2.12.0
+ >=gnome-base/gnome-vfs-2.12.0
+ >=gnome-base/gconf-2.12.0
+ >=x11-libs/vte-0.13.1
+ >=dev-libs/libxml2-2.4.23
+ >=x11-libs/pango-1.1.1
+ >=dev-libs/gdl-0.7.5
+ >=app-text/gnome-doc-utils-0.3.2
+ >=dev-libs/gnome-build-0.2.0
+ >=dev-libs/libpcre-5.0
+ >=x11-libs/libwnck-2.12
+ >=sys-devel/binutils-2.15.92
+ dev-libs/libxslt
+ sys-devel/autogen
+ devhelp? ( >=dev-util/devhelp-0.13 )
+ glade? ( >=dev-util/glade-3.1.4 )
+ inherit-graph? ( >=media-gfx/graphviz-2.6.0 )
+ sourceview? (
+ >=x11-libs/gtk+-2.10.0
+ >=gnome-base/libgnome-2.14.0
+ >=x11-libs/gtksourceview-2.1.2
+ )
+ subversion? (
+ >=dev-util/subversion-1.1.4
+ >=net-misc/neon-0.24.5
+ dev-libs/apr
+ )
+ valgrind? ( dev-util/valgrind )"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ >=sys-devel/gettext-0.14
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.20
+ >=app-text/scrollkeeper-0.3.14-r2
+ doc? ( >=dev-util/gtk-doc-1.0 )"
+
+pkg_setup() {
+ # gtk-doc is handled by eclass
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_enable devhelp plugin-devhelp)
+ $(use_enable glade plugin-glade)
+ $(use_enable valgrind plugin-valgrind)
+ $(use_enable sourceview plugin-sourceview)
+ $(use_enable !sourceview plugin-scintilla)
+ $(use_enable subversion plugin-subversion)
+ $(use_enable inherit-graph plugin-class-inheritance)"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Patch to prevent an access violation (bug #164740)
+ epatch "${FILESDIR}/${PN}-2.1.0-sandbox-fix.patch"
+
+ # Fix documentation to pass tests, upstream bug #536889
+ epatch "${FILESDIR}/${P}-documentation.patch"
+}
+
+src_install() {
+ # Install user docs into /usr/share/doc/${PF}/
+ sed -i -e "s:doc/${PN}:doc/${PF}:g" Makefile
+ sed -i -e "s:doc/${PN}:doc/${PF}/html:g" doc/Makefile
+
+ gnome2_src_install
+ prepalldocs
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ ebeep 1
+ elog "Some project templates may require additional development"
+ elog "libraries to function correctly. It goes beyond the scope"
+ elog "of this ebuild to provide them."
+ epause 5
+}
diff --git a/dev-util/anjuta/files/anjuta-2.4.2-documentation.patch b/dev-util/anjuta/files/anjuta-2.4.2-documentation.patch
new file mode 100644
index 000000000000..1cf3446b574c
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-2.4.2-documentation.patch
@@ -0,0 +1,39 @@
+diff -urNp anjuta-2.4.2-orig/manuals/anjuta-manual/C/debugger.xml anjuta-2.4.2/manuals/anjuta-manual/C/debugger.xml
+--- anjuta-2.4.2-orig/manuals/anjuta-manual/C/debugger.xml 2008-06-06 11:16:35.000000000 +0530
++++ anjuta-2.4.2/manuals/anjuta-manual/C/debugger.xml 2008-06-06 11:18:18.000000000 +0530
+@@ -49,10 +49,10 @@
+ <menuchoice><guisubmenu>Debug</guisubmenu><guimenuitem>Run Target&hellip;</guimenuitem></menuchoice>
+ to display a dialog box where you can select:
+ <itemizedlist>
+- <listitem>The program that you want to debug</listitem>
+- <listitem>The command line parameters</listitem>
+- <listitem>If you want a terminal or not (the Anjuta terminal plugin is used)</listitem>
+- <listitem>If you want to stop the program at the beginning or not</listitem>
++ <listitem><para>The program that you want to debug</para></listitem>
++ <listitem><para>The command line parameters</para></listitem>
++ <listitem><para>If you want a terminal or not (the Anjuta terminal plugin is used)</para></listitem>
++ <listitem><para>If you want to stop the program at the beginning or not</para></listitem>
+ </itemizedlist>
+ </para>
+ <para>
+@@ -403,13 +403,13 @@
+ <para>
+ Enter the location at which to set the breakpoint. It has to be specified in one of
+ the following formats:
+- <para>
+- <orderedlist>
+- <listitem><para>File_name:Line_number</para></listitem>
+- <listitem><para>Function_name</para></listitem>
+- <listitem><para>File:Function_name</para></listitem>
+- </orderedlist>
+- </para>
++ </para>
++ <para>
++ <orderedlist>
++ <listitem><para>File_name:Line_number</para></listitem>
++ <listitem><para>Function_name</para></listitem>
++ <listitem><para>File:Function_name</para></listitem>
++ </orderedlist>
+ </para>
+ <para>
+ The first one is obvious &mdash; The location refers to the line number