summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaurice van der Pot <griffon26@gentoo.org>2008-06-06 18:20:39 +0000
committerMaurice van der Pot <griffon26@gentoo.org>2008-06-06 18:20:39 +0000
commit682a378770bdef14da5ba04bb3eda5dacb18f3ce (patch)
tree92f94cc58c47eefe3edb2da44485d8e9112e5893 /dev-util
parentamd64 stable, bug #224865. (diff)
downloadgentoo-2-682a378770bdef14da5ba04bb3eda5dacb18f3ce.tar.gz
gentoo-2-682a378770bdef14da5ba04bb3eda5dacb18f3ce.tar.bz2
gentoo-2-682a378770bdef14da5ba04bb3eda5dacb18f3ce.zip
Bumped valgrind to version 3.3.1 (bug #225081).
(Portage version: 2.1.5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/valgrind/ChangeLog8
-rw-r--r--dev-util/valgrind/valgrind-3.3.1.ebuild91
2 files changed, 98 insertions, 1 deletions
diff --git a/dev-util/valgrind/ChangeLog b/dev-util/valgrind/ChangeLog
index 761ab3c3ecec..fedc3c358451 100644
--- a/dev-util/valgrind/ChangeLog
+++ b/dev-util/valgrind/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valgrind
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.87 2008/05/18 10:22:48 griffon26 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/ChangeLog,v 1.88 2008/06/06 18:20:39 griffon26 Exp $
+
+*valgrind-3.3.1 (06 Jun 2008)
+
+ 06 Jun 2008; Maurice van der Pot <griffon26@gentoo.org>
+ +valgrind-3.3.1.ebuild:
+ Version bump to 3.3.1 (closes bug #225081).
*valgrind-3.3.0-r1 (18 May 2008)
diff --git a/dev-util/valgrind/valgrind-3.3.1.ebuild b/dev-util/valgrind/valgrind-3.3.1.ebuild
new file mode 100644
index 000000000000..266648571f3f
--- /dev/null
+++ b/dev-util/valgrind/valgrind-3.3.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valgrind/valgrind-3.3.1.ebuild,v 1.1 2008/06/06 18:20:39 griffon26 Exp $
+
+inherit autotools eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="An open-source memory debugger for GNU/Linux"
+HOMEPAGE="http://www.valgrind.org"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+RDEPEND="!dev-util/callgrind"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # make sure our CFLAGS are respected
+ einfo "Changing configure.in to respect CFLAGS"
+ sed -i -e 's:^CFLAGS="-Wno-long-long":CFLAGS="$CFLAGS -Wno-long-long":' configure.in
+
+ # undefined references to __guard and __stack_smash_handler in VEX (bug #114347)
+ einfo "Changing Makefile.flags.am to disable SSP"
+ sed -i -e 's:^AM_CFLAGS_BASE = :AM_CFLAGS_BASE = -fno-stack-protector :' Makefile.flags.am
+
+ # Correct hard coded doc location
+ sed -i -e "s:doc/valgrind:doc/${P}:" docs/Makefile.am
+
+ # Fix incorrect --libs output in valgrind.pc (bug #147904)
+ epatch "${FILESDIR}/${PN}-3.2.3-pkg-config.patch"
+
+ # Remove defaulting to ppc32-linux on ppc64 without multilib
+ # "valgrind: failed to start tool 'memcheck' for platform 'ppc32-linux':
+ # No such file or directory"
+ if use ppc64 && ! has_multilib_profile; then
+ epatch "${FILESDIR}/valgrind-3.3.0-only64bit.patch"
+ fi
+
+ # Regenerate autotools files
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ # -fomit-frame-pointer "Assembler messages: Error: junk `8' after expression"
+ # while compiling insn_sse.c in none/tests/x86
+ # -fpie valgrind seemingly hangs when built with pie on
+ # amd64 (bug #102157)
+ # -fstack-protector more undefined references to __guard and __stack_smash_handler
+ # because valgrind doesn't link to glibc (bug #114347)
+ # -ggdb3 segmentation fault on startup
+ filter-flags -fomit-frame-pointer
+ filter-flags -fpie
+ filter-flags -fstack-protector
+ replace-flags -ggdb3 -ggdb2
+
+ # gcc 3.3.x fails to compile valgrind with -O3 (bug #129776)
+ if [ "$(gcc-version)" == "3.3" ] && is-flagq -O3; then
+ ewarn "GCC 3.3 cannot compile valgrind with -O3 in CFLAGS, using -O2 instead."
+ replace-flags -O3 -O2
+ fi
+
+ # Optionally build in X suppression files
+ use X && myconf="--with-x" || myconf="--with-x=no"
+
+ if use amd64 || use ppc64; then
+ ! has_multilib_profile && myconf="${myconf} --enable-only64bit"
+ fi
+
+ econf ${myconf} || die "Configure failed!"
+ emake || die "Make failed!"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed!"
+ dodoc ACKNOWLEDGEMENTS AUTHORS FAQ.txt NEWS README*
+}
+
+pkg_postinst() {
+ if use ppc || use ppc64 ; then
+ ewarn "Valgrind will not work on ppc or ppc64 if glibc does not have"
+ ewarn "debug symbols (see https://bugs.gentoo.org/show_bug.cgi?id=214065)"
+ ewarn "To fix this you can add splitdebug to FEATURES in make.conf and"
+ ewarn "remerge glibc."
+ fi
+}