summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-06-22 21:15:01 +0000
committerJohannes Huber <johu@gentoo.org>2015-06-22 21:15:01 +0000
commit6a20a3f8aed9712ee399b986c6c37791fc6e2f4c (patch)
tree274960434a8a69c408b39211ac79e57d378f1abe /dev-util
parentUpdates git eclass to version r3 (diff)
downloadgentoo-2-6a20a3f8aed9712ee399b986c6c37791fc6e2f4c.tar.gz
gentoo-2-6a20a3f8aed9712ee399b986c6c37791fc6e2f4c.tar.bz2
gentoo-2-6a20a3f8aed9712ee399b986c6c37791fc6e2f4c.zip
Add upstream patch to fix build on musl profiles, spotted by Felix Janda <felix.janda@posteo.de>, bug #552708.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xFDF4F788)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog7
-rw-r--r--dev-util/cmake/cmake-3.2.3.ebuild5
-rw-r--r--dev-util/cmake/files/cmake-3.2.3-musl-missing-include.patch28
3 files changed, 38 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 5d42bdeb5807..842463fb7b10 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.314 2015/06/16 12:22:37 zlogene Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.315 2015/06/22 21:15:01 johu Exp $
+
+ 22 Jun 2015; Johannes Huber <johu@gentoo.org>
+ +files/cmake-3.2.3-musl-missing-include.patch, cmake-3.2.3.ebuild:
+ Add upstream patch to fix build on musl profiles, spotted by Felix Janda
+ <felix.janda@posteo.de>, bug #552708.
16 Jun 2015; Mikle Kolyada <zlogene@gentoo.org> cmake-3.2.2.ebuild:
x86 stable wrt bug #545870
diff --git a/dev-util/cmake/cmake-3.2.3.ebuild b/dev-util/cmake/cmake-3.2.3.ebuild
index 8ddcec1d012a..403883a473de 100644
--- a/dev-util/cmake/cmake-3.2.3.ebuild
+++ b/dev-util/cmake/cmake-3.2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.3.ebuild,v 1.2 2015/06/12 05:24:01 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-3.2.3.ebuild,v 1.3 2015/06/22 21:15:01 johu Exp $
EAPI=5
@@ -58,6 +58,9 @@ PATCHES=(
# respect python eclasses
"${FILESDIR}"/${PN}-2.8.10.2-FindPythonLibs.patch
"${FILESDIR}"/${PN}-3.1.0-FindPythonInterp.patch
+
+ # upstream backports
+ "${FILESDIR}"/${PN}-3.2.3-musl-missing-include.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-3.2.3-musl-missing-include.patch b/dev-util/cmake/files/cmake-3.2.3-musl-missing-include.patch
new file mode 100644
index 000000000000..5e0efa902679
--- /dev/null
+++ b/dev-util/cmake/files/cmake-3.2.3-musl-missing-include.patch
@@ -0,0 +1,28 @@
+From c775072ad5a93306183f83f4396268b1690bb392 Mon Sep 17 00:00:00 2001
+From: Brad King <brad.king@kitware.com>
+Date: Wed, 22 Apr 2015 09:58:46 -0400
+Subject: [PATCH] cmGeneratorExpressionEvaluationFile: Add missing sys/types.h
+ include
+
+This is needed for 'mode_t', and on mingw-w64 in particular. We added
+use of 'mode_t' in commit v3.2.0-rc1~421^2 (file(GENERATE): Use
+permissions of input file if present, 2014-07-22).
+---
+ Source/cmGeneratorExpressionEvaluationFile.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/cmGeneratorExpressionEvaluationFile.h b/Source/cmGeneratorExpressionEvaluationFile.h
+index 4424bec..5d8b54c 100644
+--- a/Source/cmGeneratorExpressionEvaluationFile.h
++++ b/Source/cmGeneratorExpressionEvaluationFile.h
+@@ -13,6 +13,7 @@
+ #define cmGeneratorExpressionEvaluationFile_h
+
+ #include "cmStandardIncludes.h"
++#include <sys/types.h>
+ #include <cmsys/auto_ptr.hxx>
+
+ #include "cmGeneratorExpression.h"
+--
+1.7.10.4
+