summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-02-09 07:55:30 +0000
committerJeroen Roovers <jer@gentoo.org>2015-02-09 07:55:30 +0000
commit7cbb888b3514ee36cec47244c4b009ca8aa97454 (patch)
tree7c6552772709aa654ab5b86875c9646930425bd9 /dev-util
parentRaise x11-base/xorg-server compatibility (bug #539378 by bwcknr). (diff)
downloadgentoo-2-7cbb888b3514ee36cec47244c4b009ca8aa97454.tar.gz
gentoo-2-7cbb888b3514ee36cec47244c4b009ca8aa97454.tar.bz2
gentoo-2-7cbb888b3514ee36cec47244c4b009ca8aa97454.zip
Fix opjitconv open() flag (bug #538788).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/oprofile/ChangeLog8
-rw-r--r--dev-util/oprofile/files/oprofile-1.0.0-opjitconv-open.patch11
-rw-r--r--dev-util/oprofile/oprofile-1.0.0-r1.ebuild (renamed from dev-util/oprofile/oprofile-1.0.0.ebuild)5
3 files changed, 21 insertions, 3 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 4454d0dfd97f..9a1b69e6d8c0 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/oprofile
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.105 2015/01/28 10:19:53 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.106 2015/02/09 07:55:30 jer Exp $
+
+*oprofile-1.0.0-r1 (09 Feb 2015)
+
+ 09 Feb 2015; Jeroen Roovers <jer@gentoo.org> -oprofile-1.0.0.ebuild,
+ +oprofile-1.0.0-r1.ebuild, +files/oprofile-1.0.0-opjitconv-open.patch:
+ Fix opjitconv open() flag (bug #538788).
28 Jan 2015; Agostino Sarubbo <ago@gentoo.org> oprofile-0.9.9-r1.ebuild:
Stable for ppc, wrt bug #536166
diff --git a/dev-util/oprofile/files/oprofile-1.0.0-opjitconv-open.patch b/dev-util/oprofile/files/oprofile-1.0.0-opjitconv-open.patch
new file mode 100644
index 000000000000..2943a074f5ef
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-1.0.0-opjitconv-open.patch
@@ -0,0 +1,11 @@
+--- a/opjitconv/opjitconv.c
++++ b/opjitconv/opjitconv.c
+@@ -216,7 +216,7 @@
+ int file_locked = 0;
+ unsigned int usecs_waited = 0;
+ int rc = OP_JIT_CONV_OK;
+- int fd = open(dumpfile, S_IRUSR);
++ int fd = open(dumpfile, O_RDONLY);
+ if (fd < 0) {
+ perror("opjitconv failed to open JIT dumpfile");
+ return OP_JIT_CONV_FAIL;
diff --git a/dev-util/oprofile/oprofile-1.0.0.ebuild b/dev-util/oprofile/oprofile-1.0.0-r1.ebuild
index 73f40c039597..75a47fbcd4c0 100644
--- a/dev-util/oprofile/oprofile-1.0.0.ebuild
+++ b/dev-util/oprofile/oprofile-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-1.0.0.ebuild,v 1.2 2014/12/01 10:17:13 bircoph Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-1.0.0-r1.ebuild,v 1.1 2015/02/09 07:55:30 jer Exp $
EAPI="5"
inherit eutils java-pkg-opt-2 linux-info multilib user
@@ -44,6 +44,7 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}/${P}-athlon.patch"
+ epatch "${FILESDIR}/${P}-opjitconv-open.patch"
}
src_configure() {