summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-05-07 13:59:14 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-05-07 13:59:14 +0000
commit7d1bb4cc5d83e50c547da8472ad096525296a9e3 (patch)
tree33c554f7cac4ae50387ffdb684a72a955e6de32f /dev-util
parentStable for sparc, wrt bug #468220 (diff)
downloadgentoo-2-7d1bb4cc5d83e50c547da8472ad096525296a9e3.tar.gz
gentoo-2-7d1bb4cc5d83e50c547da8472ad096525296a9e3.tar.bz2
gentoo-2-7d1bb4cc5d83e50c547da8472ad096525296a9e3.zip
Latest version from upstream CVS; include /usr/lib32/pkgconfig, /usr/lib64/pkgconfig, /usr/share/pkgconfig to search paths.
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconfig-openbsd/ChangeLog9
-rw-r--r--dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507.ebuild63
2 files changed, 71 insertions, 1 deletions
diff --git a/dev-util/pkgconfig-openbsd/ChangeLog b/dev-util/pkgconfig-openbsd/ChangeLog
index 6f52fe134c1f..2f1fa1ba9271 100644
--- a/dev-util/pkgconfig-openbsd/ChangeLog
+++ b/dev-util/pkgconfig-openbsd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pkgconfig-openbsd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.12 2013/03/05 12:27:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/ChangeLog,v 1.13 2013/05/07 13:59:14 ssuominen Exp $
+
+*pkgconfig-openbsd-20130507 (07 May 2013)
+
+ 07 May 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +pkgconfig-openbsd-20130507.ebuild:
+ Latest version from upstream CVS; include /usr/lib32/pkgconfig,
+ /usr/lib64/pkgconfig, /usr/share/pkgconfig to search paths.
05 Mar 2013; Samuli Suominen <ssuominen@gentoo.org>
pkgconfig-openbsd-20130225.ebuild:
diff --git a/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507.ebuild b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507.ebuild
new file mode 100644
index 000000000000..3b27cbd0c2c4
--- /dev/null
+++ b/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig-openbsd/pkgconfig-openbsd-20130507.ebuild,v 1.1 2013/05/07 13:59:14 ssuominen Exp $
+
+EAPI=5
+
+# cvs -d anoncvs@anoncvs.openbsd.org:/cvs get src/usr.bin/pkg-config
+
+PKG_M4_VERSION=0.28
+
+DESCRIPTION="A perl based version of pkg-config from OpenBSD"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/pkg-config/"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.xz
+ pkg-config? ( http://pkgconfig.freedesktop.org/releases/pkg-config-${PKG_M4_VERSION}.tar.gz )"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pkg-config"
+
+DEPEND="
+ pkg-config? (
+ !dev-util/pkgconfig
+ !dev-util/pkgconf[pkg-config]
+ )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ virtual/perl-Getopt-Long"
+
+S=${WORKDIR}/src
+
+src_prepare() {
+ # Config.pm from dev-lang/perl doesn't set ARCH, only archname
+ sed -i -e '/Config/s:ARCH:archname:' usr.bin/pkg-config/pkg-config || die
+
+ sed -i \
+ -e 's:/usr/X11R6/lib/pkgconfig:/usr/share/pkgconfig:' \
+ -e 's:/usr/X11R6/share/pkgconfig:/usr/lib64/pkgconfig\n/usr/lib32/pkgconfig:' \
+ usr.bin/pkg-config/pkg-config || die
+}
+
+src_install() {
+ if use pkg-config; then
+ dobin usr.bin/pkg-config/pkg-config
+ doman usr.bin/pkg-config/pkg-config.1
+
+ insinto /usr/share/aclocal
+ doins "${WORKDIR}"/pkg-config-*/pkg.m4
+ else
+ newbin usr.bin/pkg-config/pkg-config pkg-config-openbsd
+ newman usr.bin/pkg-config/pkg-config.1 pkg-config-openbsd.1
+ fi
+
+ insinto /usr/share/${PN}
+ doins -r usr.bin/pkg-config/OpenBSD
+
+ cat <<-EOF > "${T}"/99${PN}
+ COLON_SEPARATED=PERL5LIB
+ PERL5LIB=/usr/share/${PN}
+ EOF
+
+ doenvd "${T}"/99${PN}
+}