summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Mrozowski <reavertm@gentoo.org>2012-11-06 01:04:41 +0000
committerMaciej Mrozowski <reavertm@gentoo.org>2012-11-06 01:04:41 +0000
commit7f30d6c35cb2b6eb0ea9e23619732e017051e1af (patch)
treee9c2cc245130fccd299c35f4511b8921233ae3a7 /dev-util
parentVersion bump for multiple minor bug fixes. Remove old unused versions. (diff)
downloadgentoo-2-7f30d6c35cb2b6eb0ea9e23619732e017051e1af.tar.gz
gentoo-2-7f30d6c35cb2b6eb0ea9e23619732e017051e1af.tar.bz2
gentoo-2-7f30d6c35cb2b6eb0ea9e23619732e017051e1af.zip
Add readline USE flag, fix manpage installation bug 439888 and machine code view bug 439766 (by Simone Scanzoni)
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key B1E955DB)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ddd/ChangeLog9
-rw-r--r--dev-util/ddd/ddd-3.3.12-r3.ebuild91
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch11
-rw-r--r--dev-util/ddd/files/ddd-3.3.12-man.patch16
4 files changed, 126 insertions, 1 deletions
diff --git a/dev-util/ddd/ChangeLog b/dev-util/ddd/ChangeLog
index 9f7c1443abb1..9b6ff5e51190 100644
--- a/dev-util/ddd/ChangeLog
+++ b/dev-util/ddd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/ddd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.67 2012/10/24 19:09:45 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ChangeLog,v 1.68 2012/11/06 01:04:41 reavertm Exp $
+
+*ddd-3.3.12-r3 (06 Nov 2012)
+
+ 06 Nov 2012; Maciej Mrozowski <reavertm@gentoo.org> +ddd-3.3.12-r3.ebuild,
+ +files/ddd-3.3.12-gdb-disassembler-bug.patch, +files/ddd-3.3.12-man.patch:
+ Add readline USE flag, fix manpage installation bug 439888 and machine code
+ view bug 439766 (by Simone Scanzoni)
24 Oct 2012; Ulrich Müller <ulm@gentoo.org> ddd-3.3.12-r1.ebuild,
ddd-3.3.12-r2.ebuild:
diff --git a/dev-util/ddd/ddd-3.3.12-r3.ebuild b/dev-util/ddd/ddd-3.3.12-r3.ebuild
new file mode 100644
index 000000000000..df7e606d2965
--- /dev/null
+++ b/dev-util/ddd/ddd-3.3.12-r3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ddd/ddd-3.3.12-r3.ebuild,v 1.1 2012/11/06 01:04:41 reavertm Exp $
+
+EAPI="4"
+
+inherit autotools-utils eutils
+
+DESCRIPTION="Graphical front-end for command-line debuggers"
+HOMEPAGE="http://www.gnu.org/software/ddd"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3 FDL-1.1"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="+gnuplot readline"
+
+COMMON_DEPEND="
+ sys-devel/gdb
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ >=x11-libs/motif-2.3:0
+ ppc? ( dev-libs/elfutils )
+ ppc64? ( dev-libs/elfutils )
+ readline? ( sys-libs/readline )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-apps/xfontsel
+ gnuplot? ( sci-visualization/gnuplot )
+"
+
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}/${P}-gcc44.patch"
+ "${FILESDIR}/${P}-gdb-disassembler-bug.patch"
+ "${FILESDIR}/${PN}-3.3.12-man.patch"
+)
+
+DOCS=(
+ AUTHORS CREDITS INSTALL NEWS PROBLEMS README TIPS TODO
+ doc/ddd{-paper.ps,.pdf,-themes.pdf}
+)
+
+AUTOTOOLS_AUTORECONF=1
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-termlib=ncurses
+ $(use_with readline)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ # Remove app defaults
+ rm -f "${S}"/ddd/Ddd
+
+ # Install ddd distribution
+ autotools-utils_src_install
+
+ # Install application icon
+ doicon "${S}"/icons/ddd.xpm
+}
+
+pkg_postinst() {
+ if ! use gnuplot; then
+ echo
+ elog "To enable data visualization in DDD, install sci-visualization/gnuplot,"
+ elog "or re-emerge DDD with gnuplot USE flag (recommended)."
+ elog "For flat file package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' >> /etc/portage/package.use && emerge -va gnuplot"
+ elog "For directory package.use layout:"
+ elog " echo '${CATEGORY}/${PN} gnuplot' > /etc/portage/package.use/ddd && emerge -va gnuplot"
+ fi
+ echo
+ elog "To be able to debug java, bash, perl or python scripts within DDD, install respectively:"
+ elog " virtual/jdk"
+ elog " app-shells/bashdb"
+ elog " dev-lang/perl"
+ elog " dev-python/pydb"
+ echo
+}
diff --git a/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch b/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
new file mode 100644
index 000000000000..738cda5946f9
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-gdb-disassembler-bug.patch
@@ -0,0 +1,11 @@
+--- a/ddd/GDBAgent.C 2004-09-01 20:07:38.000000000 +0200
++++ b/ddd/GDBAgent.C 2010-06-15 14:16:34.000000000 +0200
+@@ -3078,7 +3078,7 @@
+ {
+ string end_( end );
+ normalize_address(end_);
+- cmd += ' ';
++ cmd += ',';
+ cmd += end_;
+ }
+ return cmd;
diff --git a/dev-util/ddd/files/ddd-3.3.12-man.patch b/dev-util/ddd/files/ddd-3.3.12-man.patch
new file mode 100644
index 000000000000..c6a1bc4fba24
--- /dev/null
+++ b/dev-util/ddd/files/ddd-3.3.12-man.patch
@@ -0,0 +1,16 @@
+diff -ruN ddd-3.3.12/ddd/Makefile.am ddd-my/ddd/Makefile.am
+--- ddd-3.3.12/ddd/Makefile.am 2009-02-11 18:25:07.000000000 +0100
++++ ddd-my/ddd/Makefile.am 2012-11-06 01:48:46.363493473 +0100
+@@ -1371,10 +1371,8 @@
+ man_MANS = ddd.1
+
+ # `ddd.man' has 8-bit format, `ddd.1' has 7-bit format
+-ddd.1: ddd.man $(srcdir)/unumlaut.sed
+- -$(SED) -f $(srcdir)/unumlaut.sed ddd.man | $(DELETE_CR) > $@~ \
+- && $(MV) $@~ $@
+-
++ddd.1: ddd.man
++ iconv -f ISO8859-15 -t UTF8 ddd.man > ddd.1
+
+
+ # -----------------------------------------------------------------------------