summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-09-30 10:40:25 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-09-30 10:40:25 +0000
commit80741aad1fbf011f02c631439fcaeb13c25871e6 (patch)
tree11df7132e90d367158713ef31c1cae3c5e5fbab1 /dev-util
parentForgot to mask ezc-UserInput, too. (diff)
downloadgentoo-2-80741aad1fbf011f02c631439fcaeb13c25871e6.tar.gz
gentoo-2-80741aad1fbf011f02c631439fcaeb13c25871e6.tar.bz2
gentoo-2-80741aad1fbf011f02c631439fcaeb13c25871e6.zip
New upstream version.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/files/digest-git-1.4.2.29
-rw-r--r--dev-util/git/git-1.4.2.2.ebuild151
3 files changed, 166 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index a134fd69b33b..00d8180c33f1 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.124 2006/09/27 19:32:23 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.125 2006/09/30 10:40:25 ferdy Exp $
+
+*git-1.4.2.2 (30 Sep 2006)
+
+ 30 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> +git-1.4.2.2.ebuild:
+ New upstream version.
27 Sep 2006; Fernando J. Pereda <ferdy@gentoo.org> -git-1.4.2.ebuild:
Remove git-1.4.2 since it has a buggy builtin-mv command.
diff --git a/dev-util/git/files/digest-git-1.4.2.2 b/dev-util/git/files/digest-git-1.4.2.2
new file mode 100644
index 000000000000..0b549c14cec4
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.4.2.2
@@ -0,0 +1,9 @@
+MD5 9c8577e2e43fa08d68590928a4112547 git-1.4.2.2.tar.bz2 787691
+RMD160 1073f390d8c25e25ce363b291059f5931fef42d9 git-1.4.2.2.tar.bz2 787691
+SHA256 0782e151821172addbfbd29a1f540acac8c9d8e2ac4018ae771ccdd4a51c6d6f git-1.4.2.2.tar.bz2 787691
+MD5 a5e26352c5fce9e00d8385e480112070 git-htmldocs-1.4.2.2.tar.bz2 283914
+RMD160 a8ad7bead64dedfdafeda355dd1857bbcfb99144 git-htmldocs-1.4.2.2.tar.bz2 283914
+SHA256 e3e9d111f1d3ce2b7cdef922bbfdb67fd826c20e425867b201fb320164487cbe git-htmldocs-1.4.2.2.tar.bz2 283914
+MD5 62fb1a7aa0441e34facceb92d36046b8 git-manpages-1.4.2.2.tar.bz2 90428
+RMD160 c5e27d6055601a9564c5d9ac2c3f8ecaa7f41fed git-manpages-1.4.2.2.tar.bz2 90428
+SHA256 a1fb59e32fb4c79457435be979ca2ed9f93fedfee1c32014b307ec386776bf03 git-manpages-1.4.2.2.tar.bz2 90428
diff --git a/dev-util/git/git-1.4.2.2.ebuild b/dev-util/git/git-1.4.2.2.ebuild
new file mode 100644
index 000000000000..f86fdc94640f
--- /dev/null
+++ b/dev-util/git/git-1.4.2.2.ebuild
@@ -0,0 +1,151 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.4.2.2.ebuild,v 1.1 2006/09/30 10:40:25 ferdy Exp $
+
+inherit python toolchain-funcs eutils elisp-common
+
+DOC_VER=${PV}
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="mirror://kernel/software/scm/git/${P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk mozsha1 ppcsha1 tk webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tk? ( dev-lang/tk )
+ gtk? ( >=dev-python/pygtk-2.6 )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ use elibc_uclibc && myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/gitk
+
+ doman "${WORKDIR}"/man?/*
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ dodoc Documentation/technical/*
+ dodir /usr/share/doc/${PF}/html
+ cp -r "${WORKDIR}"/{*.html,howto} "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ if use emacs ; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/{,vc-}git.el*
+ elisp-site-file-install "${FILESDIR}"/70git-gentoo.el
+ fi
+
+ if use gtk ; then
+ dobin contrib/gitview/gitview
+ use doc && dodoc contrib/gitview/gitview.txt
+ fi
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+}
+
+src_test() {
+ cd "${S}"
+
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before."
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before."
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before."
+ einfo
+ einfo "If you want to manage subversion repositories using git, consider"
+ einfo "using git-svn. You should install dev-util/subversion and dev-perl/libwww-perl."
+ einfo
+ einfo "If you want to import a quilt series into git, consider using the"
+ einfo "git-quiltimport command. You should install dev-util/quilt before."
+ einfo
+ einfo "If you want to use the included CVS server you will need to install"
+ einfo "dev-perl/DBI and dev-perl/DBD-SQLite."
+ einfo
+}
+
+pkg_postrm() {
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}