summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2013-11-30 13:55:10 +0000
committerJohannes Huber <johu@gentoo.org>2013-11-30 13:55:10 +0000
commit85a20f522cde51f5d115267cb749294c8bcd7094 (patch)
treed9eac4b65d8cff1001d13adf74a13938e193e98e /dev-util
parentamd64 stable, bug #492256 (diff)
downloadgentoo-2-85a20f522cde51f5d115267cb749294c8bcd7094.tar.gz
gentoo-2-85a20f522cde51f5d115267cb749294c8bcd7094.tar.bz2
gentoo-2-85a20f522cde51f5d115267cb749294c8bcd7094.zip
Add upstream patch to fix linking while bootstrap on hppa fixes bug #473276.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key F3CFD2BD)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cmake/ChangeLog6
-rw-r--r--dev-util/cmake/cmake-2.8.11.2.ebuild3
-rw-r--r--dev-util/cmake/files/cmake-2.8.11.2-hppa-bootstrap.patch35
3 files changed, 42 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 20d8cf16e0bc..e8cfc6ed552d 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.261 2013/11/13 18:26:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.262 2013/11/30 13:55:10 johu Exp $
+
+ 30 Nov 2013; Johannes Huber <johu@gentoo.org>
+ +files/cmake-2.8.11.2-hppa-bootstrap.patch, cmake-2.8.11.2.ebuild:
+ Add upstream patch to fix linking while bootstrap on hppa fixes bug #473276.
*cmake-2.8.12.1-r1 (13 Nov 2013)
diff --git a/dev-util/cmake/cmake-2.8.11.2.ebuild b/dev-util/cmake/cmake-2.8.11.2.ebuild
index 053dc85d9358..775e3880afe5 100644
--- a/dev-util/cmake/cmake-2.8.11.2.ebuild
+++ b/dev-util/cmake/cmake-2.8.11.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.11.2.ebuild,v 1.3 2013/10/28 22:16:05 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.11.2.ebuild,v 1.4 2013/11/30 13:55:10 johu Exp $
EAPI=5
@@ -71,6 +71,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-2.8.11-FindBoost-python.patch
"${FILESDIR}"/${PN}-2.8.11-FindImageMagick.patch
"${FILESDIR}"/${PN}-2.8.11-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.11.2-hppa-bootstrap.patch
)
cmake_src_bootstrap() {
diff --git a/dev-util/cmake/files/cmake-2.8.11.2-hppa-bootstrap.patch b/dev-util/cmake/files/cmake-2.8.11.2-hppa-bootstrap.patch
new file mode 100644
index 000000000000..07d648e6ea8b
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.11.2-hppa-bootstrap.patch
@@ -0,0 +1,35 @@
+From: Rolf Eike Beer <eike@sf-mail.de>
+Date: Thu, 12 Sep 2013 18:59:11 +0000 (+0200)
+Subject: bootstrap: try better workaround for builds on Linux/HPPA
+X-Git-Tag: v2.8.12~21^2
+X-Git-Url: http://cmake.org/gitweb?p=cmake.git;a=commitdiff_plain;h=ca63bb1001dea6929e194ac15921fdeb7d434dcd
+
+bootstrap: try better workaround for builds on Linux/HPPA
+
+The workaround currently present works fine without -O or with -O1, but fails
+with -Os or -O2 and higher. Using -O2 is common e.g. in Gentoo, as resulting in
+bugs like this:
+
+https://bugs.gentoo.org/473276
+
+Prevent the workaround for higher optimization levels to make bootstrapping
+more likely to succeed.
+
+This is still a workaround as ld still keeps crashing in some situations.
+---
+
+diff --git a/bootstrap b/bootstrap
+index fb4a0a0..9784d5d 100755
+--- a/bootstrap
++++ b/bootstrap
+@@ -692,7 +692,10 @@ if ${cmake_system_linux}; then
+ # avoid binutils problem with large binaries, e.g. when building CMake in debug mode
+ # See http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50230
+ if ${cmake_machine_parisc}; then
+- cmake_ld_flags="${LDFLAGS} -Wl,--unique=.text.*"
++ # if -O[s23] is given the effect is inverted, so do not use the flag then
++ if [ "`echo "${CXXFLAGS}" | sed -r '/^(.* )?(-O[s234])( .*)?$/s/.*/-Os/'`" != "-Os" ]; then
++ cmake_ld_flags="${LDFLAGS} -Wl,--unique=.text.*"
++ fi
+ fi
+ fi \ No newline at end of file