summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2007-08-08 19:07:13 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2007-08-08 19:07:13 +0000
commit93c0dfc75e42584fdaa93e884b681876b45b4c27 (patch)
tree2e07512153d2e9ecf5336049edaef7362a584b4b /dev-util
parentcomment out march patch. (diff)
downloadgentoo-2-93c0dfc75e42584fdaa93e884b681876b45b4c27.tar.gz
gentoo-2-93c0dfc75e42584fdaa93e884b681876b45b4c27.tar.bz2
gentoo-2-93c0dfc75e42584fdaa93e884b681876b45b4c27.zip
Fix bug #188079. Fix broken sed to pass the assembler its flags.
(Portage version: 2.1.3.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/darcs/ChangeLog7
-rw-r--r--dev-util/darcs/darcs-1.0.9.ebuild8
2 files changed, 10 insertions, 5 deletions
diff --git a/dev-util/darcs/ChangeLog b/dev-util/darcs/ChangeLog
index c54ac3ee2dc4..e25f37484d9d 100644
--- a/dev-util/darcs/ChangeLog
+++ b/dev-util/darcs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/darcs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.74 2007/08/07 17:04:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.75 2007/08/08 19:07:13 kolmodin Exp $
+
+ 08 Aug 2007; Lennart Kolmodin <kolmodin@gentoo.org> darcs-1.0.9.ebuild:
+ Change virtual/ghc dependency into dev-lang/ghc to fix bug #188079.
+ Also correct a sed to correctly send the user's custom CFLAGS to the
+ assembler.
07 Aug 2007; Markus Rothe <corsair@gentoo.org> darcs-1.0.9.ebuild:
Stable on ppc64; bug #186845
diff --git a/dev-util/darcs/darcs-1.0.9.ebuild b/dev-util/darcs/darcs-1.0.9.ebuild
index cbc7a9e2695f..684c43041c83 100644
--- a/dev-util/darcs/darcs-1.0.9.ebuild
+++ b/dev-util/darcs/darcs-1.0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.9.ebuild,v 1.4 2007/08/07 17:04:33 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.9.ebuild,v 1.5 2007/08/08 19:07:13 kolmodin Exp $
inherit base autotools eutils
@@ -16,7 +16,7 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc"
DEPEND=">=net-misc/curl-7.10.2
- >=virtual/ghc-6.2.2
+ >=dev-lang/ghc-6.2.2
dev-haskell/quickcheck
dev-haskell/mtl
dev-haskell/html
@@ -38,8 +38,8 @@ src_unpack() {
# If we're going to use the CFLAGS with GHC's -optc flag then we'd better
# use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
- sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
- ${S}/autoconf.mk.in
+ sed -i 's:\($(addprefix -optc,$(CFLAGS) $(CPPFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
+ "${S}/autoconf.mk.in"
# On ia64 we need to tone down the level of inlining so we don't break some
# of the low level ghc/gcc interaction gubbins.